ATI AIW RV200 7500 Radeon

I’ve been trying to get an older ATI grx card working with TV out. But according to the page (URL below) this card[size=2]’[size=2]s TV function isn’t supported any longer? I have had [size=2]this card working under Debian W[size=2]hee[size=2]zy, but thought I would give 12.3 a shot. Disabl[size=2]ing KMS usually [size=2]works.[/size][/size][/size][/size][/size][/size]

[/size]Some info about my gfx card and box

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV200 QW [Radeon 7500]

uname -a
Linux 3.7.10-1.1-default #1 SMP Thu Feb 28 15:06:29 UTC 2013 (82d3f21) i686 athlon i386 GNU/Linux

I’ve followed [size=2]the instructions here[size=2] without success.
[/size][/size]SDB:Radeon - openSUSE

This page indicates the card is supported
HCL:AMD video cards - openSUSE ](]([size=2]This page states that TV out is and then isn’t supp[size=2]orted[/size]
Driver for ATI/AMD Radeon from 7000 to HD 5890 series
radeon is an Xorg driver for ATI RADEON-based video cards with the following features:

  • Full support for 8-, 15-, 16- and 24-bit pixel depths;
  • RandR 1.2 and RandR 1.3 support;
  • TV-out support (only on RV/RS1xx, RV/RS2xx, R/RV/RS3xx. Experimental support on R/RV5xx, R/RV6xx, and R/RV7xx through the ATOMTvOut option); TV-out is not supported on cards that use the Rage Theatre chip for TV-out (R100, R200).
  • Full EXA 2D acceleration;
  • Full XAA 2D acceleration (only on R/RV/RS1xx, R/RV/RS2xx, R/RV/RS3xx, R/RV/RS4xx, R/RV5xx, RS6xx. XAA Render acceleration supported only on R/RV100, R/RV/RS2xx and RS3xx);
  • Textured XVideo acceleration including anti-tearing support (Bicubic filtering only available on R/RV3xx, R/RV/RS4xx, R/RV5xx, and RS6xx/RS740);
  • Overlay XVideo acceleration (only on R/RV/RS1xx, R/RV/RS2xx, R/RV/RS3xx, R/RV/RS4xx);
  • 3D acceleration;

Xawtv run from terminal

> xawtv
This is xawtv-3.102, running on Linux/i686 (3.7.10-1.1-default)
xinerama 0: 1280x1024+0+0
vid-open-auto: failed to open a capture device
vid-open: could not find a suitable videodev
no video grabber device available

xvinfo output

> xvinfo
X-Video Extension version 2.2
screen #0
  Adaptor #0: "Radeon Textured Video"
    number of ports: 16
    port base: 63
    operations supported: PutImage 
    supported visuals:
      depth 24, visualID 0x21
    number of attributes: 2
      "XV_VSYNC" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
      "XV_CRTC" (range -1 to 1)
              client settable attribute
              client gettable attribute (current value is -1)
    maximum XvImage size: 2048 x 2048
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)

Any[size=2] help would be appreciated[size=2].



I don’t understand that statement you made. Note the RV200 is not the same as the R200.

Can you confirm, by looking at the /var/log/Xorg.0.log file, if the radeon driver is actually loading ? (and that you are not using a vesa or fb driver). My knowledge is not good enough to answer that by looking at what you posted.

Thanks for responding.

What I’ve found in past web searches is that the RV200 is based on the R100 chipset. But in my case, I don’t think my card uses Rage Theater. That’s just a guess though since I haven’t come across any docs that states that it is.

From the two dmesg’s (grep radeon and grep fb), it looks like VESA is removed, but there remains a conflict between radeon and fb as X is loading.

> dmesg |grep radeon
    3.348258] [drm] radeon defaulting to kernel modesetting.
    3.348267] [drm] radeon kernel modesetting enabled.
    3.348377] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
    3.392163] radeon 0000:01:00.0: putting AGP V2 device into 4x mode
    3.392168] radeon 0000:01:00.0: GTT: 64M 0xE0000000 - 0xE3FFFFFF
    3.392178] radeon 0000:01:00.0: VRAM: 128M 0x00000000D0000000 - 0x00000000D7FFFFFF (64M used)
    3.392242] [drm] radeon: irq initialized.
    3.395673] [drm] radeon: 64M of VRAM memory ready
    3.395677] [drm] radeon: 64M of GTT memory ready.
    3.397011] radeon 0000:01:00.0: WB disabled
    3.397029] radeon 0000:01:00.0: fence driver on ring 0 use gpu addr 0x00000000e0000000 and cpu addr 0xf8022000
    3.397611] [drm] radeon: ring at 0x00000000E0001000
    3.731604] fbcon: radeondrmfb (fb0) is primary device
    3.809743] fb0: radeondrmfb frame buffer device
    3.809758] [drm] Initialized radeon 2.24.0 20080528 for 0000:01:00.0 on minor 0

> dmesg |grep fb
    0.000000] BIOS-e820: [mem 0x000000000009f800-0x000000000009fbff] reserved
    0.081578] pci 0000:00:10.4: reg 10: [mem 0xdfffbe00-0xdfffbeff]
    0.081922] pci 0000:00:12.0: reg 14: [mem 0xdfffbd00-0xdfffbdff]
    1.064361] vesafb: mode is 1280x1024x32, linelength=5120, pages=0
    1.064364] vesafb: scrolling: redraw
    1.064369] vesafb: Truecolor: size=0:8:8:8, shift=0:16:8:0
    1.064758] vesafb: framebuffer at 0xd0000000, mapped to 0xf8080000, using 5120k, total 5120k
    1.204676] fb0: VESA VGA frame buffer device
    3.348377] fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver
    3.457862] [drm] fb mappable at 0xD0040000
    3.457870] [drm] fb depth is 24
    3.491165] ehci_hcd 0000:00:10.4: irq 21, io mem 0xdfffbe00
    3.731604] fbcon: radeondrmfb (fb0) is primary device
    3.809743] fb0: radeondrmfb frame buffer device
   15.766978] via-rhine 0000:00:12.0 eth0: VIA Rhine II at 0xdfffbd00, 00:13:8f:10:21:e9, IRQ 23

Xorg.0.log (grep radeon)

> cat Xorg.0.log-normal |grep radeon
    53.685] (II) LoadModule: "radeon"
    53.691] (II) Loading /usr/lib/xorg/modules/drivers/
    53.694] (II) Module radeon: vendor="X.Org Foundation"
    53.974] (II) RADEON(0): [DRI2]   DRI driver: radeon
    53.974] (II) RADEON(0): [DRI2]   VDPAU driver: radeon
    54.295] (II) AIGLX: Loaded and initialized radeon

Xorg.0.log (grep fb)

> cat Xorg.0.log-normal |grep fb
    "Default Screen Section" for depth/fbbpp 24/32
    53.952] (II) Loading sub module "fb"
    53.952] (II) LoadModule: "fb"
    53.958] (II) Loading /usr/lib/xorg/modules/
    53.974] (II) Module fb: vendor="X.Org Foundation"

So I’m assuming that I need to blacklist the fb module?

This suggests to me that the radeon driver is loaded. … But there could be other useful information in that log file, so rather than you feed us a small amount wrt what you think is needed, I think it may be more helpful if you copied the entire /var/log/Xorg.0.log file and pasted it to a pastebin site (such as SUSE Paste ) , press ‘create’ and then post here the URL where paste is located.

I don’t think that the case.

In addition to pasting the Xorg.0.log to a location where the entire file can be examined, could you also advise if you have v4l and/or v4l2 installed ? ie provide the output of :

rpm -qa '*v4l*'

Thanks and good luck

Thanks for pointing where attachments are posted for this forum. I posted excerpts of the log because I wasn’t able to attach the text file and didn’t think it would be appreciated if I broke it into sections.

Hi Oldcpu,
Per your request:
My Xorg.0.log is here:
SUSE Paste


> rpm -qa '*v4l*'


I last played with TV card in year 2007 (or early 2008) or so, … hence I am very out of date here. My understanding is xf86-video-v4l provides the driver, and you have that installed. v4l-conf provides tools to configure xawtv and you have that installed. So at first those looked ok. Then I looked at the version # of those. I noted they were older than what I have, and I assume that is because you are using openSUSE-12.3 and I am using openSUSE-13.1. Two other v4l apps that might be useful (but don’t explain the problem for me, are v4l-utils and v4l-utils) and likely neither is needed for what you are attempting.

I also asked myself, where did you get the ‘xawtv’ program from ? I don’t recall it being packaged for openSUSE-12.3. Did you build this yourself ? Have you tried a program other than xawtv to access your TV with your RV200?

Then, independant of that question, I made an assumption that the xawtv program is ok (and it may not be) I then looked at the /etc/X11/xorg.0.log and did not see anything striking. I noted this at the end:

 19451.290] xf86CheckModeForDriver: called with invalid scrnInfoRec
 19456.218] xf86CheckModeForDriver: called with invalid scrnInfoRec

and I assume those errors are associated when you tried to run xawtv and the driver could not be found by xawtv. Its hard to decipher such messages, but it seems to say when x86 checks for the driver, it notes it is being called with invalid screen information ? Could that be the xawtv program at fault ? Could it be the driver at fault ? I don’t know.

I then went to look for what the /etc/X11/xorg.0.log stated about screen information and long after the boot, I noted this:

    53.787] (II) RADEON(0): Monitor name: HP L1710
    53.787] (II) RADEON(0): Serial No: 3CQ907123F
    53.787] (II) RADEON(0): EDID (in hex):

which appears fine.

But then several minutes later I see this:

  9008.132] (II) RADEON(0): EDID vendor "HWP", prod id 9963
  9008.132] (II) RADEON(0): Using EDID range info for horizontal sync
  9008.132] (II) RADEON(0): Using EDID range info for vertical refresh
  9008.132] (II) RADEON(0): Printing DDC gathered Modelines:

indicating another monitor (?) device being connected. Can you explain that ? Did you transfer something else at that time to your PC other than the TV ? Or is this the connecting of your TV ?

I also note from the /etc/X11/xorg.conf.0 the entries:

    53.684] (--) RADEON(0): Chipset: "ATI Radeon 7500 QW (AGP/PCI)" (ChipID = 0x5157)
    53.684] (II) Loading sub module "dri2"
    53.684] (II) LoadModule: "dri2"
    53.685] (II) Module "dri2" already built-in
    53.820] (II) RADEON(0): [DRI2] Setup complete
    53.820] (II) RADEON(0): [DRI2]   DRI driver: radeon
    53.820] (II) RADEON(0): [DRI2]   VDPAU driver: radeon
    53.965] (II) GLX: Initialized DRI2 GL provider for screen 0

and I recall years back some users dri had difficult with radeon tv drivers (back in 2006 - illustrating how long its been since I looked at this) : v4l and dri - Mandriva Linux

I don’t know if now adays it is even possible to disable dri (as a test) to try. Possibly disabling acceleration ? ie an edit to the configuration file /etc/X11/xorg.conf.d/50-device.conf that would look something like this:

Section "Device"
  Identifier "Default Device"
  Driver "radeon"
#  ## Required magic for radeon/radeonhd drivers; output name
#  ## (here: "DVI-0") can be figured out via 'xrandr -q'
Option "NoAccel" "True"
#  #Option "monitor-DVI-0" "Default Monitor"

reboot and see if that works with your TV card. Note this is wild speculation, and I am hoping that someone more knowledgeable and more current steps in and provides less speculative and more helpful suggestions.

Its also possible you don’t have all the needed v4l packages, but if so that exceeds my knowledge to assess.

  • By the reads of it, you are confused by the terminology. Lets get that straight, as TV-out is different from A/V-in
  • TV-out is for outputting from the device an analogue video signal. Typically composite or s-video, and, in the rare case, component. Such functionality isn’t all that useful for most people any more. IOW, its a legacy throw back, as modern TV display devices will typically accept a myrid of high definition connections
  • A/V-input allows you to bring external video sources such as composite, s-video and analogue TV signals into the system. This is the functionality that you’re seeking after
  • I have not checked that actual source code, but I’m fairly confident that the TV-in functionality in the xorg radeon driver was tied into UMS code paths, and never existed for KMS … UMS is quickly going the way of the dodo in favour of KMS … UMS was stripped out of newer (v7.0 and greater) xorg radeon driver versions … version 6.14.6 was the last UMS capable radeon driver release … on the kernel side, UMS support is still available (for now), but you’d have to specifically build it with such, cause it now (since kernel 3.9) default builds to only work via KMS
  • so, yes, you can still get the tv-in support to work, but you’d have to get an older radeon xorg driver and then make sure your radeon drm kernel driver was built with UMS support, and then use UMS.
  • again, take note that this is in regard to TV-out functionality … which as indicated does not at all appear to be what you’re after (i.e. you just appear to be trying to get the TV tuner working)
  • also, the documentation is only applicable for older xorg radeon driver versions
  • lastly, the info is not conflicting (i.e. what is written appears correct (it should as it looks like its just a copy and paste from the old “man radeon”) … different chipsets and/or devices supported TV-out, while others did not).

Just as an FYI, it could be ascertained that it was loaded correctly from the xvinfo output that was provided … “Radeon Textured Video” … which is the xorg radeon’s, post overlay, method of providing Xv functionality

  • No, your device DOES use the Rage Theater chip … the RT200 is an A/V decoder that is necessary for providing A/V-input capabilities
  • xorg provides a theater driver in 6.14.6 and older versions of the xorg radeon driver, but it is absent with 7.0 and > … an interesting quirk here is that (for example, with my openSUSE 13.1 install) drivers for some of the other chipsets that combine to provide the A/V-in capabilities on those old radeon AIW cards are still provided (see /usr/lib64/xorg/modules/multimedia/ ) … though they may be included for other such devices that utilize the same

No … dmesg is displaying messages about the kernel drivers

  • radeon drm kernel driver is a different beast then radeon xorg driver
  • vesafb kernel framebuffer driver is a different beast then the vesa xorg driver
  • the loading of vesafb and then removal of it in favour of radeondrmfb (the framebuffer driver that is embedded in the radeon drm/KMS driver) is normal behaviour when using KMS … this (a) happens well before the X server is started (i.e. look at the time stamp → 3 seconds into booting the kernel) and (b) has nothing to do with the X server, but everything to do with the console framebuffer environment.

No. Don’t do anything.

No. That is an old antiquated X driver (I described it on the linuxtv wiki if you’re interested: Xf86-video-v4l - LinuxTVWiki) … its not useful.

Yes, the A/V-in (TV tuner) is primarily what function I’m after. However this card does have TV-out and if I can get that to work, great ; if not, no biggie.

This is the bottom line I need, thank you. Tyler & Oldcpu, I appreciate both of your input.

No I didn’t build it, I installed it with zypper from one of the 12.3 official repos. The only other TV package that I have been able to use is zapping, which is not in the 12.3 repos.

Thats strange … when I do a search for it on 12.3 this is what I get :](

it it is clearly not listed for 12.3 in that search. Neither do I see it under Index of /distribution/12.3/repo/oss. I searched on Packman and did not find it. So where does one find the rpm for 12.3 ?

This is all possible a mute point if the version of X that you have does not support what you intend to do, but in all honestly its not clear to me that xawtv came from an official 12.3 repository. I can’t see what I am missing.

No I can’t explain. Nothing was added or changed. Only one monitor is connected, nothing connected to S-vid out, so I’m not sure would have caused the change.

This was a fresh install off a KDE Live DVD. At the time I installed Xawtv, I had not added any repos so the only repos that zypper had access to what comes with a new install. I don’t know where else it would have come from.

Now that I think about it, I didn’t install if from zypper. I installed it from the software mgr in YaST. Not that that matters since they use the same repos.

Edited later
It’s from the 12.3 non-oss repo.

Thankyou for that. That is educational (for me). I did not realize that xawtv was not a GPL licensed application.

It is surprising to me that the search engine for 12.3 does not show up the xawtv non-oss app, but it does show up for 12.2 and 13.1.

Agreed. I had to look twice to make sure I was seeing in as being from the NOSS repo.

I am still puzzled as to what this may be. When trying to surf on the 'EDID vendor “HWP”, Prod id 9963" I found your debian support thread Debian User Forums • View topic - need help with Ati Radeon 7500 and TV but found no more. In the debian support thread, the HWP id9963 is identified immediately in the log file. However in the openSUSE log file an HP L1710 is identifed first and only minutes later an HWP Prod id 9963. I suspect there is something there that I could learn, but at the moment it escapes me.

FWIW, I very (read: VERY) briefly chatted with Alex Deucher (AMD OSS dev) and Mauro Chehab (V4L maintainer) about this the other day … Alex indicated that he thought it would likely be pretty easy for a motivated individual to add the code to KMS and to expose the V4L interface … and Mauro, similarly, thought it wouldn’t be too hard for a motivated person to switch those userspace i2c drivers over to kernel space, and I agree given there is definite overlap in some cases. So if you’re motivated enough, by all means have at it … (i.e. the onus would be upon you)

    53.786] (II) RADEON(0): EDID for output DVI-0
    53.786] (II) RADEON(0): Manufacturer: HWP  Model: 26eb  Serial#: 16843009
    53.787] (II) RADEON(0): Monitor name: HP L1710
    53.787] (II) RADEON(0): Serial No: 3CQ907123F
    53.787] (II) RADEON(0): EDID (in hex):
    53.787] (II) RADEON(0):    00ffffffffffff0022f0eb2601010101
    53.787] (II) RADEON(0):    0713010368221b8ceedc55a359489e24
    53.787] (II) RADEON(0):    115054adef8081800101010101010101
    53.787] (II) RADEON(0):    010101010101302a009851002a403070
    53.787] (II) RADEON(0):    1300540e1100001e000000fd00324d18
    53.787] (II) RADEON(0):    530e000a202020202020000000fc0048
    53.787] (II) RADEON(0):    50204c313731300a20202020000000ff
    53.787] (II) RADEON(0):    00334351393037313233460a202000fc

    53.811] (II) RADEON(0): EDID for output S-video
    53.811] (II) RADEON(0): Output DVI-0 connected
    53.811] (II) RADEON(0): Output S-video disconnected

  9008.132] (II) RADEON(0): EDID vendor "HWP", prod id 9963
  9008.483] (II) RADEON(0): EDID vendor "HWP", prod id 9963
  9008.548] (II) RADEON(0): EDID vendor "HWP", prod id 9963

As seen in the output above, it shows to be working (albeit you’d have to connect it something to confirm that its actually working properly)

Model: 26eb (hex) = prod id 9963 (dec)

I’m motivated and this would be a good way to learn more. This would be a challenge, but I think I can figure it out with the above info (given enough time, ha).

The first question that comes to mind is how would an older kernel and X effect release 12 or 13 of OpenSUSE?

Thanks again Tyler.