ATI 9800 R350 NH 11.3


Is it true that there is no other driver for this card under SuSE 11.3 other than the “radeon” that came with the distro?

I had this card running under 11.2 with an ATI prop driver and it ran really well. It now shows between 6 and 700 FPS (glxgears) but I think it was a good deal quicker under 11.2.


When I type “man radeonhd” I see no reference of support for the ATI 9800 R350. That card is deemed a ‘legacy’ card by ATI so they refuse to support that card now for Linux. I do see the card listed when I type “man radeon” suggesting the radeon driver supports the card. In addition to the radeon driver, there is also the VESA and FBDEV drivers that should work with that card, but their performance will be SIGNIFICANTLY worse than the radeon driver.

The radeon driver implementation in openSUSE-11.3 while mostly superior to that in 11.2 (with some exceptions, where your card is possibly one) is still not as good IMHO as the radeon driver implementations in the latest Fedora nor Ubuntu, where both of those distributions have applied fixes to either the kernel, mesa, radeon driver (or some other app) that has not yet made its way upstream, and hence not made it way down stream for other distributions to share, and thus openSUSE still does not have the same radeon driver performance.

In the case of my wife’s Radeon ATI 9200 PRO, I had to do an edit to the 50-device.conf file to get slightly better performance, and even then it is not as good as I saw in openSUSE-11.1 (11.2 performance in my wife’s PC case was actually worse than it in 11.3). I posted here about this in post#17 in this linked thread.

Hm … I had thought the proprietary driver support from ATI stopped BEFORE 11.2 for that card. Do you mean 11.1 ? (I confess my memory is fuzzy on this).

Hello oldcpu and thanks for the input.

Since posting, I had some very weird things happening with 11.3. For instance, whenever I had to give the root password to the update applet, yast etc, it always failed.

I eventually brought back the backed-up image of the 11.2-based system and will have to stick with taht ibn the meantime. When I ran glxgears, I get FPS over 300 with the OOB Radeon driver.

Cheers - AK

Hi oldcpu,

I went over your brilliant post at “…” and followed the steps through.

I had all the basics albeit that I couldn’t manage to trigger Mesa 7.7 to replace the Mesa 7.6 that I have.

So now I’m getting an average 42-4300 FPS (a 1000 increase from before I followed your steps) out of this card with the radeon driver from xorg. This is very adequate for my use of video etc. So thanks for the post.

Cheers - AK.

Hello Oldcpu

I to have a laptop a acer aspire 5102 WLMI turion X2 1gb mem and ati radeon Xpress 1100
installed 11.3 and only the radeon driver for the aticard Hell NO
Installed kernel after that the ati driver :wink:
installed xorg.conf (patched xorg.conf from nvidia machine)
And a whopping 1280x800 resolutioon
Also installed madwifi-0.9.4-current.tar.gz drivers for the Atheros wifi card
Now the laptop runs like sunshine with opengl so Nezius Sauerbraten run on it with nearly 330Fps

11.3 runs without problems on this kernel

SDB:Radeon - openSUSE is a brilliant page/guide, but I can not take credit for it. Someone else put it together.

What worked for me (with openSUSE-11.3) on my wife’s PC was to apply this to the /etc/X11/xorg.conf.d/50-device.conf file:

Section "Device"
  Identifier "Default Device"

  Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  #oldcpu added following 2 lines
  Option "BusType" "PCI"
  Option "AGPSize" "64"


where her hardware is an ATI 9200 PRO (RV280). I documented that effort in post #17 here: Suse 11.3: No KDE/X11 start on ATI Radeon RV280 5960

Its great to read you managed an improvement. What sort of xorg.conf (or 50-device.conf) file did you end up creating ?

Interesting that you could roll back openSUSE-11.3’s 2.6.34 kernel to an older kernel and get things to work !! Well done.

Is this a custom kernel build of your own? Or are you using someone else’s kernel build ?

Interesting that you could roll back openSUSE-11.3’s 2.6.34 kernel to an older kernel and get things to work !! Well done.

Is this a custom kernel build of your own? Or are you using someone else’s kernel build ?

Oldcpu this kernel came from Index of /distribution/11.0/repo/oss/suse/x86_64

now with the kernel but that will do or 11.1 with kernel

download them both and try them out


ps kernel was one of the early kernel for 11.2

Ok, thanks.

Am I correct that as an update, you have decided the works better for you on 11.3 (with the ATI hardware) than the in your initial post?

I confess to being suprised (but happy for you) that an 11.0 kernel will work with 11.3.

Oldcpu you have to have a xorg.conf to use with the older kernels

When 11.1 was out there was the beginning off 11.2 first with the same kernel as 11.1 later the and later again the 2.6.31 kernel 11.2 has as stock

I got the kernel at that time and burnd it to a cd with the xorg conf with the mouse and keybord parts in it

The xorg i even use in 11.3 (mouse and keyboard are comments now)

You have to install that kernel by hand with rpm --force --nodeps -Uvh *.rpm in the directory where that kernel is
and clean /boot for 2.6.3x entrys
same for /lib/modules

So i have kernel on 11.3 with xorg 1.9.0 in the big machine pinched just before 11.4 was upgraded to the 2.6.36 kernel that wont work do severe error in ext4 solved by now but not interested

This and xorg.conf as i use are olso burned on a cd for use in 11.4 if there might be trouble

So i have the Madwifi drivers for Atheros chipset in my laptop wich compile on a 2.6.3x kernel
as ATH5 give disconects
And the ati drivers for a Xpress 1100 card

Thats my backup and box with goodies