ATI 4850 not working with fglrx driver

Well I just upgraded from 10.3 now to 11 and at first I had an old x1900gt which worked fine, I got a 4850 in the machine now and reinstalled suse 11 but now the fglrx driver seems broken, it fails every time. I’m back on the default vesa driver until someone can help me out.

P.S. I tried the one click install and the old manual instal and neither works. Or am I jumping the gun and the 4850 support is still coming?

The 4850 is only supported by the 8.6 (8.503) and newer driver. What is in Opensuse is the 8.5 (8.493) version. You can download the 8.6 from amd’s website and generate a package from that. But everytime the kernel gets updated you will need to reinstall the fglrx module.


Well Jeff, your right about the driver verion but 2 other things to note.

I did download the newer ati driver and it failed to, then I noticed that there was a kernel update, updated and double checked that I had all the 32 bit packages also installed. I rebooted and prepared the kernel, made sure to remove the older 8.493 driver and custom installed the newer driver as there is no suse 11 option and the 10.3 auto install did not work either. after I restarted X I needed to run sax2 -r -m 0=fglrx and it still said Vesa driver but it had the 3d option enabled and defaulted to the LCd’s native resolution. fglrxinfo said it was the newer 8.5xx driver and double checked the online update, part of the problem was that the older 8.5 catalyst ( 8.493 driver ) is whats in the suse11 dir on ati’s site and in the suse repo’s not the newer one so one click install and the online update was downgrading me to the older driver ( I should pay more attention to driver versions from now on ). I’m not sure also if the kernel update helped or if it was just the driver version but I hope this info helps anyone with the newer 48xx cards. Basically until the repos have the newer driver in them you have to download and manually install the old way, making sure to prepare the kernel first.