ATI 11.1 repository FINALLY up.

Took them long enough, but the ATI repository is finally up.

Simply go to YaST software management, and click the following

  1. Configuration
    (menubar)]Repositories]]Add (Button)]Community repositories (radio button)]**Next **(Button)]**ATI repository *(List option at the bottom)]Ok]Ok]Accept and you got working ATI drivers after a reboot.

For those that don’t have it under community yet, add as a repository (not browseable via a webbrowser)

Yes, but does the driver actually work? That’s something we have learned not to take for granted with ATI.

worked for me but i still had to remove the 32bit fglrx and symlink and symlink it to the 64bit
with this command
rm /usr/lib/dri/ && ln -s /usr/lib64/dri/ /usr/lib/dri/
to help out users running opensuse 11.1 64bit

Okay took me a while to test… as my server corrupts it’s filesystem pretty much every single boot and the recovery takes like 3 hours.

It installed fine and I could boot into the GUI… checked YaST monitor/graphics card, hardware acceleration grayed out.

So started up a console.

  1. su
    to gain root privileges*]init 3*]cp /etc/X11/xorg.conf xarg.conf (never hurts to have backup)]sax2 -r -m 0=fglrx]Change settings / Test changes / Save changes*]init 5
    Went to YaST graphics card/monitor again… hardware acceleration no longer grayed out.
    Started a video in smplayer with video set to “xv”… and it works! Hardware acceleration is a nice thing to have.

So it seems to be fine, at least for an ATI Radeon 3200 (AMD 780G chipset)

Thanks for the update.

But wow, that sounds like a lotta work for a little 3D acceleration. I might just wait for the 8.13 installer to come out on the ATI site.

It’s adding one repository, some ok clicking, then
6 commands, 5 if you don’t make a xorg backup.

  • Some clicking around in sax.

Wouldn’t call it a lot of work.

I couldn’t get desktop effects working after replacing my ATI X300 for an ATI Radeon HD 2600XT so, after seeing this post, I decided to bite the bullet and give the binary-only driver a try. Adding the repositories went fine (and so did the new driver installation after realising that it only recommends the new packages when you go to exit yast).

Rebooted, but it didn’t make a difference, so I tried Axeia’s instructions (by the way, typing “init 3” or “init 5” does nothing for me as root, I have to type “startx” to get back into X).

So, the only other suggestion in this post, from Havoc65, was my last resort (I previously dismissed it thinking to myself "surely I don’t have to go relinking files when the packages I’ve installed are for x86_64, so shouldn’t it know that it needs to put the 64-bit file where it’s supposed to go? wrong!).

After changing the symlink and rebooting, I finally got eyecandy working. Resizing windows was painfully slow (is there a way to adjust this? I couldn’t find a setting), but apart from that, everything else was quite speedy (oh, desktop sphere and cylinder don’t work, either).

Another MAJOR problem I have with this new driver is that logging out of X leaves me at a blank screen. Can’t Ctrl-Alt-F1 to a console, can’t Ctrl-Alt-Backspace to kill X, and I can’t even use the magic sysrq keys to unmount my file systems and do an emergency reboot. This is a showstopper!

I think I’ll put my X300 back in and copy my original xorg.conf back. Linux and 3D still don’t seem to be all it’s cracked up to be, unfortunately. My brother is keen on all things computer-graphics and 3D but I’m yet to convince him that Linux is worth this kind of hassle :frowning:

You might want to give NVIDIA a try instead of ATI, can’t say they’re trying very hard when it takes them THIS long to get a repository up.
Everything working fine with minimal effort on the NVIDIA card, on the ATI I’ve set to set the compositing type to xrender instead of GL… but then again that was just to test, the PC in question just needs hardware acceleration for video’s for me to be satisfied with as it probably speeds up my thumbnail creation script.

I’ve installed the driver from the repository and did the trick for the 64 bit version.
I have an Radeon HD 2400, correctly detected:
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: ATI Radeon HD 2400 XT
OpenGL version string: 2.1.8304 Release

However, OpenGL aplications are not displayed when they are static (and flicker when dynamic). I only see the frame and the background windows.
I’ve checked this with VMD (molecular visualisation) and torcs (the car games).
Any idea on how to solve this?

add the widget turn off compositing
and when you play 3d games just turn the compositing off which should stop the game flicker

Thanks. But can you be more precise on how to add that widget? I only know that composite can be turned off in xorg.conf by:
Section “Extensions”
Option “Composite” “Disable”

But can it be done “dynamically” when you want to play, for example?
BTW, what is ‘composite’?

Short term decision. As a community, we need Intel and ATI to be successful as they are cooperating with FOSS driver development, which is the real solution.

Reverse engineering efforts without docs should not be necessary to support hardware that we buy.

As consumers we need something that works, if A fails you move on to B.

Previous post was a bit more ‘straight to the point’ then I intended it to be. Was supposed to be more of a if A fails and you need it to work, you might want to give B a try.

Does It Work?

I’ve tried all the suggestions in this thread, the HowTo, the Wiki, and most anywhere else to no avail. The 11.1 ATI repo version, ATI downloaded 8.12 Automatic, or 8.12 Custom Generated for 11.1 just don’t get anywhere. I always end up after a sax2 -r -n 0=fglrx with ribbon candy and then an out of frequency signal.

This on multiple installations from working 10.3 to 11.0 to new installs of 11.1

Very frustrating.

Supplemental Info:

ATI Radeon 850 Series
32 bit install
P-4s 3.4 w/2, 3, and 4 gb ram
Attempted with pae & default kernels

Worked fine with 11.0

11.1 64 bit
ati 3450 based card

Installation worked fine but didn’t configure my display correctly. Whenever I try to reconfigure using sax the machine hangs and I have to do a reboot. I need to look into it more and have been to busy to fix it since it’s only a minor problem with the display.

Dear Havoc65,
Please, can you explain how to ‘add the widget turn off compositing’. I can’t find this widget anywhere.