Atheros Wireless Card Misidentified / openSUSE 11.0

Hello! This would be the first time I post something in the forums. This is my problem:

I have a Compaq Presario F754LA with a Mobile AMD Semprom Processor 3600+ running openSUSE 11.0, and I’ve been trying to use the madwifi driver to enable the wireless card, unsuccessfully. I have followed every step indicated in this page: (including blacklisting the ath5k kernel module), using this madwifi repository:, but at YaST Network settings still says “Unable to configure the network card because the kernel device (eth0, wlan0) is not present.
This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.”, and I can’t use the wireless card.

Then I noticed that at YaST Control Center->Network devices->Network settings, the wireless card is identified as “AR242x 802.11abg Wireless PCI Express Adapter”, but according to the hp web site and to Windows Vista (also installed on the notebook), the card is an “Atheros AR5007 802.11b/g Wireless”.

I suppose that the madwifi driver doesn’t work due to this misidentification. If so, how do I fix this?

I apologize if I have some writing mistakes, I’m from Venezuela and I only speak some english. In advance, thank you for your help.

Hi alejorro70.

My understanding is that AR242x refers to the chipset series, and AR5007 refers to the model of wireless adapter as identified by the mfr.

In any case, it’s not a misidentification, so you are in good shape!

There are many methods and posts about that chipset here. Many of them didn’t work for me.

Eventually I found this one and it did work:

[Solution]Atheros AR242x - Suse11 - pae kernel - openSUSE Forums](

I suggest you read the entire thread before beginning, as there are some prerequisites and clarifications further down.

This one describes more or less the same process, but he words things a little bit differently:

AR242x wireless working (part 1) - openSUSE Forums

Good luck!


Please find here: HCL/Laptops/Acer - openSUSE my instructions for Aspire 5720z with Atheros 5007G.

lol! thanks converted. I followed the instructions on the first thread you mentioned, and it worked just fine.

Thanks allot!!! lol!

^^ Nice! Isn’t it a relief when it turns out to be easy to fix? :slight_smile:

I thought I had broken it again earlier today. I kept uninstalling and reinstalling madwifi thinking I was doing something wrong. Whoops! I had moved the hardware switch on my laptop, disabling wifi! :open_mouth:

lol! how crazy.

Now I’m gonna try to enable the LEDs of the wireless card. I hope is easy too.

Just for future reference, a couple of current Atheros chipsets are 2417 for 5007G, 2424 FOR 5006EXS, and 2425 for ??? . When installed, V11 1st tried ath5k, then ath_pci, and finally, after it’s running what SUSE calls 5006, so I’m guessing that one is for both / all three chipsets.

Here’s where they list some of their drivers, and the list:

< Atheros Communications >

Driver Downloads

Click a driver below to begin downloading.

AR81Family DOS Driver
AR8121_AR8113_AR8114-combo-pxev1.0.0.12-rplv1.2.7.6.rar 34K
AR8121_AR8113_AR8114-ndis2-ver1.0.0.15.rar 8K
AR8121_AR8113_AR8114-packet-ver1.0.0.14.rar 13K
AR8121_AR8113_AR8114-pxe-v1.0.0.12.rar 24K

AR81Family Linux Driver
AR81Family-linux-v1.0.1.0.tar.gz 77K

AR81Family Novell Driver
AR8121_AR8113_AR8114-odi16-v2.6.1.5.rar 17K
AR8121_AR8113_AR8114-ODI32-v1.5.rar 12K

Atheros AR81Family Windows Driver x86/x64(Vista, XP, Server 2003)
AR81FamilyWinSetup_1.0.0.40_WHQL.rar 2195K

Atheros L1 DOS Driver
l1-ndis2-v1.0.613.15.rar 8K
l1-packet-ver1.2.613.12.rar 13K
L1combo-v1.0.20.15.rar 66K
L1pxe-v1.0.20.15.rar 47K

Atheros L1 Linux Driver
l1-linux-v1.2.40.3.tar.gz 85K

Atheros L1 Novell Driver
L1-ODI16-v2.6.1.5.rar 17K
L1odi32-bin-v1.09.rar 13K

Atheros L1 Windows Driver x86/x64(Vista, XP, Server 2003)
L1WinSetup_v2.4.7.15_WHQL.rar 1807K

Atheros L2 DOS Driver
l2-combo-v1.0.20.20.rar 64K
l2-ndis2-v1_0_613_7.rar 7K
l2-packet-ver1.2.613.9.rar 12K
l2-pxe-v1.0.20.20.rar 46K

Atheros L2 Linux Driver
l2-linux-v1.0.40.4.tar.gz 72K

Atheros L2 Novell Driver
L2-ODI16-v2.6.1.5.rar 17K
L2odi32-bin-v1.09.rar 11K

Atheros L2 Windows Driver x86/x64(Vista, XP, Server 2003)
L2WinSetup_v2.6.7.17_WHQL.rar 1743K

I hope this will help some Atheros users.

Britt Dickson
San Jose