Atheros Otus Driver and D-Link DWA-160

Ok, so I decide to slap OpenSuse on my system, and what should have been an easy switch, turned into a pain in the rawhide.

I’m trying to install the Atheros Otus driver which I acquired from D-Link’s website for my DWA-160 rev.A1 Xtreme N USB wireless NIC.

The provided instructions stated to either click the .rpm file and let Yast do its thing, or bring up the terminal and type

rpm -ivh otusdriver-3.2.0-x.i386.rpm

Where “x” is the driver version (17 in my case).

Instead of installing, making my NIC work, and everyone lives happily ever after, I get this in the terminal:

Preparing… 100%
############################## 100%
1: otusdriver
############################## 100%

Installation of the driver failed in the compile phase

error: %post (otusdriver-3.2.0-17.i386.rpm)scriptlet failed, exit status 255
The error is very similar in Yast, except it uses a few more words.

I’ve verified that all of the packages necessary (and some) are installed.
These include make, autoconf, and gcc (awk and the other thing that goes with it).

I get the same issue with both 32-bit and 64-bit Suse.

I’ve been working at this for three days from morning till night trying to resolve the issue, and getting nowhere.

Any and all help would be immensely appreciated.

To assist anyone trying to help, HERE is my NIC and HERE is the download page for the drivers.

Thank you in advance for any assistance.

Got the kernel sources & kernel sysms installed ? or tried the nodeps command ? a quick scout of man rpm should help you out

Andy

I already had kernel-sources installed, but installing syms ontop didn’t change the outcome.

I’m not familiar with the nodeps command though. In what context do I use it?

something like

 rpm -ihv nodeps name_of_rpm.rpm

Andy

Adding nodeps into the command gave this response:

error: open of nodeps failed: no such file or directory

I tried putting a hyphon infront to make it a command option and it returned:

-nodeps: unknown option

Is there a package I need to have installed

bump

Still no solution to this problem, but I would love to get it worked out.
I’ve switched back to Windows for the time being, 'cause it’s just inconvenient having my personal rig off the grid.

Hopefully someone can think of another possible response, otherwise I may just have to wait until the next version of the Atheros Otus driver releases and try my luck. :frowning:

Did you try ndiswrapper using the Drivers from the CD it came with? I Suggest using Vista Driver folder if you use the CD from the box. then after that modeprobe it. From there you should add it in your network settings. It works fine with me now.

“Courage is the Magic that turns Dreams into Reality”

This is crazy, how can one seriously suggest using “nodeps” for installing a completely dubious RPM package?

In addition it will not help at all to get rid of that scriptlet error.

Deinstall that thing and tell us which distribution you are using, including the architecture (i586 or x86_64) and kernel version (uname -r).

OK, forget about the information, just saw how old the thread is, still, using nodeps is not advisible at any time.

@Akoellh: I completely agree this time. Nodeps should not even be in a question. If you ask whether somebody used it, the next reader is gonna try and flood the fora with all the system misbehaviour.

Linux internal infrastructure is build on things depending on the availabitity of other things. Installing with this option is ignoring the integrity of your OS.

In this case it’s also a pitty the OP gave up so early (or I am so late in responding), but for further readers of this post a little hint.

In my OBS-Repository you will find two different types of drivers for these otus devices.

Index of /repositories/home:/Akoellh

  1. The old otus driver “arusb_lnx”, kmp-packages for openSUSE 10.3 - 11.1 are available (for openSUSE Factory the driver is included in the kernel).

If you want to use WPA with this device, you will need a special wpa_supplicant, I also offer packages version 0.6.8, however the implementation of “otus”-extension is a bit hackish, so I don’t know if that will work, feedback would be highly appreciated.

  1. The new mac80211-based driver “ar9170”, kmp-packages available for openSUSE 11.1 and openSUSE Factory, the driver for 11.1 is in the “compat-wireless-kmp-Kernelflavor”, for openSUSE Factory there is an extra package ar9170-kmp-Kernelflavor.

This driver needs binary firmware images, which are available through the package “ar9170-firmware” but can be used with the “standard” wpa_supplicant (wext-extension).

Feedback is highly appreciated as the drivers might be merged to the semi-official “driver:wireless”-repo later.