Atheros Networking with latest packages

I have normally had problems (also in 10.3) with SuSE not properly detecting my wireless card, so I’ve become used to it. But I’m stuck this time when it comes to a solution. Normally madwifi is the quick fix, a single update and then it’s working. But no such luck this time around:
I am unable to install the madwifi kernel modules because of a missing dependency; this error dialog pops up:

nothing provides kernel(vmlinux) = 18d57d8dd4787c30

I googled in search of a solution, but haven’t found anything of substance.

All my packages are updated except for the newest KDE4 packages, as I’m trying to pick and choose which ones to break in order to get them all installed. If it helps, I’m running 64-bit…

The other route I’ve already tried is ndiswrapper with ndisinstaller. I downloaded the Atheros WLAN drivers for XP and Vista from Fujitsu (my laptop is an A6110), but only found .inf files that ndisinstaller refused to install.

Any ideas or suggestions?

Its possible you downloaded the wrong madwifi for your kernel. Can you provide the output of:
uname -a

… also point to where you are getting the madwifi kernel modules rpm from …

Also, per this thread/post:
Installed Files - openSUSE Forums
you could try to learn more about the dependency. … ie if your madwifi rpm is called “madwifi-someversion-somekernel-somearch.rpm”, then type:
rpm -qpR madwifi-someversion-somekernel-somearch.rpm
and use that to try help you figure out EXACTLY what is causing the dependency hiccup

Here is the output of uname -a (minus my box name): #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux

The listed installed madwifi from the “rpm -qa --last > installed-applications.txt” command is:


Obviously, you were correct. They don’t match.

The output of the last command was an error; maybe because the package didn’t install correctly; also tried with .rpm ending but it made no difference…

rpm -qpR madwifi-kmp-default-r3698+AR5007EG_2.6.25.4_8.2-2.1
error: open of madwifi-kmp-default-r3698+AR5007EG_2.6.25.4_8.2-2.1 failed: No such file or directory
error: open of madwifi-kmp-default-r3698+AR5007EG_2.6.25.4_8.2-2.1 failed: No such file or directory

Does this help?

I think that is the problem.

That is because the command “rpm -qpR” is to be run against an rpm file (ie rpm -qpR some-rpm-file.rpm"). IF you wish to do the same and query the rpm database for an rpm that is installed, then the command to use is: “rpm -qR some-installed-rpm”. I hope that clarifies the use.

It looks to me that the kernel version differences are causing this problem. I think you need to find a madwifi version that is compatible with your kernel.

Instead of fighting with NATIVE wifi-driver,
I’d suggest using ‘ndiswrapper’ (i.e. the Windows-driver).

[If you’ve never used ndiswrapper before, there’s a
bit of learning curve, but it takes less ‘software engineering’
skills than fighting source-kernel-build issues, in my

My 2-cents…



using *src.rpm of madwifi rebuild package

rpmbuild --rebuild  package name ]

if using madwifi driver blacklist ath5k z.B.

echo "blacklist ath5k" >> /etc/modprobe.d/blacklist

Have Fun :slight_smile:

if not working under madwifi then as above i would suggest ndiswrapper. is it an internal card? or plug in pcmcia or usb? please post ls command depending on which (lspci or psusb) and see if your card is detected. ndiswrapper is very easy to use and can be installed easily from yast.

I thought I had mentioned this in my earlier posts, but Ndiswrapper wasn’t working with the wireless drivers I had downloaded; I’ve already tried both vista (no .inf files after cabextracting the .exe) and xp (two .inf files [maybe i should cat them?]) drivers with Ndisinstaller without success. The XP driver (which is the more probable one to use with ndiswrapper I assume) gave me the same error both times.

I have actually had a breakthrough with getting suse to at least recognize the interface; it is configurable from within KNetworkManager as ath0 after having compiled the source tarball of madwifi 0.9.4 with make, make install (as root), then modprobe_ath0. After rebooting, Yast recognized it and allowed me to configure it.

Here begin the new problems: It is already recognizing the wireless router I am wanting to connect to, but it doesn’t seem to want to connect to either of the possible wireless access points [my Vista install detects and connects to both].
Instead, it freezes at about halfway and eventually fails.

A possible explanation of my troubles is that I am in Europe where I have to connect through a wireless modem (this is not really a dial-up modem requiring I enter a number to be dialed, rather only username and password); it’s simply a PPPoE wireless modem. In Vista, I connect without the ISP provider’s software by setting up a new PPPoE connection, entering my details, and Whaboom! connected! and have accomplished this before on Kubuntu Hardy (also running KDE4) with the sudo pppoeconfig or -conf command. Then I plug in the second wireless router, enter the networking info of the PPPoE Modem, and can connect to the second router (which has better security and range than the other one) with the computer treating it as a “direct” internet connection without any tinkering under the Linux hood required.

But the 64-million (euros sound better) question is whether or not this sort of configuration is possible under SuSE. I have seen it hinted at in Yast, but have not had success with any of them yet. I’m on the brink of success, but could use a little friendly shove from the community.

I will keep trying to solve this and see if I get lucky…
thanks for the help everyone…

>>>If it helps, I’m running 64-bit…

There’s your problem with what you tried with ndiswrapper.
Both XP and (normal)Vista have 32-bit drivers.

What you have to do in this case is go to NDISWRAPPER’s
area at:

and find the 64-bit driver for your adapter. Or, failing that,
go to vendor’s site.

Hope this helps…


the XP drivers I found were 64-bit, but I will try the link…

I am now officially confused. Frustrated with the lack of wireless last night, I decided to fully update my vista install with sp1 and such. I was curious about the wireless adapter as windows offered me an update for it from 5/14/08; in all respects a very recent driver.

The problem is that SuSE and Windows are telling me that I have a different wireless adapter installed.
Under Windows: AR5006EXS (orESX?)
Under SuSE: AR242x

If the Windows driver is functioning properly, then it seems clear that this is the driver I should be using…

Why is SuSE telling me that I have the wrong device?

Should this even matter if I compiled the source tarball?

Yes, you correct…compiling the tarball (source-code)
should build the driver correctly, based on whatever system
(32-bit vs 64-bit) that you build it on.

It’s not uncommon that Windows and Linux would use different
names for drivers/devices. Windows tends to use (distributor’s)
model-name, whereas Linux tends to use the internal chip-vendors
family name. So, there may NOT really be a conflict.

That said, the one SURE way to identify the hardware under
Linux is to use the newer utility ‘hwinfo’ (which you have
to install separately as I recall).

‘hwinfo’ gives MORE information than the older ‘lspci’, ‘lsusb’,
etc series. And, ‘hwinfo’ is bus-independent, so you don’t need
to KNOW which bus your hardware is attached to.

Additionally, ‘hwinfo’ shows the unique ‘vendor-id’ and ‘device-id’. Those values should be identical under both
Windows and Linux. And, it also tells you the driver-names
of the kernel-modules (e.g. ‘ath5k’) needed.
Also, if you inspect the file ‘/var/log/messages’, you
should see indications that any driver is indeed DETECTING
the unique vendor-id/device-id values that it is written
to support. (If you DON’T see such indications, that’s a
clear sign that you don’t have a valid supporting driver
installed/configured for a given piece of hardware.)

[Hint: Try the cmd: ‘hwinfo >hwinfo.txt’, which will put
the VOLUMINOUS output into a file, and then inspect the result
using a text-editor.]

One last word of caution…since you’re using the 64-bit
version of Linux: Many of us (including me) stick with the
32-bit version of Linux, because that’s what 95-percent of
the world is still using, and thus it is MUCH more heavily
tested, both in hardware and in software support.
[Once you get your basic hardware and software working on
the 32-bit edition and gain some experience, then you can
consider migrating to 64-bit edition. Just my 2-cents worth.]

Hope this helps…


Thanks Dave for the clarification.
I chose 64-bit because I have had the most problems in the past with little annoyances like a lack of flash in firefox or something like that, and had also noticed a little extra kick in daily performance once several programs were opened or file transfers were going in the background. I can try the 32-bit version out, but should that really effect the driver situation with the wireless? My problem, after all, has been the fact that I haven’t found the updated madwifi module for the updated kernel that Yast foists upon you right after startup. It even lists it as a security upgrade (update me or die), as I recall. And adding the 11.0 Madwifi repo (which has been down for me the past couple of days) did not give me the correct module…
This version of SuSE is a great!!! (looking, working) distro…
that is missing the wireless support that worked out of the box with Fedora 9 and Ubuntu Hardy. I’ve seen the question asked before, and it seems very ungrateful to ask it, but how can SuSE have less wireless support out of the box if all of the code is open for everyone?

Thanks very much for the hwinfo command; I’ll try it out and report what I find,

Sorry to read about your wireless difficulties. Your timing has been unfortunate, as the madwifi site has been down. The ndiswrapper approach should also solve your problem.

Reference no “out of the box” openSUSE support, the thing is, the code is proprietary … As of openSUSE-10.1, Novell/SuSE-GmbH try hard not to include any proprietary code. That means, no out of the box support.

Hi there-

I’m using an Atheros Communications Inc. AR5212/AR5213 chipset and had the same issues you’re describing in your first post (re: the incorrect kernel for the madwifi modules package), so I simply downloaded madwifi from the website and compiled.

It’s quite simple, actually:
Unzip the folder (Madwifi-0.9.4.tar.gz)
Enter the folder
#make install
#modprobe -r ath5k (if loaded, this module wasn’t working with my chipset, it’s supposed to, but, well, you know how it goes :wink: )
#modprobe ath_pci

Give it a minute or two, and you should be able to connect. If it works for you, I’d suggest blacklisting the ath5k module for now in etc/modprobe.d/blacklist.

Hope this helps, or at least gives you a direction to work!

I did exactly this and my Atheros WiFi still does not work. I am at the latest factory kernel on OpenSUSE 11.0 KDE4.

which uses you for a package ? there which is for a Netwotkcard ?


Have Fun :slight_smile:

What did I use for a source rpm? madwifi-0.9.4-1.src.rpm
What is my kernel? - harryc@linux-y087:~> uname -a
Linux linux-y087 #1 SMP 2008-06-07 01:55:22 +0200 i686 i686 i386 GNU/Linux
What packages were output and installed? harryc@linux-y087:~> rpm -qa | grep wifi
**What does the blacklist look like?**harryc@linux-y087:~> cat /etc/modprobe.d/blacklist | grep ath
blacklist ath5k
**What’s my network card?**linux-y087:/home/harryc # lspci | grep Atheros
02:02.0 Ethernet controller: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor (rev 01)


dmesg | egrep 'ath|wifi|hal'


lspci -nn | grep Ethernet


Have Fun :slight_smile:

harryc@linux-y087:~> dmesg | egrep 'ath|wifi|hal'
Marking TSC unstable due to: TSC halts in idle.
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
ath_pci: 0.9.4
ath_rate_sample: 1.2 (0.9.4)
wifi0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
wifi0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: turboG rates: 6Mbps 12Mbps 18Mbps 24Mbps 36Mbps 48Mbps 54Mbps
wifi0: H/W encryption support: WEP AES AES_CCM TKIP
wifi0: mac 5.9 phy 4.3 radio 4.6
wifi0: Use hw queue 1 for WME_AC_BE traffic
wifi0: Use hw queue 0 for WME_AC_BK traffic
wifi0: Use hw queue 2 for WME_AC_VI traffic
wifi0: Use hw queue 3 for WME_AC_VO traffic
wifi0: Use hw queue 8 for CAB traffic
wifi0: Use hw queue 9 for beacons
wifi0: Atheros 5212: mem=0xd0200000, irq=11
ath0: no IPv6 routers present
linux-y087:/home/harryc # lspci -nn | grep Ethernet
02:02.0 Ethernet controller [0200]: Atheros Communications Inc. AR5212/AR5213 Multiprotocol MAC/baseband processor [168c:0013] (rev 01)
02:08.0 Ethernet controller [0200]: Intel Corporation 82801CAM (ICH3) PRO/100 VE (LOM) Ethernet Controller [8086:1031] (rev 42)