Atheros network wireless driver problem on dell xps 8700 desktop.

Hello,
My name is Danny Patel and i am new to the opensuse. I have dell xps 8700 and i am having wireless setup problems. I have done some research and found out about my device model.

It is Atheros Communications Inc. Device 0032 (rev 01)
04:00.0 0280: **168c:0032 (rev 01)

**I got this information by following the steps shown in the forum for wireless setup, but i could not go further from here. I was instructed to find the firmware but i did not find anything like that. I need some help here.

Thanks,
Danny ****

Please follow the directions here
http://forums.opensuse.org/english/get-technical-help-here/wireless/487148-new-name-compat-wireless.html#post2558438

Welcome to the forums Danny. Which version of openSUSE are you using? This Atheros device is supported by the ath9k driver. Here’s an online guide for openSUSE 12.3:

16. Wireless Driver Installation - Making Your Broadcom, Ralink etc. Wifi/Wlan Work

Have you tried configuring wireless connectivity via the network manager yet?

Hi,

I am using opensuse 11.3

You don´t need any Firmware, you need an actual Kernel, so install openSUSE 12.3:

alias pci:v0000168Cd00000032sv*sd*bc*sc*i* ath9k
uname -a
Linux linux64.linux 3.7.10-1.16-desktop #1 SMP PREEMPT Fri May 31 20:21:23 UTC 2013 (97c14ba) x86_64 x86_64 x86_64 GNU/Linux

Should work out-of-the-box.

I hope you mean 12.3 because 11.3 is EOL and so has no support.

According to an other thread he’s using 11.3. It would explain why f.e the Atheros is not recognized.

Yes, I read that an hour or so ago…I hope he takes the advice to upgrade to current…