Atheros - I am desperate, please help

Hello.

I am really desperate to setup the wireless. It worked, for some short period of time, I do not remember what I did, so I have a proof that it can be configured. But that is forgotten how and I am pressing reset switch… Lets go from beginning: Atheros detected but not working and cannot be setup via Yast.

then I gone to: Atheros ndiswrapper - openSUSE
after doing what is told there, here is what I got


laptux:/home/ebeli # dmesg | grep ndiswrapper
ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
ndiswrapper: driver net5211 (,05/02/2007,5.3.0.45) loaded
ndiswrapper (ZwClose:2227): closing handle 0xf79aa6a8 not implemented
ndiswrapper (NdisWriteErrorLogEntry:191): log: C0001389, count: 4, return_address: fa376064
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xf398ea00
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0x28
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xfa2c8000
ndiswrapper (NdisWriteErrorLogEntry:194): code: 0xfa2c8000
ndiswrapper (mp_init:216): couldn't initialize device: C000009A
ndiswrapper (pnp_start_device:439): Windows driver couldn't initialize the device (C0000001)
ndiswrapper (mp_halt:259): device f2811500 is not initialized - not halting
ndiswrapper: device eth%d removed
ndiswrapper: probe of 0000:02:00.0 failed with error -22
usbcore: registered new interface driver ndiswrapper

I just cannot make it work. Yast always ask “ndiswrapper is not modeprobed, do you want…”.
Anyways, doesnt work. I removed ndisrwapper driver and finally, removed ndiswrapper itself.

Then I gone to MadWiFi option.
1st, I blacklisted ath5k module and gone to Atheros madwifi - openSUSE
I did what I was told there, modprobed ath_pci, rebooted.


laptux:/home/ebeli # dmesg | grep ath
ath_hal: module license 'Proprietary' taints kernel.
ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
ath_pci: 0.9.4


laptux:/home/ebeli # modinfo ath_pci
filename:       /lib/modules/2.6.25.11-0.1-pae/weak-updates/ath/ath_pci.ko
license:        Dual BSD/GPL
version:        0.9.4
description:    Support for Atheros 802.11 wireless LAN cards.
author:         Errno Consulting, Sam Leffler
srcversion:     D3FD3BD11169A96DBCFF8DE
alias:          pci:v0000168Cd00009013sv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000001Dsv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000001Csv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000001Bsv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000001Asv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000019sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000018sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000017sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000016sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000015sv*sd*bc*sc*i*
alias:          pci:v0000168Cd0000101Asv*sd*bc*sc*i*
alias:          pci:v0000168Cd00001014sv*sd*bc*sc*i*
alias:          pci:v000010B7d00000013sv*sd*bc*sc*i*
alias:          pci:v0000A727d00000013sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000013sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000012sv*sd*bc*sc*i*
alias:          pci:v0000168Cd00000007sv*sd*bc*sc*i*
depends:        ath_hal,wlan
vermagic:       2.6.25.5-2-pae SMP mod_unload 586
parm:           countrycode:Override default country code (int)
parm:           maxvaps:Maximum VAPs (int)
parm:           outdoor:Enable/disable outdoor use (int)
parm:           xchanmode:Enable/disable extended channel mode (int)
parm:           rfkill:Enable/disable RFKILL capability (int)
parm:           autocreate:Create ath device in [sta|ap|wds|adhoc|ahdemo|monitor] mode. defaults to sta, use 'none' to disable (charp)
parm:           ratectl:Rate control algorithm [amrr|minstrel|onoe|sample], defaults to 'sample' (charp)
parm:           ath_debug:Load-time debug output enable (int)

snapshot1

when I try to add new wireless, module box is just empty. It doesnt help to write ath_pci inside, because it looses it on the next open.
snapshot2

Please help.

You have the ‘vermagic’ problem…code that’s there to insure that
the kernel you compiled the driver for, matches the kernel
you’re now trying to install/use the driver in.
[Note how kernel versions on ‘filename’ line do NOT match those
on the ‘vermagic’ line.]

So, basically, you need to RE-COMPILE (re-make) the driver, before
you do the ‘make install’ step (which moves the compiled driver from
your work area down into the kernel that it’s gonna run under).

The cleanest way is just to re-do everything…delete the work directory that
you initially un-TARed the downloaded madwifi driver into, then re-do
the ‘tar’ etc.

Make sense?

[That said, don’t feel bad. It’s not your fault. Novell screwed up when they
chose to pre-install ‘ath5k’ instead of the madwifi driver. In my opinion.
Which is only ONE of their sub-optimal choices that is making 11.0
such a support nightmare.]

well, I do not quite understood what you said.
I removed madwifi from yast then
I downloaded sources of the MadWiFi (not rpm), I did make and make install.
Suse offers madwifi 0.9.3, I have newest from the madwifi site.

Make sure that you have blacklisted ‘ath5k’ driver.

Also, make sure that if you have the file:
‘/etc/modprobe.d/ndiswrapper’
present, that you delete it.
(It defines ‘wlan0’ device, which you do NOT now want.)

Then, if you see the device name ‘wlan0’ associated with the
device (on ‘network devices’->‘network settings’ screen), click
on the ‘delete’ option and get rid of it. Re-boot.

[Any of the above stuff is left over is left-over from your attempts to
use either ndiswrapper and/or the ‘ath5k’ driver.]

Now configure your device (for the ath_pci module). You should now
be able to get it to work. The device name should come up as ‘ath0’.

Post back if you still have problems.

Hope this helps…

Dave

it was already. Double-check, yes, it is in blacklist.

it was there, I have deleted it now, rebooted

Thanks Dave, but We’re back to square 1…
Please see http://www.varnus.com/snapshot1.png

I cannot configure it, as it is disabled. Unless you thought on some other kind of configuration, like adding new device. Which if I do, I do not have any modules listed in module combobox, and if I write ath_pci, it is lost on next open of yast->network devices

there is something interesting in hwinfo:


70: udi = '/org/freedesktop/Hal/devices/pci_168c_1c'
  pci.subsys_vendor_id = 6715 (0x1a3b)
  info.subsystem = 'pci'
  pci.device_class = 2 (0x2)
  info.product = 'AR242x 802.11abg Wireless PCI Express Adapter'
  pci.device_subclass = 0 (0x0)
  info.udi = '/org/freedesktop/Hal/devices/pci_168c_1c'
  pci.device_protocol = 0 (0x0)
  pci.vendor = 'Atheros Communications Inc.'
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:06.0/0000:02:00.0'
  info.vendor = 'Atheros Communications Inc.'
  info.parent = '/org/freedesktop/Hal/devices/pci_1039_a'
  pci.product = 'AR242x 802.11abg Wireless PCI Express Adapter'
  pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:06.0/0000:02:00.0'
  pci.product_id = 28 (0x1c)
  linux.hotplug_type = 2 (0x2)
  pci.vendor_id = 5772 (0x168c)
  linux.subsystem = 'pci'
  pci.subsys_product_id = 4134 (0x1026)

~~~~~~

12: PCI 200.0: 0282 WLAN controller
  [Created at pci.310]
  UDI: /org/freedesktop/Hal/devices/pci_168c_1c
  Unique ID: B35A.m0vUiPh1JS3
  Parent ID: H0_h.VpS90DeKnS9
  SysFS ID: /devices/pci0000:00/0000:00:06.0/0000:02:00.0
  SysFS BusID: 0000:02:00.0
  Hardware Class: network
  Model: "Atheros AR242x 802.11abg Wireless PCI Express Adapter"
  Vendor: pci 0x168c "Atheros Communications, Inc."
  Device: pci 0x001c "AR242x 802.11abg Wireless PCI Express Adapter"
  SubVendor: pci 0x1a3b 
  SubDevice: pci 0x1026 
  Revision: 0x01
  Features: WLAN
  Memory Range: 0xfaaf0000-0xfaafffff (rw,non-prefetchable)
  IRQ: 16 (1 event)
  Module Alias: "pci:v0000168Cd0000001Csv00001A3Bsd00001026bc02sc00i00"
  Driver Info #0:
    Driver Status: ath5k is not active
    Driver Activation Cmd: "modprobe ath5k"
  Driver Info #1:
    Driver Status: ath_pci is active
    Driver Activation Cmd: "modprobe ath_pci"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #17 (PCI bridge)

Now, something from a boot.log


<6>ath_pci: 0.9.4
<6>ACPI: PCI Interrupt 0000:02:00.0[A] -> GSI 16 (level, low) -> IRQ 16
<7>PCI: Setting latency timer of device 0000:02:00.0 to 64
<3>wifi%d: unable to attach hardware: 'Hardware revision not supported' (HAL status 13)
<6>ACPI: PCI interrupt for device 0000:02:00.0 disabled

What the hack is the problem here?
:frowning:

beli0135 wrote:
>
> <6>ath_pci: 0.9.4
> <6>ACPI: PCI Interrupt 0000:02:00.0[A] → GSI 16 (level, low) → IRQ 16
> <7>PCI: Setting latency timer of device 0000:02:00.0 to 64
> <3>wifi%d: unable to attach hardware: ‘Hardware revision not supported’ (HAL status 13)
> <6>ACPI: PCI interrupt for device 0000:02:00.0 disabled
>
> --------------------
>
>
> What the hack is the problem here?

As the message says, that driver does not support that hardware! You probably
have exhausted the Atheros knowledge here. I would post this message (with the
last line changed) to linux-wireless@vger.kernel.org. That is where the wireless
experts hang out.

Larry

Thank you Larry.
a week ago, I do not know what I did, but for a brief moment, before reboot, I managed to set it up. I do not know how, I know that I had ndiswrapper and ath_pci at the same time up.
After reboot it stopped working, and after, neither with ndiswrapper nor ath_pci could I make it work. But it DID worked for a bit…

:frowning:

I got mine going with ndiswrapper. Get the driver here: http://blakecmartin.googlepages.com/ar5007eg-32-0.2.tar.gz For 64bit change the 32 in the link to 64.

Install the .inf file with

ndiswrapper -i path_to_.inf

Remove ath5k

modprobe -r ath5k

Add ath5k to the end of /etc/modprobe.d/blacklist file

blacklist ath5k

modprobe ndiswrapper module

modprobe ndiswrapper

Open Yast>System>/etc/sysconfig Editor. Expand System>Kernel and select MODULES_LOADED_ON_BOOT. Add ndiswrapper. Reboot. Then set it up with Yast again. Just be sure to change the module option while setting up the card under the hardware tab from ath5k to ndiswrapper. You should be good to go after another reboot.

OH YEA!
Worked!!!

I done the same procedure before, but I see now that the driver you provided has some bytes difference from the driver I got on CD with laptop. Probably there was the catch.
Anyways, it is working.

A BIG THANKS!!!

well it worked, but I have another problem now.

After a few minutes, my whole system freezes.

Anyone knows why and how to avoid?

I noticed earlier that you tried the ath_pci module from madwifi. Make sure to blacklist it also if it is being loaded. If two kernel modules are fighting over something, it can cause lockups.

What is the output of

ndiswrapper -l

Nope, both ath5k and ath_pci are blacklisted. When ndiswrapper is alone, it hangs the system after minute to 3 minutes.

I needed to unload driver and cliear kernel setting in yast. Otherwise system locks

here is ndiswrapper -l

net5211 : driver installed
device (168C:001C) present (alternate driver: ath5k)

Problem solved… with madwifi.

actually, ndiswrapper helped. Here how it was…

with ath_pci alone, yast could not configure the card. Reason unknown. With ndiswrapper it could, but system was freezing within 2 minutes.

So, I put up ndiswrapper, configured the card, set to manual startup, configured wpa_supplicant, rebooted. Wireless was now working, but prone to freezing the system.

Then I blacklisted ndiswrapper, unloaded module, recompiled madwifi, modprobbed ath_pci, gone to Yast and in kernel, I forced ath_pci module loading.

Voila!!!

OK ladies and gentleman, situation is following:

(just for info, running openSUSE 11.0, card is identified as Atheros AR242x 802.11abg, windows XP identifies it as Atheros 5211)

  1. ath5k doesn’t work, as we all know, not even from kernel 2.6.26.2

  2. madwifi, ath_pci doesn’t work either. Tried everything imaginable
    situation now: ath5k and ath_pci blacklisted

  3. ndiswrapper


  • original driver that came on CD and that WinXP is using (around 82k) doesnt work. Makes no problems but it doesnt work.
    — drivers downloaded from atheros.cz
  1. ar5001a - doesnt work, slows the system incredibly
  2. ar5001x - doesnt work
  3. ar5001x+ - doesnt work
  4. ar5007eg - WORKS but locks the system after a minute or two

I am out of ideas. I would be very much obliged for a suggestion

You might try installing the latest version of ndiswrapper: NDISwrapper - Home

correction: windows reports ar5007EG

Anyways, installed new ndiswrapper.

ar5007eg still locks the system, but I have some results.
Using driver that windows installed there.

wpa_supplicant returned message:


> wpa_supplicant -Dwext -iwlan0 -cwpa_supplicant.conf

Trying to associate with 00:1d:7e:f1:dd:2c (SSID='varnus' freq=2437 MHz)
Associated with 00:1d:7e:f1:dd:2c
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Trying to associate with 00:1d:7e:f1:dd:2c (SSID='varnus' freq=2437 MHz)
Associated with 00:00:00:00:00:00
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Trying to associate with 00:1d:7e:f1:dd:2c (SSID='varnus' freq=2437 MHz)
Associated with 00:1d:7e:f1:dd:2c
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Trying to associate with 00:1d:7e:f1:dd:2c (SSID='varnus' freq=2437 MHz)
Associated with 00:00:00:00:00:00
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Trying to associate with 00:1d:7e:f1:dd:2c (SSID='varnus' freq=2437 MHz)
Associated with 00:00:00:00:00:00
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Trying to associate with 00:1d:7e:f1:dd:2c (SSID='varnus' freq=2437 MHz)
Associated with 00:1d:7e:f1:dd:2c
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Trying to associate with 00:1d:7e:f1:dd:2c (SSID='varnus' freq=2437 MHz)
Associated with 00:1d:7e:f1:dd:2c
WPA: No SSID info found (msg 1 of 4).

wpa_supplicant.conf is


ctrl_interface=/var/run/wpa_supplicant
eapol_version=1
#ap_scan=1
network={
	ssid="varnus"
	scan_ssid=1
	proto=WPA
	pairwise=TKIP
	key_mgmt=WPA-PSK
	psk="SomeLongPassphrase"
}

My ar5007eg works perfectly in opensuse 11 with ndiswrapper. I wrote a small how to for another user on the Linux Mint forums: Linux Mint Forums • View topic - Atheros WiFi problem (solved) The only difference is opensuse doesn’t have /etc/modules. You have to add the ndiswrapper module in Yast>System>/etc/sysconfig Editor>System>Kernel>MODULES_LOADED_ON_BOOT. Reboot and then configure your card with Yast>Network Devices>Network Settings. On the hardware tab there will be a drop down menu called “Module Name”. Be sure to make that ndiswrapper instead of ath5k. On the next reboot, you should be able to use networkmanager to select a signal to connect to.

I have MODULE_LOADED_ON_BOOT set to ndiswrapper, but there is NO module in drop down list. I actually had to write it down.
So, I suspect there is some problem… but looking at dmesg, ndiswrapper is loaded properly.

Post the output of

lsmod