Atheros AR5007 problems can't find my network

Hello

I have a bit of a problem after installing openSuSE 11.1 on my laptop. The installation went through fine and everything is up and running besides my wireless network. Connecting through the Realtek/wired NIC was no problem though… Anyway here comes some (hopefully usefull) output:

lspci -v

08:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Ex
press Adapter (rev 01)
Subsystem: Hewlett-Packard Company Device 137b
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at d1200000 (64-bit, non-prefetchable) [size=64]
Capabilities: [40] Power Management version 2
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Count=1/1 Enable-
Capabilities: [60] Express Legacy Endpoint, MSI 00
Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
Capabilities: [100] Advanced Error Reporting
UESta: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP-
ECRC- UnsupReq+ ACSVoil-
UEMsk: DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP-
ECRC- UnsupReq- ACSVoil-
UESvrt: DLP+ SDES- TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+
ECRC- UnsupReq- ACSVoil-
CESta: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
CESta: RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
AERCap: First Error Pointer: 14, GenCap+ CGenEn- ChkCap+ ChkEn-
Capabilities: [140] Virtual Channel <?>
Kernel driver in use: ath5k_pci
Kernel modules: ath_pci, ath5k


iwlist scan

lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:21:04:10:C8:17
ESSID:“ConnectionPoint”
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=10/100 Signal level:-93 dBm Noise level=-100 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000068c3dc057f7
Extra: Last beacon: 536ms ago
Cell 02 - Address: 00:14:6C:7E:34:A0
ESSID:“Lan1”
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=14/100 Signal level:-91 dBm Noise level=-100 dBm
Encryption key: on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000037c36cb1b82
Extra: Last beacon: 536ms ago


iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11bg ESSID:“vintergatan”
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr: off Fragment thr=2352 B
Encryption key: off
Power Management: off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


From dmesg:

ath5k_pci 0000:08:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
ath5k_pci 0000:08:00.0: setting latency timer to 64
ath5k_pci 0000:08:00.0: registered as ‘phy0’
ath5k phy0: Support for RF2425 is under development.
ACPI: Battery Slot [BAT0] (battery present)
ACPI: WMI: Mapper loaded
phy0: Selected rate control algorithm ‘pid’


ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)


ADDRCONF(NETDEV_UP): wlan0: link is not ready
NET: Registered protocol family 17


Router settings:

SSID: vintergatan
802.11g and 802.11b mixed mode
Auto channel scan
Status visible
Security mode: WPA Personal
WPA mode: auto (WPA or WPA2)
Cipher type: TKIP and AES

The output from iwconfig says the ESSID is “vintergatan” because of me, running the command iwconfig wlan0 essid “vintergatan”.

I have no idea what the results from iwlist scan are, I don’t recognize those networks.
Obviously the device is runnig, but I can’t manage to connect to my network “vintergatan”.

I’ve tried to download and install the madwifi driver found at snapshots.madwifi-project.org/madwifi-hal-0.10.5.6/
with modeprobe ath_pci, blacklisting ath5k from /etc/modprobe.d/blacklist and all sorts of possible sollutions found googling around.

I’m running KDE 4.1 and NetworkManager if that’s to any help.

Can you please help me? I refuse to go back to Windows Vista, and I hope this problem wont stop me from running openSuSE.

Thanks[/size]