Atheros AR242x wireless chip in openSUSE 11


How can I install madwifi-kmp for Atheros AR242x wireless card? I added madwifi repo from wiki and the madwifi-kmp prompts some conflict with the current kernel( So I am wondering if there will be a kernel update soon or this is a bug?


Add this repo & install madwifi from there, some people have had better results with this repo YMMV

Index of /repositories/home:/schmolle1980/openSUSE_11.0


Thax, I will try.

I too have the same card. I have the latest madwifi (got it from link on front page)

I have also blacklisted ath5k but it still loads and on network settings it says it cannot configure possibly due to missing firmware. What do i do?

I’ve got the same problem, this sucks. I’m running x64 which seems to be compounding the problem :frowning:

Adding that repo worked…thanks alot.

No matter what I try (ndiswrapper, madwifi) I cannot get my ath242x wireless card to work with my suse11 install (on a AMD64 (tl-60).

Is it likely that being on 64bit suse 11 is causing problems, and installed 32 bit might help?

Suse11 is fantastic, and running like a dream on this laptop… now if only I could get wifi I would be sorted.


Did you try this thread? Worked for me.