Atheros ar2427, can scan for wifi, but can not connect

I have an Atheros ar2427 chip in my Asus EEE 1001P and I’m using WICD to configure it. I can scan for wlans, but I can not connect. I installed the compat wireless package from yast and I downloaded the source from the compat wireless site and tried to compile it (which seems to be the solution for Ubuntu) but I got an error and an interesting warning.

Thanks for any help and any useful advice

uname -a

Linux 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux

lspci -nnk

02:00.0 Network controller [0280]: Atheros Communications Inc. AR2427 Wireless Network Adapter (PCI-Express) [168c:002c] (rev 01)
    Subsystem: Device [1a3b:1112]
    Kernel driver in use: ath9k

compiling compat wireless

.../compat-wireless-2010-10-28/ "WARNING: CONFIG_CFG80211_WEXT will be deactivated or not working because kernel was compiled with CONFIG_WIRELESS_EXT=n. Tools using wext interface like iwconfig will not work. To activate it build your kernel e.g. with CONFIG_LIBIPW=m."
make -C /lib/modules/2.6.34-12-desktop/build M=/home/bob/Downloads/compat-wireless-2010-10-28 modules
make: *** /lib/modules/2.6.34-12-desktop/build: No such file or directory.  Stop.

AFAICS this has neither to do with the driver, nor the kernel. Compat-wireless should not be needed. The compile error is there because you don’t have the kernel-sources installed.

I’d say there’s something wrong in your wicd settings/install. Any reason why you use wicd instead of the networkmanager?

I installed the kernel sources package already, still it throws the same error.
Well I’m running Xfce and I did not find any network manager anywhere (maybe I’m just blind) so I decided to install wicd

Did you get this solved? Has anyone else got the AR2427 working? I have the same machine same problem and have tested with FreeBSD current and Fedora 14 and Fedora 15 alpa.

Ath9k (the driver your card is already using) is in the kernel. You’ve already stated that you can scan for wireless networks but cannot connect. Compat-wireless is just going to provide the same driver.
It seems to me like you have a configuration issue, not a driver issue.

Here’s the driver page that tells you how you can get the very latest driver from git and compile it if you really think that’s what you need (or want) to do.
ath9k - Linux Wireless

Also note, no n support.
AR2427 (>=, no 802.11n hardware support, its bonded out) 1x1 SB PCIe

Ever tried to ‘killall NetworkManager’ before trying to connect?

For the record, compat-wireless will again provide ath9k; however, the standard
driver will be from 2.6.37, whereas the one from compat-wireless is effectively
the one from 2.6.40! As there have been many improvements, it may fix some problems.