Atheros 5005G card doesn't find signal

Hi,

in my laptop I am using a Belkin F5D7010E wireless card. From my experience with opensuse 10.3, I believe to know that it is build with an Atheros 5005G chipset. It worked with suse 10.3 and a 5005G driver.

During the installation of suse 11.0, a driver for the 5005G chipset was installed (Yast reports AR2413 802.11bg NIC) and the firmware seems to run.

iwconfig says

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

iwlist scan delivers

wlan0 No scan results

I am sure that the card is working (booting another OS, everything works fine).

Here now my question: What is wrong ? Why doesn’t the card find the signal under suse 11.0 ?

Thanks in advance for your help

Montfinal

What does dmesg have to say?

Larry

OK, I executed dmesg, but it delivers tons of output. In order not to explode this forum I uploaded the output to a server. You can look at it under the following link:

http://online-tip.exofire.net/admin/dmesg.txt

I hope this is convenient.

Thanks for your help

montfinal

montfinal wrote:
> OK, I executed dmesg, but it delivers tons of output. In order not to
> explode this forum I uploaded the output to a server. You can look at it
> under the following link:
>
> http://online-tip.exofire.net/admin/dmesg.txt
>
> I hope this is convenient.

The critical section is as follows:

ath5k_pci 0000:02:00.0: registered as ‘phy0’
phy0: Selected rate control algorithm ‘pid’
ath5k phy0: Atheros AR5213A chip found (MAC: 0x78, PHY: 0x45)
ath5k phy0: RF2112A 2GHz radio found (0x56)
ADDRCONF(NETDEV_UP): wlan0: link is not ready
ath5k phy0: failed to wakeup the MAC Chip
ath5k phy0: can’t reset hardware (-5)
pccard: card ejected from slot 0

It appears that the ath5k driver does not support the AR5213A.

Please post these lines to linux-wireless@vger.kernel.org. The Atheros experts
hang out there.

Larry

OK thanks

Montfinal

Larry,

I got an error message, the address

linux-wireless@vger.kernel.org

delivers permanent errors !?

Ciao

Alexander

montfinal wrote:

> linux-wireless@vger.kernel.org

That is a valid E-Mail address. What errors are you getting?

Larry

OK sorry, my fault. As I am just setting up the new suse distro, I haven’t got my kmail configured yet. I used a webmail interface. The diagnostic code says: Diagnostic-Code: smtp; 550 5.7.1 Content-Policy reject msg: The message contains HTML subpart, therefore we consider it SPAM or Outlook Virus. TEXT/PLAIN is accepted.!

I’ll try again with kmail.

Ciao

Alexander

Some update:

As I was looking for a rather stable solution and I have not so much time to experiment, I decided to step back to the madwifi drivers.

The yast repository for suse 11.0 can be found here Additional YaST Package Repositories - openSUSE

as well as a HOWTO.

The crucial point is that the ath5K should be disabled by inserting a blacklist ath5k in the file /etc/modprobe.d/blacklist. After installation of the madwifi driver, configuration in yast and restart of the system, my good old belkin card is back to life.

Thanks anyhow to Larry and Nick (via the vger.kernel.org mailing list) for their help.

Alexander