ath9k issues resolved with a router setting?

Bear with me… Like many folks here and across the Linux user-land I had been struggling with my Atheros 928x wireless card. Seamed that no matter what I tried the results were the same : connectivity was atrocious. My wife’s asus laptop had no issues with WiFi so I know the D-Link router was functioning as well as expected.

So the problem MUST be with the ath9k. Right? I’m not so sure. I went back to the router’s settings made a change to the security settings. Securty mode is set to wpa-personal, I switched wpa mode from wpa2-only to auto (wap and wap2) and the cipher type to tkip and aes. Rebooted and it works. And its been perfect for a few hours now. I don’t use the router’s default password, remote log in is disabled, and the pass code is a random 16 character alpha numeric string.

How is this possible?

| [RIGHT]IPv4 Address:[/RIGHT]
|
| 192.168.X.XXX|
| [RIGHT]IPv6 Address:[/RIGHT]
| FEXXXXXXXXXXXXX:912E|
| [RIGHT]MAC Address:[/RIGHT]
| 00:26XXXXXX:2E|
| [RIGHT]Access point (SSID):[/RIGHT]
| XXXXX|
| [RIGHT]Signal strength:[/RIGHT]
| 77%|
| [RIGHT]Security:[/RIGHT]
| WPA2-PSK|
| [RIGHT]Connection speed:[/RIGHT]
| 150 MBit/s|

People here like it very much if they know which verson of openSUSE you use. It helps in helping you on a solution for the correct openSUSE version.

os is 13.2 64bit, KDE4

On Mon 04 May 2015 04:46:01 PM CDT, pigsrus wrote:

Bear with me… Like many folks here and across the Linux user-land I
had been struggling with my Atheros 928x wireless card. Seamed that no
matter what I tried the results were the same : connectivity was
atrocious. My wife’s asus laptop had no issues with WiFi so I know the
D-Link router was functioning as well as expected.

So the problem MUST be with the ath9k. Right? I’m not so sure. I went
back to the router’s settings made a change to the security settings.
Securty mode is set to wpa-personal, I switched wpa mode from wpa2-only
to auto (wap and wap2) and the cipher type to tkip and aes. Rebooted and
it works. And its been perfect for a few hours now. I don’t use the
router’s default password, remote log in is disabled, and the pass code
is a random 16 character alpha numeric string.

How is this possible?

IPv4 Address:

192.168.X.XXX

IPv6 Address:

FEXXXXXXXXXXXXX:912E

MAC Address:

00:26XXXXXX:2E

Access point (SSID):

XXXXX

Signal strength:

77%

Security:

WPA2-PSK

Connection speed:

150 MBit/s

Hi
Your router could be auto switching the n speed bandwidth from 20 to
40MHz if your system is a 1x1 wireless card. Look at the the output
from;


/sbin/lspci -nnk |grep -A2 Network

It could also be other AP’s in your local on the same channel causing
issues.


Cheers Malcolm °¿° LFCS, SUSE Knowledge Partner (Linux Counter #276890)
SUSE Linux Enterprise Desktop 12 GNOME 3.10.1 Kernel 3.12.39-47-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!