aterm doesn't work (only) under twm/ctwm/mwm and (only) if they were started from gdm.

and I should add ‘only’ when gdm uses gnome-shell login screen. This problem (probably) appeared with Gnome 3.4, and I first noticed on ArchLinux several months ago. Now it affects openSUSE 12.2 as well … and googling for new answers, all I found was my old question. :frowning:

$ aterm
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  20 (X_GetProperty)
  Resource id in failed request:  0x100000b
  Serial number of failed request:  26
  Current serial number in output stream:  26

More info here: aterm doesn’t start under twm/ctwm/mwm (only)

I would appreciate not to receive the same kind of answer I got on the Arch forum - which is otherwise very helpful. :wink:
I hope it could be fixed with some X server option … will try a couple ones (provided gdm doesn’t ignore them).

Pffft! >:(