ASUSTek AC51 802.11a/b/g/n/ac Wireless Adapter [Mediatek MT7610U]: No USB driver (mt76x0u) available

Dear Team,

when I’m trying to use the wireless adapter mentioned above under Leap 15.1 it is being recognized, but it seems that there’s no driver available.

Under Tumbleweed it works like a charm (See https://privatebin.net/?0e4d15d91f8c3d92#DzCyD42tnBJFQuFY3YJJJCfdrRDqLq8be74EotkWBpbh ), but it isn’t usable under Leap 15.1.

So my question is:

Is it possible to backport the working driver “mt76x0u” to Leap 15.1? I wouldn’t switch to tumbleweed due to stability reasons.

Kind Regards,

MehrMateMann

Looks like a kernel issue. You can add the Kernel:Stable repo and use a kernel from that repo.

Leap logs:
https://privatebin.net/?97cb5f3e7f247ea1#8CfPKcJXE9XkbUypXDMboZ5gAfau2e8tTsHV2AB9GXtL

Well…when I’m looking to the official documentation, the openSUSE team recommends not to install the latest stable kernel, quote:

"…] Installing the latest kernel only makes sense for kernel developers and kernel testers. …] "
(source: https://doc.opensuse.org/documentation/leap/reference/html/book.opensuse.reference/cha.tuning.multikernel.html#sec.tuning.multikernel.latest).

That’s why I opened this thread ;).

Or should I open an issue in the bugtracker?

Kind Regards,

MehrMateMann

You could, but I think the device is too new. And since 15.1 is released, no new backports are going to be added. So, you have two options: