ASUS Xonar DX :=> Headache

You adjust this in your mixer.

i will try those two very shortly, yes thank you, i will post back shortly

cannot find anything about digital audio in the mixer,

i adjusted audio modbrobe.d sound file made it 2 then 1 again, i do get sound from speakers on both numbers with speakers plugged into the xonar when i reboot, but stuttered or no sound when the desktop returns after reboot, still can not choose virtuoso driver in yast>souns, what to do?

amarok will only play with onboard sound

you said to configure xonar sound card, i am asking how to do that

Can you say that again in different words? I do not understand what you mean.

Same there, I do not understand what you mean.

How about when onboard sound is disabled in BIOS ?

Your digital audio is, I believe, IEC958. Is there any mention of that?

Thank you very much for your help old cpu, i actually did more damage via alsaconf, but i have re-installed suse and i have disabled onboard sound in bios and that seemed to do the trick, sound now via xonar dx thank you.
Earlier I was thinking that seeing as both audio were configured in yast i could use either, but not so.

:slight_smile:

There are still problems with it, audio in kaffiene doesn’t work, audio in vlc when watching dvd stutters when it first starts then it is ok for the rest of the movie, audio from amarok is fine but not quite as good as in windows using winamp or vlc, and audio from vlc in suse does not work it stutters badly,

so all in all i must say that i will have to use windows for audio listening, the linux drivers are not quite up to it and i have no xonar dx gui in suse,

maybe in a future version of suse the audio will improve, it has come a long way since i started using 9.2.

oh well it was worth trying, perhaps the original poster of this thread could post a recipe for how he got the xonar dx to work in 64bit, (maybe 32bit is better?) because i still reckon it uses the wrong drivers (oxygen instead of virtuoso, but i’m not certain as i can’t seem to find out what to do), causing all the stuttering in various programs, as i have windows (dualboot) to bench mark it from. and i do not have these issues in windows.

i am trying to make it so that i only use suse, but sadly i still can not do that yet.

:frowning:

sorry i don’t know what this is ?

i find it all very confusing, is it using alsa, or pulse audio, is it a xine or gstreamer back end, what is all this? seems like too many default options, beyond default, settings and more options should only be installed by users knowing what they are doing.

just have one audio software option by default install makes it easier.

if anyone finds a recipe for installing xonar dx on suse please tell me, thanks, i’ll check this thread from time to time

Are you a gnome user?

IMHO there are still problems with audio stuttering with pulse audio and Gnome, that do not exist with KDE (to the same extent).

I also encountered such problems with fedora-10 Linux running gnome. Again, this is IMHO a problem with Pulse Audio adding an extra layer between the multimedia player application and the sound driver (alsa). In the case of Fedora-10 I minimized such problems by going into each player and changing the output video module, … typically changing it to “alsa” (ie to the alsa-api) helped.

Reference audio in kaffeine not working, its likely because of your selected sound engine. What sound engine have you selected in kaffeine (there is a choice of gstreamer or xine). And have you replaced the crippled Novell/SuSE-GmbH packaged gsteamer/xine with the Packman packaged version?

What might be useful is to document exactly what was done by the openSUSE setup, so if other users have this problem, we can use your setup as a baseline, such that they do not need to re-install.

I assume you re-installed openSUSE-11.0 (and not 11.1).

Please, if you get the chance, could you to provide more information, with your PC connected to the internet copy and paste the following into a gnome-terminal or konsole:

wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh 

When the script completes it will pass you a URL. Please post that URL here.

Also, please copy and paste the following one line at a time into a gnome-terminal or konsole and post the output here.rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
cat /proc/interrupts
cat .asoundrc

I’m hoping that information will help document the successful ASUS Xonar DX configuration.

thank you old cpu,
I use 11.1_x86_64, KDE 3.1.4,
One thing i am confussed on is which audio am i using is it pulse or alsa?

http://www.alsa-project.org/db/?f=2537046a59ff12adeed1cd8093a893cea0520c5a

alsa-plugins-pulse-1.0.18-6.13
alsa-oss-1.0.17-1.43
alsa-oss-32bit-1.0.17-1.37
alsa-1.0.18-8.9
alsa-plugins-1.0.18-6.13
alsa-utils-1.0.18-6.4

libpulse0-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
libpulse-browse0-0.9.12-9.5
pulseaudio-utils-0.9.12-9.5
pulseaudio-module-x11-0.9.12-9.5
pulseaudio-module-lirc-0.9.12-9.5
pulseaudio-esound-compat-0.9.12-9.5
libpulse-mainloop-glib0-0.9.12-9.5
pulseaudio-0.9.12-9.5
pulseaudio-module-zeroconf-0.9.12-9.5
pulseaudio-module-jack-0.9.12-9.5
libpulsecore4-0.9.12-9.5
pulseaudio-module-bluetooth-0.9.12-9.5
libxine1-pulse-1.1.15-44.pm.2
vlc-aout-pulse-0.9.8a-1.4

libasound2-1.0.18-8.9

Linux linux-6xwj 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

options snd slots=snd-hda-intel,snd-oxygen

wRyD.7ISuh_cLQF9:MCP51 High Definition Audio

alias snd-card-0 snd-hda-intel

AMUB.hJ2fTVR7hHD:Virtuoso 100 (Xonar DX)

alias snd-card-1 snd-oxygen

onboard sound is now disabled in bios

       CPU0       CPU1

0: 75 0 IO-APIC-edge timer
1: 2 0 IO-APIC-edge i8042
4: 2 0 IO-APIC-edge
7: 1 0 IO-APIC-edge parport0
8: 1 0 IO-APIC-edge rtc0
9: 0 0 IO-APIC-fasteoi acpi
12: 4 0 IO-APIC-edge i8042
14: 0 0 IO-APIC-edge pata_amd
15: 0 0 IO-APIC-edge pata_amd
16: 49689 0 IO-APIC-fasteoi ahci, AV200, nvidia
18: 2 0 IO-APIC-fasteoi ohci1394
20: 3 0 IO-APIC-fasteoi ehci_hcd:usb2
21: 17194 0 IO-APIC-fasteoi ohci_hcd:usb1
22: 11201 0 IO-APIC-fasteoi sata_nv
23: 176522 0 IO-APIC-fasteoi sata_nv, eth0
NMI: 0 0 Non-maskable interrupts
LOC: 213193 901164 Local timer interrupts
RES: 3676 1477 Rescheduling interrupts
CAL: 147 2282 function call interrupts
TLB: 1251 1627 TLB shootdowns
TRM: 0 0 Thermal event interrupts
THR: 0 0 Threshold APIC interrupts
SPU: 0 0 Spurious interrupts
ERR: 1

cat: .asoundrc: No such file or directory

well i hope this helps in some way, i do see in there that alsa 1.0.17 is mentioned and the 32bit? this is 64bit suse

i am wondering if i should enable the alsa repo’s and update alsa then delete the alsa repo’s, just get the latest alsa driver?

yes i did upgrade the crippled kaffiene, i can play dvd on it just no sound, but i’ll have a look see if i can tell it to use xine, kaffiene uses xine, xine packages and kaffiene from packman, only phonon backend-xine from KDE Core, and xinetd from OSS(no other option),

Replace the Novell/SuSE-GmbH packaged libxine1 with the Packman packaged libxine1. And select the xine sound engine in kaffeine. Also install libffmpeg0 packaged by Packman (not the version packaged by Videolan). By installing libffmpeg0, its dependencies will pickup various other apps providing you necessary codecs.

ok thanks i have done that,

amarok uses the yauap engine and plays audio (mp3, wav, flac), but when i turn it up it distorts
(the xine engine with amarok but is no good, the audio is too low, not very load, and does stutter).

VLC, i can not play audio, it stutters, i can play dvd - it does stutter a little at the beginning but goes on to play dvd reasonably well with good audio (just a hint of stutter here and there but very watchable).

Kaffeine, i can not play audio on that, it stutters and will crash when asked to play a cd, however, it will now play dvd ok, but audio is a little low

i just don’t think i can use opensuse with the xonar dx for audio at all, it is just not working, they say that alsa supports xonar, but i’m not sure about that, i know all this works properly as it does on windows with no problem, oh well over to xp again for audio listening.

I can leave it there but really i think alsa and opensuse need to do a lot more work on this, please ? :slight_smile:

We are all mostly unpaid volunteers and openSUSE enthusiasts on this forum. We are not developers, nor packagers of the OS, nor the applications.

IMHO if you wish to contact the devs, the best way is to write bug reports on openSUSE, and on the applications (via their own error/bug tracking systems).

thank you old cpu, i will try the bug reporting, i will also try #alsa irc, maybe alsa have a forum?

will it be better if i try 32bit opensuse, maybe the 64bit audio drivers are not up to it yet?

should i try updating to the latest alsa via alsa repo’s?

You can try, although I am suspicious that the “stuttering” you are experiencing is due to pulse audio.

The guide for updating your alsa is here. Note there are 6 zypper commands you must send, and not 3. Many users make the mistake of sending only 3. You need to pick the exact 3 consistent with your openSUSE version and with your kernel version. Alsa-update - openSUSE

ok i don’t understand why is there pulse and alsa? are they both audio platforms or drivers?

Can i delete pulse and try just using alsa, or is there some other better thing?