ASUS Xonar DX :=> Headache

I want to know how to install this sound card in my Suse 11.0. Could be installated by Yast2???

I use this card under my SUSE 11 x64 I just added the alsa updated packages from repos:
-multimedia:audio
-multimedia:audio:KMP ->for the drivers

Yast shows it as CMI8788 (snd-oxygen) which is wrong cause it uses snd-virtuoso (the second and newest driver module from the oxygen driver family) and as a result it cannot array it and setup it properly.
I tried the idea to upgrade YaST2 packages to the SVN ones but still it recognizes it as a snd-oxygen card.
I use it cause somehow it just worked after I installed the new git packages and a restart from the 2 repos I gave you above!:wink:

Sound quality is excellent 24bit/192Khz works, as it should be cause the card can offer real high-end sound characteristics and not only at numbers:)

I was on vacation when you made your post and hence I missed it. I only saw this because of djdoo’s reply. You could try working your way through the audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

Be certain to install alsa-firmware, in case that is needed.

If you decide in the end you need to update alsa per djdoo’s advice, the link providing you guidance is here: Alsa-update - openSUSE

Alsa-firmware package is still at version 1.0.17 even at yesterdays git packages…
Could this be a problem causing YaST to recognize the card as an snd-oxygen one??

Furthermore I face another problem now and I need your advice, My PC cannot shutdown or restart properly cause the procedure stops when stopping the sound driver as it sais after init stops D-bus (which sais done).

Any idea why this happens?
I have the very latest packages for alsa installed and KMP drivers for kernel 2.6.25.18 as I always used to have with almost daily updates.
I tried to stop alsasound manually through YaST with the runlevel module but it sais uknown error!:cry:

You best start a new thread on that … your title “ASUS Xonar DX :=> Headache” is so general, it is not going to garner much attention.

why have you done that? Let me quote from the troubleshooting guide that I linked to: SDB:AudioTroubleshooting - openSUSE

be careful about applying further updates of alsa. The v.1.0.16 alsa rpms on this web site are very “cutting edge”, they are built regularly, and they could have recently introduced bugs that have not been fixed yet. Hence once you get your sound working, you may wish to remove this “cutting edge” multimedia repository (while still keeping the installed rpms).
Constantly updating day after day, when something does not work, in the hope that it magically will start to work, is NOT the way we do things with Linux.

After it did not work with the first update here, you should have posted asking for help. Now that things have deteriorated so badly that you can’t start your PC, there is not much that we can do until that is fixed.

Fix your problem with not being able to start your PC first.

No no! I can start the PC normally…

I just cannot STOP the sound driver!
If I choose terminate (runlevel 0) the shutting down procedure stops at Shutting Down Sound Driver step.
Then if you press Ctrl+Alt+Delete the procedure goes on and it unmounts filesystems and all but it just reboots the PC instead of hang this way and when it finishes I just press the power button once to shut down.

I update the packages all the time cause Xonar DX card is not fully supported yet so I am looking to see if any new features arrive in the fresh packages from git, that’s why…
I know the risks you are correct. I just asked if you could suspect anything about this… I also cannot playback 24bit/192Khz FLAC files I recorded with audacity from the line in of the card whereas at vista are playable normally but it seems I can fully record 24bit/192Khz samples with alsa.
Very strange…

IMHO a better way to do this is to write a bug report, so that the dev (developer) will tell you when there is an update you should try.

Well to tell you the news I fixed the not stopping problem…
I searched which app was stuck and found out that was the ‘‘amixer’’ app!
I installed the package alsa-utils version 1.0.16 one from the standart suse 11 repo and everything works fine now!!

I just have the non 24bit/192Khz playback (at flac 24bit files) issue as I told you above (but audacity plays those files with ALSA:front output… strange)(maybe libxine has the problem?) and some features still not working(cannot be reached through mixer) such as bass redirection for small speakers and stereo upmixing to center-subwoofer also.

So do you suggest to talk directly to alsa guys in order to see the progress and offer any help??
Cause this card really worths it!:wink:

ok i have a headache with xonar dx on 11.1 64bit now :frowning:

on board sound works ok, i can choose to make the xonar as default card, but no sound, it also has the oxygen driver, but i can not configure it (no modules), apparently the xonar needs virtuoso driver. alsa firmware installed

does that mean i have to update alsa via Alsa-update - openSUSE because as it is now i have no options with which to edit the sound card in yast, is there something else i should be doing to get the card going ?

thank you help much appreciated :slight_smile:

i am using kde 4.1.3

rpm -qa | grep alsa
alsa-plugins-pulse-1.0.18-6.13
alsa-plugins-1.0.18-6.13
alsa-oss-1.0.17-1.43
alsa-oss-32bit-1.0.17-1.37
alsa-1.0.18-8.9
alsa-utils-1.0.18-6.4
alsa-firmware-1.0.17-1.42
ken@linux-zu8y:~> rpm -qa | grep pulse
libpulse0-0.9.12-9.5
alsa-plugins-pulse-1.0.18-6.13
libpulse-browse0-0.9.12-9.5
pulseaudio-utils-0.9.12-9.5
pulseaudio-module-x11-0.9.12-9.5
pulseaudio-module-lirc-0.9.12-9.5
pulseaudio-esound-compat-0.9.12-9.5
libpulse-mainloop-glib0-0.9.12-9.5
pulseaudio-0.9.12-9.5
pulseaudio-module-zeroconf-0.9.12-9.5
pulseaudio-module-jack-0.9.12-9.5
libpulsecore4-0.9.12-9.5
libxine1-pulse-1.1.15-20.8
pulseaudio-module-bluetooth-0.9.12-9.5
ken@linux-zu8y:~> rpm -q libasound2
libasound2-1.0.18-8.9
ken@linux-zu8y:~> uname -a
Linux linux-zu8y 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux
ken@linux-zu8y:~> cat /etc/modprobe.d/sound

options snd slots=snd-hda-intel,snd-oxygen

AMUB.hJ2fTVR7hHD:Virtuoso 100 (Xonar DX)

alias snd-card-1 snd-oxygen

wRyD.7ISuh_cLQF9:MCP51 High Definition Audio

alias snd-card-0 snd-hda-intel

I don’t understand this. Sound works? or sound does not work?

Can you explain more about your sound hardware setup. How about, with your PC connected to the internet, you run the script:/usr/sbin/alsa-info.sh
and post here the output URL it provides.

the on board sound works eg. the motherboard sound, but i get no sound from my add in asus xonar dx pci-e sound card, it probably needs the correct drivers as the original poster said, yast sees them as oxygen drivers, but i think xonar card needs virtuoso drivers. anyway no sound from the xonar dx

/usr/sbin/alsa-info.sh

it first asks if i want to install a new version of alsa, should i do this first ?

I do not think it asks that :slight_smile: … Please read it carefully.

I believe what it asks is do you want to install a new version of the script “alsa-info” which is NOT the same thing as installing a new version of alsa !

If you are running alsa-info as a normal user, and select YES, it will fail to install the new version of alsa-info, as one needs root permissions to save updates to /usr/sbin . If you run alsa-info.sh with root permissions, then it will update the script.

Either is fine by me. You can

  • run the old version of the script as a regular user, and select NO to the update to the script, or
    *]run the old version of the script as user root, select YES to update the script, and after the script is updated, switch back to being a regular user and run the script again as a regular user
    In both cases your ALSA will NOT be updated. :slight_smile:

ok thank you, here it is :slight_smile:

http://www.alsa-project.org/db/?f=84a9479a8c5fd258226f94713406e281b40009dc

i have checked all mixer and sound volumes, they seem ok, i just can’t choose the snd-virtuoso in yast, i think that is what it needs, just says no modules

OK, so I see your PC has a Nivida onobard sound card (ALC883) in IRQ 22 and the AV200 Xonar DX on IRQ 16 :


!!Soundcards recognised by ALSA
!!-----------------------------
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfe024000 irq 22
 2 [DX             ]: AV200 - Xonar DX
                      Asus Virtuoso 100 (rev 2) at 0x7c00, irq 16 

Reference loaded modules, I see from the script your PC does have the snd_virtuoso and snd_oxygen_lib modules loaded.

Did you try adjusting your mixer ? I note this:
!!-------Mixer controls for card 2 [DX]

Card hw:2 ‘DX’/‘Asus Virtuoso 100 (rev 2) at 0x7c00, irq 16’
Mixer name : ‘AV200’
Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right - Rear Left - Rear Right - Front Center - Woofer - Simple mixer control ‘Front Panel’,0
Mono: Playback [off]
Simple mixer control ‘IEC958’,0
Mono: Playback [on]
Simple mixer control ‘Analog Input Monitor’,0
Mono: 1 [100%] [0.00dB] Playback [off]
Simple mixer control ‘Stereo Upmixing’,0
Capabilities: enum
Items: ‘Front’ ‘Front Surround’ ‘Front Surround Back’
Item0: 'Front Surround’You have digital audio (IEC958) ON, … are you using digital audio ? What happens if you switch that OFF (put the setting back to its default value of this does not help) ?

I do not have a PC with 2 sound devices, so I have no hands on experience here. I note the script lists your sound devices as card-0 and card-2, but your /etc/modprobe.d/sound file lists them as card-0 and card-1.

What happens if you change your /etc/modprobe.d/sound file to:

options snd slots=snd-hda-intel,snd-oxygen
# AMUB.hJ2fTVR7hHD:Virtuoso 100 (Xonar DX)
alias snd-card-2 snd-oxygen
# wRyD.7ISuh_cLQF9:MCP51 High Definition Audio
alias snd-card-0 snd-hda-intel

then restart your PC, and try again to get your Xonar working.

You could also switch OFF your motherboard sound, and then try to get your Xonar card working.

You can also try running (with root permissions) “alsaconf” (no quotes) in addition to trying YaST > Hardware > Sound, although note both of those will clear out any custom settings in the /etc/modprobe.d/sound file.

A last resort would be to create a custom .asoundrc file, optimised for two sound cards.

you quote that o have digital audio on, where do i find that, i am at a loss with this

what do i do first? in yast
do i choose xonar as default device?
then what from there

see from the script your PC does have the snd_virtuoso and snd_oxygen_lib modules loaded.

yes but i am not able to edit the xonar card in yast, it says no modules

why is it so hard in linux?

It can be hard because the manufacturers provide no support for their hardware for Linux, and users are forced to rely on many hacks put together and organized as best possible.

Did you try the edit to the /etc/modprobe.d/sound file that I suggested?

Did you try switching OFF mother board sound in your BIOS like I suggested?