Asus Xonar DS card is not detected or configurable

I just installed Suse 12.2 and everything worked fine right out of the box.

OS: Linux 3.4.11-2.16-desktop x86_64
System: openSUSE 12.2 (x86_64)
KDE: 4.8.5 (4.8.5) “release 2”
Sound card: Asus Virtuoso 200 (Xonar DS)

Suddenly I have no sound. I checked Yast=>Sound and my card was listed along with another device ( not dummy output )

I decided to delete both and reconfigure my card. Now no card is detected.

I then tried to add my card. I checked off “Show List of Kernel Modules”, and selected Asus Virtuoso driver ( snd-virtuoso ) => Asus Virtuoso driver.

I have tried all three setup choices, Quick automatic setup, Normal setup and Advanced setup with possibility to change options. Each time I get the same error message. “An error occurred during the installation of Asus Virtuoso driver. The kernel module for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.”

I also ran sudo /usr/sbin/alsa-info.sh[size=2]. Here are some of the results.[/size]


 !!Kernel Information
 !!------------------
 
 Kernel release:    3.4.11-2.16-desktop
 Operating System:  GNU/Linux
 Architecture:      x86_64
 Processor:         x86_64
 SMP Enabled:       Yes
 
 !!ALSA Version
 !!------------
 
 Driver version:     1.0.25
 Library version:     
 Utilities version:  1.0.25
 
 !!Loaded ALSA modules
 !!-------------------
 
 !!Sound Servers on this system
 !!----------------------------
 
 Pulseaudio:
       Installed - Yes (/usr/bin/pulseaudio)
       Running - Yes
 
 !!Soundcards recognised by ALSA
 !!-----------------------------
 
 --- no soundcards ---

 !!PCI Soundcards installed in the system
 !!--------------------------------------
 
 !!Advanced information - PCI Vendor/Device/Subsystem ID's
 !!-------------------------------------------------------
 
 !!Loaded sound module options
 !!---------------------------
 
 !!ALSA Device nodes
 !!-----------------
 
 crw-rw----+ 1 root audio 116,  1 Nov 10 13:18 /dev/snd/seq
 crw-rw----+ 1 root audio 116, 33 Nov 10 13:18 /dev/snd/timer
 
 !!Aplay/Arecord output
 !!--------------------
 
 APLAY
 
 aplay: device_list:256: no soundcards found...
 
 ARECORD
 
 arecord: device_list:256: no soundcards found...
 
 !!Amixer output
 !!-------------
 
 !!Alsactl output
 !!--------------
 
 --startcollapse--
 --endcollapse--
 
 !!All Loaded Modules
 !!------------------
 
 Module
 snd_seq
 snd_timer
 snd_seq_device
 snd
 soundcore
 fuse
 af_packet
 nvidia
 firewire_ohci
 firewire_core
 usblp
 usb_storage
 crc_itu_t
 joydev
 sr_mod
 cdrom
 sky2
 skge
 i2c_i801
 floppy
 mperf
 button
 iTCO_wdt
 iTCO_vendor_support
 sg
 serio_raw
 asus_atk0110
 coretemp
 pcspkr
 microcode
 autofs4
 processor
 thermal_sys
 scsi_dh_rdac
 scsi_dh_emc
 scsi_dh_hp_sw
 scsi_dh_alua
 scsi_dh
 ata_generic
 ata_piix
 pata_jmicron
 

As you can see there are a lot of blanks. Is it possible the card died[size=2] and I need[size=2] a new one?[/size][/size] How can I fix this?

This card works fine here, though on 11.4. It’s supported in the kernel.

Question: does the card produce sound in Yast?
Question2: did you check the phonon settings in KDE?
Question3: do all the channels for the card show up when running alsamixer?

I got the card working!

Thanks for your attempt to help. I appreciate your effort. As to the questions, it was as if no card was installed. Yast was blank so, no there was no card to select to make a sound. Further, as I explained, it would not let me add or configure the card manually. It just gave the error message that I quoted in the first post.

In phonon there was a gray, non-selectable image of the card. The only selectable item there was Dummy Output.

alsamixer did not detect the card and only showed one channel for Dummy Output.

The solution was to boot into the system as root. The sound was fully functional for root, so immediately I thought it was a permissions issue. Still logged in as root I configured the card. I was pretty sure that when I booted in as a user I would still have no sound, and I would need to sort out the permissions. To my surprise everything works and is back to normal for users too.

This leaves me a bit mystified as to why logging into Yast as root did not work. Is it possible that I still have some lingering permissions issues?