Asus x53s problems


I own an Asus x53s laptop with windows vista out of the box, and for job related reasons I needed to have also Linux.

I decided to install Opensuse 11.0 (this was a year ago), and apparently everything works save for the sound and internet connections. I thought it could be driver problems, but according to some technical service shops I have consulted, the appropriate drivers are already installed (I managed to install the first I found with Yast), but they are not compatible with my hardware.

However, according to this web, everything is in fact compatible, so I am at a loss.

Details of the devices are:

Wifi: Intel(R) Wireless WiFi link 4965AGN
Net cable: Atheros L1 Gigabit Ethernet 10/100/1000 Base-T Controller.
Sound: Realtek High Definition Audio.

If these happen to really be not cmpatible, could you recommend another distribution of easy installation, which operates with KDE?

Thank you.

By the way, I´ve just tried following the troubleshooting guide here (the SDB Audio Troubleshooting), and I must stop at the step in which one is asked to reconfigure the sound card, as the model of mine is not listed.

I recommend you sort your internet connection first. Once that is sorted, I may be able to help you with your sound, but it is MUCH easier to sort the sound if you have internet access from that openSUSE boot.

Well, I dońt know if either I managed to fix the ethernet cable, or if it never really had a problem and I just assumed it had, but cable connection works.

Still working on wireless, though and not getting anywhere. I downloaded appropriate Windows drivers and tried doing “ndiswrapper” them, to no result.

Doing ndiswrapper -l gives:

l160x64 : driver installed
device (1969:1048) present (alternate driver: atl1)
l160x86 : driver installed
device (1969:1048) present (alternate driver: atl1)
netw5v32 : invalid driver!
netw5v64 : driver installed
device (8086:4229) present (alternate driver: iwl4965)

Which I think it means that I installed a couple of drivers just to see if they worked, but the only one which I know to be correct (netw5v32 as my Vista OS is 32 bit) doesn want to work.

Two additional questions: Could these drivers conflict? and if yes (beware, newbie and potentialy stupid question), how to uninstall them?

Another thing. I am not really sure, but I may have installed the 64 bit Opensuse 11.0 version. Could this be the reason why these things are not working.

Thank you for your help.

OK, so you have internet. Then I am going to assume your internet connection is working in the following …

Now the general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide:SDB:AudioTroubleshooting - openSUSE but you noted you had problems with that.

Please do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will ask you if you wish to share the information (select YES) and it will post its output on the Internet/web. And when finished it will give you the URL of the web site where the information is posted. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a detailed recommendation. (but try the alsa-firmware installation/reboot first)

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.