Asus WL-160N USB wifi adapter

Tying to get an Asus WL-160N working.

Yast didn’t detect the device so I downloaded this driver

RT2870USB(RT2870/RT2770)
from here
Ralink Technology: Linux

#Extracted
#cd to the driver directory
#make
#make install
#modprobe rt2870sta
#echo “alias ra0 rt2870sta” >> /etc/modprobe.d/rt2870sta

According to several posts I’ve read it works on most linux distros.
Linux wireless LAN support http://linux-wless.passys.nl

Yast still doesn’t show the device in Network Settings and Network Manager doesn’t show Wireless available.

The device sees my wifi hub tsgwifi but I’m too CL noob to get it working.

Can someone help from this point?

???

dv7t:~ # lsusb
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 004: ID 046d:c526 Logitech, Inc.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 004: ID 0b05:1731 ASUSTek Computer, Inc. ASUS 802.11n Network Adapter
Bus 007 Device 003: ID 046d:09b8 Logitech, Inc.
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dv7t:~ # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

" Nickname:"RT2870STA"ss ESSID:"11n-AP
Mode:Auto Frequency=2.412 GHz Access Point: Not-Associated
Bit Rate:1 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality:0 Signal level:0 Noise level:169
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

vmnet1 no wireless extensions.

vmnet8 no wireless extensions.

dv7t:~ # iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

ra0 Scan completed :
Cell 01 - Address: 00:1E:58:F3:22:AB
ESSID:“tsgwifi”
Mode:Managed
Channel:9
Quality:100/100 Signal level:-35 dBm Noise level:-87 dBm
Encryption key:on
Bit Rates:11 Mb/s
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK

pan0 Interface doesn’t support scanning.

vmnet1 Interface doesn’t support scanning.

vmnet8 Interface doesn’t support scanning.

Hi. I had a better luck with the seamonkey drivers . Goto rt2x00.seamonkey.org. Hope this helps

Thanks bcrisciotti.

I’ll have a look at these.

Update:

Flailing around I managed to get the card to connect to my local wifi hub WPA/PSK.

Here’s what I did after the above, I think.

Yast > Network Settings > Add > Wireless > Enable Device Control for Non-Root User > Module Name > rt2870sta > Finish

Bingo Network Manager now has Wireless enabled and I’m able to connect to my wifi router!

Here’s where I’m stuck again!

Reboot - No Wireless in NM :frowning:

To get it working again:
Yast > Network Settings > Add > Wireless > Enable Device Control for Non-Root User > Module Name > rt2870sta > Finish

Can some kind gru help me out with where Yast is supposted to be saving my wifi card setup so that it comes up after reboot???

Thanks in advance!

in the set-up, there is a section which asks you when you want the device activated, select from the drop-down menu

Andy

Yes I have selected At Boot but it doesn’t come up.

Pat

Try to start with the stick unplugged and use the traditional method ifup. Make sure you have smpppd installed. Then
insert the stick. It should be up. At least it happens to me. I use Kde so using kinternet helps me a lot in enabling the connection.

Thanks bcrisciotti !

I’ll give that a try :slight_smile:

No joy on the ifup idea.

I no longer get that option in Yast Network Settings.

Tried the OnHotPlug option still no joy:(

Yast Networking seems seriously crippled with openSuse 11 :frowning:

I’ve never had problems detecting and configuring network cards using Yast since starting to use Suse 9.

Hi,
I have the same ASUS adapter and have managed (with a bit of struggling) to get it running and starting automatically at boot time. If you are still having trouble just reply back and I’l let you know how to do it. But I’m picking you probably already have it working now anyway.