ASUS UX305CA + snd_hda_intel / power saving problem

Hello everyone.

I have already opened another thread concerning the ASUS UX305CA notebook.

Now I have encountered a problem using the soundchip of the device. Until now I have used the integrated speakers. But yesterday I tried using my headphones.

The problem is that the sound makes terrible noise when using the audio jack of the notebook. When using the headphones and the notebook is on battery you actually hear when the chip is being disabled (crackling noise) and enabled again because of the powersaving. When its disabled there is also background noise.
And once the battery is empty and you charge it again there are also interferences until the battery is full.

I have done some research due I found out that it has to do with the power saving options. What I can do is disabling the power saving for the soundchip. That works but is not the optimal solution.

Which options do I have beside disabling the power saving feature? The soundchip is very common I guess.

25: PCI 1f.3: 0403 Audio device
  [Created at pci.366]
  Unique ID: nS1_.pGdi04DQXKA
  SysFS ID: /devices/pci0000:00/0000:00:1f.3
  SysFS BusID: 0000:00:1f.3
  Hardware Class: sound
  Model: "Intel Audio device"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x9d70 
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x1cfd 
  Revision: 0x21
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xdf128000-0xdf12bfff (rw,non-prefetchable)
  Memory Range: 0xdf100000-0xdf10ffff (rw,non-prefetchable)
  IRQ: 128 (1859 events)
  Module Alias: "pci:v00008086d00009D70sv00001043sd00001CFDbc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=yes, avail=yes, need=no, active=unknown

Thanks in advance for your replies.

Am Wed, 06 Jul 2016 10:46:01 GMT
schrieb hihu <>:

> Driver Info #0:
> Driver Status: snd_hda_intel is active
> Driver Activation Cmd: “modprobe snd_hda_intel”
> Config Status: cfg=yes, avail=yes, need=no, active=unknown

from “modinfo snd_hda_intel”

parm: power_save:Automatic power-saving timeout (in second, 0 =
disable). (xint)

So you need to set power_save=0 as a module loading option to disable this

Add this line:

options snd-hda-intel power_save=0



or maybe better to an extra file like “/etc/modprobe.d/50-my_sound.conf”.

Make sure the file ends in “.conf” or it will be ignored.

After reloading the the respective module(s) (or restarting the machine in the
Windoze manner) this option will be active.

You can check the actual value with

cat /sys/module/snd_hda_intel/parameters/power_save

Never attribute to malice that which can be adequately explained by stupidity.
(R.J. Hanlon)

Thank you very much.

That helped me a lot. Now its working far better.

ps: How can I set the title to solved?

We don’t have such habit here, since what worked for you might not work for others having the same problem, and you cannot change the thread title anyway (unless you are a Forums Admin of course…).
You already stated that it worked for you, you can change the title of your reply if you like (as I did on this reply to the thread).
Keep having fun with OpenSUSE.