ASUS N61JV-X2: Suspend and HIbernate problems

I own an ASUS N61JV-X2 notebook PC. When I tried both the suspend and the hibernate separately, it did work in the respective manner, but resuming from a suspended or a state of hibernation results in a black screen with a mouse cursor.

How do I make resuming from suspension or hibernation work?

Please reply with step by step instructions. I am new to OpenSUSE 11.4 64 bit for GNOME.

Thank you.

Read here
SDB:Suspend to RAM - openSUSE

I suspect it’s connected to your graphics device. Is it a nvidia?

This sort of problem is not unusual and there is no one certain fix

Yes, I have a nVIDIA GeForce GT 325M with nVIDIA Optimus and an Intel HD IGP. I did not install the proprietary nVIDIA binary drivers because of my past experience with Ubuntu 10.10 64 bit Maverick Meerkat; nVIDIA does not plan to support Optimus in GNU/Linux.

I guess that I will not use the suspend or hibernate features anymore to solve my problem. Thank you.

If you didn’t install the nvidia driver then you are using nouveau.
It’s up to you of course
Much depends how much fiddling you are prepared to do and or re-installs

The driver should work
nVidia Driver via Repo in 11.3 & 11.4 - Guide


I have a nvidia card and the suspend recovers, but black screen (with nouveau and the proprietary drivers). The hibernation work like a charm though.

Did you add the


in the /etc/suspend.conf to disable the splash screen during suspend ?

I changed my /etc/suspend.conf file to reflect the splash = n code change.

I will test the suspend feature soon.

I do not want to install the proprietary nVIDIA binary drivers because I know that it will not work on my ASUS N61JV-X2 notebook PC because I have nVIDIA Optimus which is not supported by nVIDIA. Installing those drivers will result in a black screen, TTY console, or something worse after I reboot my computer.

I will test the hibernation feature soon as well.

I will let you know how it goes.

Thank you.

The suspend feature works now with the new code change. I will test the hibernation feature now. I will report back soon.

Resuming from hibernation does not work. It does hibernate correctly and it does turn off the electrical power from my notebook PC, but when I push the power button on my laptop it just displays the ASUS logo during POST and then the SUSE icon which leads to a black screen whereby I cannot do anything.

How do I solve this problem?

Thank you.

Resume from Hibernation should result in the grub boot menu again. And it’s because of this I don’t recommend using hibernation. Especially if you have windows on the machine as well. And quite frankly it’s as quick to come back from shutdown as it is from hibernation.

I have a notebook asus n53jf and there was suspend problem with usb 3.0
Try this (last script) : The Chakra Project - Forums / Sleep mode / suspend to ram doesn’t work now it works for me…

Anyone using hibernation has to be carefull indeed. But for me, since suspend doesn’t work (and that I feel very sorry about that because I prefer suspend to RAM than to disk), I have to revert to hibernation… :\


Your problem was going into suspend to RAM or getting out of it ?

Suspend to ram & suspend to disk. My pc wasn’t able to switch off after s2disk…Trying s2ram, i had the system halted on the black screen of console.
This is my experience with a new notebook with usb 3 port and nvidia optimus graphics.

As long as the suspend and resume feature works, that is all that I will ever need. I have Crucial 8.00 GB of DDR3 PC-8500 SODIMM SDRAM and I also have an Intel 2nd Generation 160.00 GB Solid State Drive so everything is super fast on my ASUS N61JV-X2 notebook PC. OpenSUSE is a little bit slower than Ubuntu, but it is still much much faster than Microsoft Windows 7 Professional 32 bit.

I am happy with OpenSUSE. I hope to keep this installation intact and upgrade when newer releases are made available to the general public in the near future.