ASUS N551VW how to set the display resolution


The issue is related to getting a laptop ASUS N551VW with desired display resolution and video drivers configured.
Intel® Core™ i7 6700HQ Processor, Skylake
Intel® HM170 Chipset
UHD (3840 x 2160)
NVIDIA® GeForce® GTX 960M
integrated Intel® HD Graphics 530

The BIOS does not allow choosing or switching between the graphic cards.

The installation of Opensuse LEAP 42.1 went nicely with default settings and the display was set at 3840 x 2160 by default. Any attempt to reset it afterwards to desired lower resolution in KDE5 or Gnome fails. On every next login into graphical environment, it simply gave a black screen.
Then I tried Tumbleweed as it is shipped with recent kernel. The installation with default settings hung just before opening graphical YAST console (by the way the same hung with LEAP 42.2 beta). So I tried with ‘nomodeset’ option and 'acpi_osi= ’ in boot options (the acpi_osi= to have my touchpad working, which fortunately was possible with xf86-input-synaptics library).
Now the installation and login into graphical desktop went in predefined resolution but graphics is extremely sluggish and could not be used at all.
My asking is how to set the Operating System to use desired resolution of the display (1920x1080 or 1980x1440) with desired video graphic module running in order to have the composite desktop environment switched on.
Thank you in advance.

Hi, writing this from an N551JW with no problems… but with an** i7 47**20 and 1920x1080 native resolution. So I think you face two problems.

  1. the SkyLake processor.
    It needs at least a 4.3.x kernel, so no dice with the stock 4.1.x on Leap 42.1 but the (upcoming) 42.2 with a 4.4.x kernel or the current Tumbleweed at 4.7.x should both be OK.

  2. the UHD (3840 x 2160) graphics.
    Here Gnome-settings > Displays offer several choices from the native 1920x1080 down to 800x600, so I wonder if you have problems in your X11 driver stack.
    If that fails, you may check Gnome-settings > Tweak Tool > Windows tab > HiDPI Window scaling: setting it to 2 should scale all graphics to the equivalent of 1920x1080.

If you prefer KDE Plasma5 wait for somebody else to answer :wink:

Thank you for your reply.

Unfortunately i have already tried unsuccessfully the steps you advice.

  1. As I wrote in my initial post I had installed Tumbleweed , which carries the most recent kernel with it, so it should work fine with Skylake.
    The problem is that installing it step by step just clicking next, it hung between stages of getting IP address and starting graphical YAST installer interface.
    So putting “nomodeset” in boot option line together with desired resolution configuration from popup menu F3 before staring installation overcame that obstacle and installation itself passed fine keeping predefined resolution.
    After finishing installation process logging in graphical desktop is also fine but everything is extremely sluggish, I recon the “nomodeset” uses none of the video cards but kind of software emulation for drawing the desktop. So it is useless for day to day usage unless there is a way the X-server to be transferred to use some of the video cards for drawings.
    The trouble comes that for some reason the installation process can not go to correct video kernel module along with desired resolution configuration .
  2. Actually installation of LEAP 42.1 went much easier without need of setting it to nomodeset, which is strange having in mind that its kernel does not go quite well with Skylake CPU. Logging in KDE or GNOME is as expected and allows to change resolution settings to lower ones, but at every next logging in any graphical desktop it just produce a black screen. Obviously the settings are accepted but for some reason the system can not switch into new resolution configuration successfully.

And my question is what configuration should be putted in boot options entry at pre-installation stage so the desired resolution and correct video module to work successfully for getting up composite graphical desktop at the end.
If there is another work around way i will be more than happy to let me know.

Don’t know about UHD. For two video cards I understand that you need bumblebee or NVidia prime to switch. Just guessing…

Confirming that, but as installed the Intel Integrated graphics should work OK, although at a slower speed; but Skylake graphics had problems with the Intel driver in kernels up to 4.3.x.
Once the basic graphics works, Bumblebee or suse-prime with the proprietary NVIDIA driver should be installed for maximum performance; please note that the open source nouveau driver doesn’t support your rather new NVIDIA chip yet.

Just wondering… since you installed with the “nomodeset” option, it is likely that the installer configured “nomodeset” for the regular boot too, which should not be needed AFAIK.
Try looking at the kernel command line (press “E” at the GRUB screen, look for a line beginning with “linuxefi”), if you see “nomodeset” there, try deleting it, then press F10 to boot.
If it boots to the modesetting (Intel) driver, you may change the boot command line permanently in Yast2-Bootloader, in the “Kernel parameters” tab.

If that doesn’t work, maybe some “i915.xxxx” option might be in order; but as said I have no Skylake nor UHD so I cannot help you there.

In my search I came across this forum posts
I guess this should work in Opensuse.
I had succeeded to install Ubuntu 14.04 initially with first usage of the laptop few months ago . It was with DOS preinstall when I purchased it.
I have noticed that for the first few booting Ubuntu used NVidia card then it switched to Intel by itself with no announce or indication. The thing to go with Ubuntu was that thouchpad not working issue with Opensuse LEAP 42.1 and 13.2.
Ubuntu managed to work just fine out of box. But then the shutting down and rebooting the machine got problematic over time for some reason and it usually had to be done the hard way.
So I decided to upgrade to 16.04 in order to solve the issue eventually and then I got stucked with new problem which does not existed before.
Going into GUI of the installation screen of Ubuntu (same with Fedora) only the upper one forth of the screen showed the GUI screen scaled to new size but it was not usable for the artefacts the cursors leaves.
Opensuse was the only one to produce normal working full screen image of the GUI .
And I came to the conclusion that I have to instruct the booting process which video card to use and now it come clear also which driver to load for it.
It seams something prevent the OS from fallling to the right combination.