ASUS Laptop freezing after a few days of uptime

Hello, I’ve been using OpenSuse 13.2 on my ASUS laptop for about a year now. Recently, my laptop has been freezing after what seems to be a few days of uptime. Every time it freezes I’m forced to press & hold the laptop power button to turn it off.
It seems to occur when I’m working on some java project in Eclipse. I’m not sure if that is the cause or not, it just happens to be open when my laptop freezes (among other programs like Firefox, VLC, pdf viewer, etc…). However there is a suspicious line in my journalctl log that leads me to believe otherwise.
In my journalctl these are the last few lines before the most recent freeze occurs (JavaMOD is the name of the java perspective in my Eclipse):

-- Logs begin at Tue 2014-11-25 11:41:07 EST, end at Sat 2016-03-05 00:17:56 EST. --
Mar 04 18:46:50 gnome-session[1287]: Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x28004cf (JavaMOD - )
Mar 04 18:45:02 systemd[16485]: pam_unix(systemd-user:session): session closed for user root
Mar 04 18:45:02 CRON[16483]: pam_unix(crond:session): session closed for user root
Mar 04 18:45:02 systemd[1]: Cannot add dependency job for unit systemd-udev-root-symlink.service, ignoring: Unit systemd-udev-root-symlink.service failed to load: Invalid argument. See system logs and 'systemctl status systemd-udev-root-symlink.service' for details.

I haven’t been keeping track of the journalctl during the previous freezes so I can’t draw any conclusions as to what might be causing the problem.

I also had a remote ssh session open on my other computer which was running top to see if there was any programs that were consuming a lot of resources, however I’m not seeing anything unusual in the attached pic (taken while my laptop was frozen):

I’ve been updating constantly and yet these freezes still occur, any help is much appreciated!

In my experience,
Any/all heavy Dev apps (and that would definitely include Eclipse) cannot be left open indefinitely.
You’d have to understand that Dev tools are built to do things that aren’t normally permitted. In fact, just leaving these tools open while doing normal activity (like extensive browsing the Internet) might expose you to malware which ordinarily wouldn’t affect a normal User doing normal things.

Besides that, Dev apps aren’t usually written with attention to, or certain settings like memory usage a garbage collection might be modified intentionally, possibly causing memory leaks. For performance reasons, Dev tools might even be given a default higher priority setting which could exacerbate any normally small issues.

My general recommendation is to open and use your Dev tools only when you’re actually working. Suspend or better yet close Dev tools when not being used.


I had dismissed Eclipse as just a glorified text editor before, but now that you mention it, I can see how resource intensive Eclipse may be (especially while also running services such as Tomcat & mySQL).
I should have also mentioned in my first post that I was using Gnome 3.14. I have recently updated to 3.16 and so far things seem stable, however I will follow your advice and close all development tools when I’m not using them, and will report back if things freeze again.

Thank you for your reply

Just had another freeze-up, this time the only expensive program I had open was Firefox with a youtube video playing.

Checking my journalctl I see an ungodly amount of warnings (1001 lines! all occurring at the same time):

gnome-session[1281]: (gnome-settings-daemon:1535): housekeeping-plugin-WARNING **: Failed to enumerate children of [paths here]: Permission denied

Almost all of these warnings seem to point to files in /var/tmp and /tmp (these folders do not seem to be large enough to cause problems. /tmp is 77.9MB and /var/tmp is 12.5MB)

There are also a lot of SFW2-INext-DROP-DEFLT messages that seem to pass through my wireless nic (is this normal?).

I also see a warning during the boot process, which says something about checking systemctl but it passes too quickly for me to note the full command it gives and boot.log doesn’t seem to say anything about this.

I have a feeling that I should just reinstall everything at this point, but is there anything I should do first before resorting to this?

Don’t really know if it might be related, but that just reminds me of something I witnessed last year while running OS 13.2 on a tight /root partition.
IIRC that was due to (unneeded) BTRFS snapshots filling up /root, highly fragmented, large (>30 MB) journal files leading to a lot of seeks on the (slow) spinning drive, and occasionally a large wpa_supplicant.log being filled up with WiFi warnings / errors.
If this is your case too, maybe checking free space on /root, deleting unneeded snapshots, deleting the current journal log (and any unneeded logs as well) and deleting the current wpa_supplicant.log might help you.

Since you are using Gnome 3.16, please be aware that on Leap the gdm display manager was “downgraded” to 3.14.2 because of some problems with gdm 3.16 and the current Xorg seen during beta testing. Again, I don’t really know if that might be related.

My journal file was 4GB so I figured out that changing the SystemMaxUse parameter in /etc/systemd/journald.conf limits the maximum journal file size. I set it to 200M and now the journal file seems to be hovering around 112M. I’ve also cleared all but my current snapshots using snapper.

wpa_supplicant.log doesn’t appear to be taking up a lot of space so I just left it alone for now… If I freeze again then I’m going to truncate this file then downgrade Gnome back to version 14.

Things seem to have stabilized for now, however there are a few lingering things that I’ve discovered:
running dmesg -l err

    3.833845] systemd[1]: Failed to start Load Kernel Modules.
   14.487465] intel_soc_dts_thermal: request_threaded_irq ret -22

however when I run systemctl status systemd-modules-load.service

systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)
   Active: active (exited) since Tue 2016-03-08 12:01:28 EST; 2min 4s ago
     Docs: man:systemd-modules-load.service(8)
  Process: 382 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=0/SUCCESS)
 Main PID: 382 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/systemd-modules-load.service

everything appears to be OK.

And running *journalctl -b -p err *doesn’t report any errors since last boot
[EDIT] initially it did, however after running zypper dup and running “systemctl enable bluetooth.service” these errors seem to have disappeared

I’m beginning to suspect that maybe I’m using the wrong kernel or something. The version I’m currently using is: 4.4.4-1.g0c1f87e-default, should I revert back to another version?

Thanks for your replies

If you are using BTRFS on a spinning disk, this was surely clogging your disk with unnecessary seek requests (I wonder how fragmented that 4GB file might be…) and your new setting looks way more sensible for ordinary tasks. That alone might have slowed down your system so much at times that it seemed frozen. I remember experiencing cyclical such problems that disappeared when the Journal file eventually rolled over, just to grow again with usage.

So you are using OS 13.2 with a 4.4.4 kernel instead of the stock 3.16.7? That is not forbidden AFAIK, but I wonder why you don’t upgrade to Leap or Tumbleweed if you really need a 4.x kernel and Gnome 3.16… there are so many things that might go wrong, or at least have not been tested, with a configuration like yours.