Asus K50IN : No Sound No Graphic Driver

Hello all
I Have a Asus Laptop K50IN Series
and I have Installed OpenSUSE 11.1 today
But I can’t Find the Graphic Card Driver and the Sound
the Graphic Card is Nvidia Geforce G102M
and I Don’t Know what is the Sound card

Can You help me please
thanks alot

up…?

Welcome to openSUSE forums !!

Please note we are almost all volunteers, with day jobs. So sometimes it can take a day or two before someone responds to a post. :slight_smile:

You may wish to brush up on some basic openSUSE Linux concepts: Concepts - openSUSE

Reference your sound problem, you could try working your way through the openSUSE audio troubleshooting guide:
SDB:AudioTroubleshooting - openSUSE

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole

/usr/sbin/alsa-info.sh

Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

Reference the graphic driver, do you have a GUI, or just text?

You can tell what graphic driver your pc is trying to use by typing:

grep -i driver /etc/X11/xorg.conf

Note that:

  • vesa - the vesa driver. works on most graphic cards (nvidia, intel, ati), but is slow in performance. Comes with openSUSE.
  • nv - the open source (openGL) nividia graphic driver. Reasonable (average) performance in most cases. Comes with openSUSE.
  • nvidia - the proprietary nVidia driver. The best performance, but can be tempermental during kernel updates or xorg updates.

Please advise if you have no graphical desktop.

All my tries in the Sound Card Has been Failed

No No I have a Graphical Interface
I type in terminal : grep -i driver /etc/X11/xorg.conf
that what apear
Driver “kbd”
Driver “mouse”
Driver “fbdev”
I want to install Nvidia Driver
I am Sorry for My lating

OK, … then please, can you run the script I provided the command for and provide the output URL it gives. Also run the other commands and provide the output they give. The sooner you can do that, the sooner we can get your sound working.

OK, you are using a very basic / minimal driver known as the frame buffer driver (fbdev). Its very basic.

I recommend you reboot your PC, and when the green grub boot menu appears (where you select windoze, or openSUSE or openSUSE fail safe) select the openSUSE boot and press the “3” key (no quotes) to enter the value 3 in the options line. That will force a boot to run level 3, which is an text/ascii boot level.

When you get to the login prompt, log in as a regular user and enter your password. Then type ‘su’ (no quotes) and enter the root password in order to get root permissions.

Then backup your /etc/X11/xorg.conf file (just to be safe) noting that Linux the characters are case sensitive. You can backup by typing:

cp /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup

Once you have the backup, then try to see if the openGL nvidia driver will work. I suspect it will not, but its worth trying. You can do this by typing:

sax2 -r -m 0=nv

and if that works, exit sax2. Note it is slow so do not rush it. Note that assumes your PC has only 1 graphic hardware device. Note the last four characters in that command are “zero equals nv”.

Then restart your pc by typing “shutdown -r now” and this time do NOT type 3.

If that sax2 command does NOT work, instead try the VESA driver and type:

sax2 -r -m 0=vesa

and if that works, exit sax2. Note it is slow so do not rush it. Note that assumes your PC has only 1 graphic hardware device. Note the last four characters in that command are “zero equals vesa”.

Then restart your pc by typing “shutdown -r now” and this time do NOT type 3.

Please advise if your PC has more than one graphic card.

if I put the mice ,the sound will be run
but if I eject it will sound stop?? ; why laptop does not play the sound by it self
ok I will make your instruction for Graphic Card
I so so thank you
god bless you

I have no idea what that means.

Please, you will have to explain it more simple for me. …

sorry sorry
I mean when I put the Headset the sound will work

t
How…,
if that by typing in terminal
grep -i driver /etc/X11/xorg.conf
that what appear
Driver “kbd”
Driver “mouse”
Driver “vesa”
like first time

When you plug the headset in, the speaker sound is supposed to stop, and you should get sound out of the headset. Is that what happens? Or do you get no sound out of the headset?

This states that your PC is using the VESA driver, where the VESA driver is an open source free driver that works on almost every graphic card. It is robust in that it will survive a kernel update or an xorg update. But it is slow.

Please type the following (enter root password when prompted for a password) and pass here the output:
**su -c ‘sax2 -p’
**

From run level 3 (ie NOT from a GUI terminal, but booting a text mode after typing “3” (no quotes) in the grub menu) did you try with root permissions:
sax2 -r -m 0=nv

ie follow my recommendation from post#6:
openSUSE Forums - View Single Post - Asus K50IN : No Sound No Graphic Driver

That is the open source (openGL) nvidia driver, and it will give better performance than the vesa driver that you are using now.

… and please confirm you do have a graphical interface now.

I am Very Sorry for my poor English
I mean , The Sound not work from the first
but when I plug the headset the sound will be work

OK, that makes sence. From what have read, according to the alsa developers (where alsa is the sound driver used mostly in Linux), it is far easier to get sound working in a headset, than it will be in the speakers.

This should be fixable. :slight_smile:

BUT before we try to fix it, can you now confirm you have a graphical (GUI) interface?

Per post#6 above, can you please provide more information.

i.e. :

I can’t understand what this mean
I type

su -c 'sax2 -p'

that what’s appear

Chip: 0  is -> VESA Framebuffer Graphics        03:00:0 0x10de 0x0873 AGP fbdev

and I typed

sax2 -r -m 0=nv

appear to me sax2 faild to start or something like this

That tells me Linux does not recognize your graphic hardware.

like ??? That did not come thru.

… anyway, it is a mute (silent) point as clearly from ‘sax2 -p’ that sax2 does not recognize your Nvidia Geforce G102M hardware.

You probably have to stick with the VESA driver until either:

  • the openGL is updated to function with the Nvidia Geforce G102M or
  • you download and install a proprietary Nvidia Geforce G102M driver for Linux from nVidia.

You still did not answer my question (that I can find).

Do you have a GUI (desktop) with the VESA driver?

oh I lose the GUI

what does that mean? Please, I can not understand.

If you have no GUI yet, then try VESA at a lower resolution. ie :

sax2 -r -l -m 0=vesa
(where that is a lower case “L” and that is zero equals vesa).

Then restart and test.

If that does not work, you can also try the frame buffer display/driver again (which is pretty poor quality).

To do that simply (with root permissions) copy:
cp /etc/X11/xorg.conf.install /etc/X11/xorg.conf
and restart your PC.

Note to restart from an ascii/text prompt , one types with root permissions:
shutdown -r now
and to shut down one types
shutdown -h now

How I can Install Nvidia Driver