asus HD 5750 - Suse 11.3-64 bit, no desktop after one click install

I tried to install the easy way, the catalist driver.

I used this page:

SDB:ATI drivers - openSUSE

When I clicked the link, yast asked for the root password.

After ar reboot, no more desktop.

Then I did
init 3 adn startx ( it seems although I have no desktop, I am in runlevel 5)

xorg xserver 1.8.0
using config file: /etc/X11/xorg.conf
using config derectory: /etc/X11/xorg.conf.d

15 lines who only a slightly differ at the end.

(ww) fglrx: nomatchng device section forinstance (bus ID pci: 0@0:17.0
(ww) fglrx: nomatchng device section forinstance (bus ID pci: 0@0:18.0
(ww) fglrx: nomatchng device section forinstance (bus ID pci: 0@0:18.2

Fatal server error caught signal 11

xinit no such file or directory errno 2
xinit no such process errno 3

and a
segmatation fault at adress (nil)

I am totaly lost, but I am wondering.
My mobo support crossfire, but when you use one graphics card, you need to insert a (asus specific ?) card in the other pcie slot.
(to have you’re one card word at 16x)

I am wondering is Linux ( the driver) trying to make this insert card work?

because of the (ww) fglrx: nomatchng device section forinstance (bus ID pci: 0@0:17.0 etc.

Mobo asus M4A89GTD pro

It seems I did download the right driver because of this:

AMD video driver is running on a device belonging to a group targeted for this release.

I have a XFX Radeon HD 5670. I installed the same drivers and got the same problem. My mobo does not support crossfire so I do not have that extra card but I have an integrated graphics card. I have no idea how to fix this. :frowning:

Well then I can atleast rule out, it has anything to do with crossfire.

We probably found a bug.

I just did the same thing and got the same results(no more desktop).

I get this:

WARNING: GdmDisplay: display lasted 0.174459
gdm[3859]: WARNING: GdmLocalDisplayFactory: maximum number of x display failures reached: check x server log for errors

:’( New to OpenSUSE, I have used Ubuntu causally for a few years now. This is no fun, because I have no clue how to fix it and I just spent hours today setting up my new opensuse.

You can always try this.

SDB:ATI troubleshooting - openSUSE

I am posting here to try and find out what is wrong with the one click install, so other won’t have the same problem.

I found a kdm log file.

It says it can’t find flgrx module.

I am now gonna check

/etc/x11/xorg.conf

Follow the instructions at openSUSE Lizards » ATI HD57xxx fglrx drivers under 11.3. Worked for me.

Thanks, but right now I am trying this one.

https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_cat86-inst.html

I dowloaded the driver with windows, but right now, have a problem starting the installer, from the windows harddisk. It starts but then quits, complaining about no permision, although I am root.

And I found out, that Suse is not mounting one partion, I made during install.
I am now gonna edit the fstab file, and then try again.

Maybe I need to do chmod on the installer.

I guess once I reinstall I will give the openSUSE Lizards » ATI HD57xxx fglrx drivers under 11.3 method a try. Thanks

I re-installed SUSE 11.3

Then follows this page, and used Yast, I did no have the guts to try the one click install again.
SDB:ATI drivers - openSUSE

After a reboot the catalist drivers were installed, I now have 3D support.

I tested it true the command line with glxgears

Display
Leverancier: ATI Technologies Inc
Model: 0x68BE
2D-stuurprogramma( driver): fglrx
3D-stuurprogramma(driver): ATI

Opensource FPS here I come. Like Nexeus

Hi,

my experience on openSUSE-release 1.0.2-244.2 64 bit and KDE 4.5.2 “release 2” after updating to kernel 2.6.34.7-0.3-desktop x86_64
with ATI Radeon HD 3200 Graphics and ati-driver-installer-10-9-x86.x86_64.run installed

GUI loaded but no 3D acceleration and odd effects.

solution

  • ati driver uninstalled
  • ati driver installed from repository (re-install of run file produced errors)
  • renamed file /etc/X11/xorg.conf to /etc/X11/xorg.conf-101009 (rename name not relevant)
  • rebooted (hay-presto, all worked)

System now works happily without an xorg.conf file.

I had two problems with the 10.9 Catalist drivers.

Installing the 10.10 beta solved this.

Problem one, black boxes in firefox, and number two even worse, when hitting ctrl alt F5 and F7, I could not read the command line, becasue the screen was too distorted.

Leaked 10.10 beta Drivers:
Catalyst 10.10 Beta für Linux - Treiber - ATi-Forum.de