Asus G50v - OpenSuse 11.2 - No Sound on headphones

Hi,

I have a problem with my notebook: Asus G50v.
All is working fine except sound in headphones; my sound in speakers is fine.
Also, home, I have another external SB: SB Live! 24-bit External
This one is working fine.

I did run /usr/sbin/alsa-info.sh, but when I did upload, do not show me the link (only I have the bellow messages):
Your ALSA information is located at
Please inform the person helping you.

I did save the information, but is 33Kb file; I don’t know how share the information.

The others commands results:

rpm -qa ‘alsa

alsa-utils-1.0.21-3.1.i586
alsa-plugins-1.0.21-3.3.i586
alsa-1.0.21-3.2.i586
alsa-devel-1.0.21-3.2.i586
alsa-oss-1.0.17-25.2.i586
alsa-firmware-1.0.20-3.2.noarch
alsa-tools-1.0.21-2.5.i586
alsa-plugins-pulse-1.0.21-3.3.i586

rpm -qa ‘pulse

pulseaudio-module-gconf-0.9.19-2.3.i586
libpulse-browse0-0.9.19-2.3.i586
pulseaudio-module-x11-0.9.19-2.3.i586
pulseaudio-module-zeroconf-0.9.19-2.3.i586
pulseaudio-utils-0.9.19-2.3.i586
libxine1-pulse-1.1.16.1-7.6.i586
libmpg123-0-pulse-1.9.1-0.pm.3.1.i586
libpulse0-0.9.19-2.3.i586
alsa-plugins-pulse-1.0.21-3.3.i586
libpulse-mainloop-glib0-0.9.19-2.3.i586
libpulse-devel-0.9.19-2.3.i586
pulseaudio-module-lirc-0.9.19-2.3.i586
pulseaudio-0.9.19-2.3.i586
pulseaudio-module-bluetooth-0.9.19-2.3.i586
vlc-beta-aout-pulse-1.1.0-2009110802.1.i586

rpm -q libasound2

libasound2-1.0.21-3.2.i586

uname -a

Linux G50v 2.6.31.5-0.1-pae #1 SMP 2009-10-26 15:49:03 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-usb-audio

u1Nb.w3SAN3oGsLA:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

qhSX.TcjWR8fBM49:SB Live! 24-bit External

alias snd-card-1 snd-usb-audio

Thanks for help.

Gabi

Again sorry; just I did saw the comment in the other thread.
the link, for result of command “/usr/sbin/alsa-info.sh” is:
pastebin - Unnamed - post number 1672413

Hi,

I did solve the problem, following oldcpu’s advices from thread:
Macbook Core Duo/OpenSuse 11.2 - No Sound Headphone Port - openSUSE Forums
What I did:

run command
#> /usr/sbin/alsa-info.sh --no-upload
search in generated file for section:
!!HDA-Intel Codec information
!!---------------------------
–startcollapse–

Codec: Realtek ALC663 <----- on this line is codec’s name
In the file from address:
http://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt
you will find the codec, in my case “ALC663”

Next, I did edit conf. file
/etc/modprobe.d/50-sound.conf with command:
#> gnomesu gedit /etc/modprobe.d/50-sound.conf

and I did add first line; the content of my file is:

options snd-hda-intel model=asus-mode3
options snd slots=snd-hda-intel,snd-usb-audio

u1Nb.w3SAN3oGsLA:82801I (ICH9 Family) HD Audio Controller

alias snd-card-0 snd-hda-intel

qhSX.TcjWR8fBM49:SB Live! 24-bit External

alias snd-card-1 snd-usb-audio

Next I did restart sound system with command:
#> su -c ‘rcalsasound restart’

I did try all the model for asus but is working only with
m51va
asus-mode1
asus-mode3

Thanks to oldcpu for his advices!
Gabriel
:slight_smile:

Congratulations on sorting this. I confess I did not see your post yesterday (I was busy installing 11.2 on my main PC , which was an unintended change of plans as I had planned to keep 11.1 on longer - but thats another story :slight_smile: … ).

If you get the chance, what you could do is write a bug report on openSUSE-11.2 “sound” component, noting your problem, and what you did to solve the problem. Also attach a copy of the alsa-info.txt file (you can get that by running " /usr/sbin/alsa-info.sh --no-upload " ) . The auto probe of alsa should have automatically configured for your card on 11.2, and it is suprising that it did not. There is guidance here for raising bug reports: Submitting Bug Reports - openSUSE

By raising a bug report you get the attention of the Novell/SuSE-GmbH packager for sound, who is also an alsa driver developer. Hence any fix they make as a result of reading your bug report (and they are VERY good at passing fixes “upstream” ) will benefit all Linux distributions.

Thanks once again for sharing your solution.

By raising a bug report you get the attention of the Novell/SuSE-GmbH packager for sound, who is also an alsa driver developer. Hence any fix they make as a result of reading your bug report (and they are VERY good at passing fixes “upstream” ) will benefit all Linux distributions.

Thanks once again for sharing your solution.

This not entirely my solution; thanks to you I arrived to solution; I’m not linux expert, just a big fan and supporter of linux.
I will try to raise a bug report; but I saw this is happenig also in FC11.

Wish I had seen the thread earlier, I could have assisted you.

I have a G50v and all aspects of the sound card work flawlessly.

In yast just set the sound card for asus-mode3.

Yast >Hardware >Sound >Edit > (Use Given Board Model) click Edit, enter asus-mode3 save the settings and enjoy.

brucecadieux, you and gpaunescu can “flip a coin” to see who gets to write the bug report! rotfl!

yes, your solution is more is to be done by configuration point of view; but still remain one question: there is also a mode named g50v, but not working; any about this?

Not sure if this thread is still open but I have a problem. My nephew did something to his laptop and we took it back to best buy and they couldnt help him. I have been able to restore his laptop ASUS G50v, but there is no sound or mic. If you use headphones there is sound. It says there is sound but there is none. Also going to the sound devices again it shows that there is supposed to be sound but there is none. Same thing with the MIC it says there is supposed to be there but it is not. Any Ideas? Thanks in advance for your help.

-AkWingnut

akwingnut, I almost missed this thread. It is often better if one starts a new thread.

Did you try the suggestions in this thread? Which was to change the /etc/modprobe.d/50-sound.conf file to read something like:

options snd-hda-intel model=asus-mode3
options snd slots=snd-hda-intel,snd-usb-audio
alias snd-card-0 snd-hda-intel