ASUS Eee 1005 HA Hotkeys


I’m trying to put up the standard hotkeys for my (old) ASUS 1005 HA in opensuse 13.1 XFCE. I managed to achieve most of this “manually”, which means by binding keys in the keyboard settings or installing packages (like xfce4-volumed).

So far I didn’t manage to set up the display and tochpad on|off toggle and of course the hotkey for “Super Hybrid Engine”. Although I think that the functionality in general should be there, since the eeepc_laptop kernel modul is running, I don’t know how to set this up.

What I found and what on the first sight seems to be a solution to all of this, was this package for Arch Linux

promising full functionality for all hotkeys. However, being relatively new to Linux and just getting to know opensuse, I have no idea on what to do with this Arch-package. I suppose I need to build some stuff, but do not know what and how.

Could anyone help me out?

Just a little update on what I tried so far:

Since I have no real experience in compiling from source, I tried to convert the tar.gz file from the AUR repo into a rpm package using alien. This worked in so far, that I did not receive any error messages. Same for the installation.
But after reboot, nothing has changed. I looked into the PKGBUILD file for dependencies and there it says:

depends=(acpid xorg-server-utils dmidecode)

I suppose this is not taken into account by alien, since only dmidecode was installed after the installation. I then added acpid and searched for xorg-server-utils but couldn’t find an exact expression. Seems like it is Arch-related…

Someone better informed than me will probably read the truth out of this: That I have actually no real idea of what I am doing…:wink:

So if anyone has any experience in compiling packages from other distros OR could recommend any other way to get the hotkeys to work properly, please let me know!