To preface everything that is to follow I have tried Ubuntu 8.04, Mint 4 and 5, Mandriva Live, Sebayon 3.5 and finally OpenSuse 11. I have yet to get the audio to work but I was able to get the Wifi to work half-assed on compiled madwifi drivers in Mint.

On to suse - here is what my lspci shows:

00:00.0 Host bridge: ATI Technologies Inc RS690 Host Bridge
00:02.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Graphics Port 0)
00:04.0 PCI bridge: ATI Technologies Inc Device 7914
00:05.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 1)
00:06.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 2)
00:07.0 PCI bridge: ATI Technologies Inc RS690 PCI to PCI Bridge (PCI Express Port 3)
00:12.0 SATA controller: ATI Technologies Inc SB600 Non-Raid-5 SATA
00:13.0 USB Controller: ATI Technologies Inc SB600 USB (OHCI0)
00:13.1 USB Controller: ATI Technologies Inc SB600 USB (OHCI1)
00:13.2 USB Controller: ATI Technologies Inc SB600 USB (OHCI2)
00:13.3 USB Controller: ATI Technologies Inc SB600 USB (OHCI3)
00:13.4 USB Controller: ATI Technologies Inc SB600 USB (OHCI4)
00:13.5 USB Controller: ATI Technologies Inc SB600 USB Controller (EHCI)
00:14.0 SMBus: ATI Technologies Inc SBx00 SMBus Controller (rev 14)
00:14.1 IDE interface: ATI Technologies Inc SB600 IDE
00:14.2 Audio device: ATI Technologies Inc SBx00 Azalia
00:14.3 ISA bridge: ATI Technologies Inc SB600 PCI to LPC Bridge
00:14.4 PCI bridge: ATI Technologies Inc SBx00 PCI to PCI Bridge
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:00.0 VGA compatible controller: ATI Technologies Inc M76 [Radeon Mobility HD 2600 Series]
01:00.1 Audio device: ATI Technologies Inc RV630/M76 audio device [Radeon HD 2600 Series]
05:00.0 SATA controller: JMicron Technologies, Inc. JMicron 20360/20363 AHCI Controller (rev 02)
07:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
08:01.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
08:01.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
08:01.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
08:01.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
08:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)

My built-in wifi card is in fact an Atheros 5007EG chipset. I tried using my Windows athXXX.inf file with a freshly installed ndiswrapper to no avail. As in modprobing it works without any erros but pulling the WIFI NIC in Yast asks if I want to modprobe the ndiswrapper…and still shows the AR242x 802.11abg Wireless PCI Express Adapter (Not connected)
BusID : 0000:07:00.0 interface as Not configured and wont let me do anything with it. I attempted to create my own interface and assign ndiswrapper as the module for it and it successfully knocked out my wired nic upon completion :\

I tried madwifi both through the 1-click install and by compiling my own for my kernel. Everything goes without a glitch I modprobe ath_pci and get squat. I tried the same thing of adding my own wireless interface and assigning madwifi to it without any luck.

No matter what I do I end up with

lo no wireless extensions.

eth0 no wireless extensions.

pan0 no wireless extensions.

What am I doing wrong ? What am I missing ? Anyone ? I am getting ready to give up on this **** laptop and use it with the cursed Vista it came with. >:(

try the madwifi drivers from here Index of /repositories/home:/schmolle1980 some people have reported better success with them


Ok got my madwifi-kmp-default-r3725+AR5007EG_2.6.25.16_0.1-2.6.x86_64.rpm Should I install it directly as rpm package or …?

you can install with zypper or YaST, the choice is yours :slight_smile:


Woohoo ! Thanks man - closer than I have ever been. I now have ath0 interface but…even though ath5k is blacklisted it showed it as the module chosen by Yast… I changed it to madwifi and still get only:

lo no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"" Nickname:""
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:1 Mb/s Tx-Power:17 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/70 Signal level=-96 dBm Noise level=-96 dBm
Rx invalid nwid:13 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

pan0 no wireless extensions.

Cant scan for networks…

change to traditional ifup, see if that works,if not, try changing the channel on your wireless router


My noob level is very high :frowning: How do I change to standard ifup exactly ?

it’s under the global options in YaST- network devices - network settings


We have the same wireless card, and mine is working fabulously. I can’t explain the ifup stuff (as I didn’t ever need to learn it), but here is perhaps a simpler method. I would try removing the other modules or doing a fresh install first; just make sure there’s a kmp package on the build site (linked below) and you should be able to follow these instructions. Good luck!

Suse and Atheros wireless - openSUSE Forums

Have a lot of fun :slight_smile:

hmm…going to try again. Do you by chance have the same sound card as me ? :sarcastic:

nope, unfortunately not…

actually that should be FORTUNATELY NOT - I ahve exhausted every distro and setting including OSS 4 replacement of the the ALSA and still cant get the sound to work in any of the linux flavors on this cursed laptop. >:(

Sorry for the driver issues with the sound card! Is at least the wireless working now?

I assume you tried working your way through the openSUSE audio troubleshooting guide? (with no success):
SDB:AudioTroubleshooting - openSUSE

Hi there,

I also have an A7K.
I can confirm that I got wireless working nicely by following this posting.

openSUSE Lizards » Atheros AR 5007 EG on openSUSE 11.0
Took me a while to figure out that wireless card had a different MAC address than the Ethernet.

Sound of course doesn’t work and hasn’t worked since I got it last January.

Posted a bug during 11.0 beta, and have been following the progress of others in ALSA land. you can see my postings

I’ve also tried OSS4.0 and 4.1 without success.

Hopefully sound can get sorted in one of the 11.1 betas…

You have a real alsa guru helping you in that bug report thread. If anyone can help you, they can.

I assume you confirmed your sound hardware works with another non-linux os? (such as bsd or ms-windows ? )

Indeed. I did try to build alsa 1.0.14 from source against the kernel shipped in 11.0, but that didn’t work so well and I haven’t followed up with him.

I tried 1.0.17 again last night, but it appears that some 1.0.18rc stuff has leaked in there and doesn’t detect my sound card at all (rather than the current situation where it is detected, but no sound commeth forth)

I will give 11.1 beta a whirl when the live CD comes out, but given how hard its been to get wireless working I’m somewhat nervous. What version of alsa is 11.1 supposed to have anyways.

Laptop shipped with Vista and sound worked there. Boot sound works as well. Having followed some of the stuff in the OSS forum it appears as though there is a family of soundcards out there that only seem to have Vista working on them. boo.

I installed 11.1 beta1 on a Test PC last night. It has 1.0.18RC3 of alsa.

Just had a quick peak at the 1.0.18 changelog. looks like more notebook support was added by bodies at Realtek. Lets hope that the a7k is sorted.

Hopefuly 11.1B2 has live cds so I can test it out. Guess if it doesn’t work I’ll submit a bug report to Alsa rather than the suse forum

I read in the bug report that sound now works in 11.2 RC1 ? …

Hopefully the same will be true in 11.2 RC2 (released today) and also 11.2 GM (set for 12-Nov).