Asus A15 graphics problem

this is the output…

famnunezponce@localhost:~> rpm -qa | egrep -i 'nvidia|prime|nouveau' 
libvdpau_**nouveau**-20.3.5-273.1.x86_64 
libdrm_**nouveau**2-2.4.104-1.3.x86_64 
**nvidia**-gfxG05-kmp-default-460.67_k5.11.6_1-36.1.x86_64 
libdrm_**nouveau**2-32bit-2.4.104-1.3.x86_64 
x11-video-**nvidia**G05-460.67-36.1.x86_64 
**nvidia**-glG05-460.67-36.1.x86_64 
**nvidia**-computeG05-460.67-36.1.x86_64 
kernel-firmware-**nvidia**-20210315-1.1.noarch 
plasma5-applet-suse-**prime**-1.1-1.5.noarch 
xf86-video-**nouveau**-1.0.17-1.4.x86_64 
suse-**prime**-0.7.17-1.2.noarch 
Mesa-dri-**nouveau**-20.3.5-1230.2.x86_64 
famnunezponce@localhost:~> 



openSUSE installs nouveau drivers by default. Before installing Nvidia proprietary driver you have to uninstall nouveau drivers and blacklist them.
Then you have to reboot to get OS without nouveau being loaded.
Direct change nouveau -> Nvidia often has troubles and is not supported by Nvidia.

With nouveau and Nvidia drivers is being installed both you cannot use Nvidia GPU.

So: uninstall all, except libdrm_nouveau2, reload into command prompt (kernel parameter “3”), install Nvidia drivers only.

Try to use builtin GPU without external GPU to get some experience.

great! how do i install nvidia on command prompt…before i uninstall everything i have to know this of course :slight_smile:

Actually looking at what you have installed, the only thing that needs to be uninstalled is Mesa-dri-nouveau-20.3.5-1230.2.x86_64
You can do this from software management in yast and i suggest you block the package too. The installer asks if you want to do this if it detects an nvidia card in the first place so it;s safe to do and the nouveau driver itself is already blacklisted by the nvidia driver.

Now, i can help you with some debugging for this as my configuration is similar to yours but i need some info that i have no seen in the thread yet.
-the output of nvidia-smi (just type this in a terminal and it will output a table with some info)
-have you updated tumbleweed recently ? since i am on a fresh install i am on a newer kernel and nvidia driver.
-do you have the same issue with the external monitor in normal mode (as opposed to rotated) ?
-you mentioned the issue happens on a cold boot, restart and screen lock and that to solve it you need to reboot again. does rebooting a second time help ? since i suppose rebooting would present the same issue

I suppose you are running on the nvidia card all the time (even though this is an optimus laptop), did the external monitor work before installing the nvidia driver ? (this would tell me if the port you are using is connected to the nvidia card or the integrated one)

hi! thanks for your help…
first…

famnunezponce@localhost:~> nvidia-smi 
Wed May  5 23:19:50 2021        
+-----------------------------------------------------------------------------+ 
| NVIDIA-SMI 460.67       Driver Version: 460.67       CUDA Version: 11.2     | 
|-------------------------------+----------------------+----------------------+ 
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC | 
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. | 
|                               |                      |               MIG M. | 
|===============================+======================+======================| 
|   0  GeForce GTX 166...  Off  | 00000000:01:00.0 Off |                  N/A | 
| N/A   46C    P8     2W /  N/A |    545MiB /  5944MiB |      8%      Default | 
|                               |                      |                  N/A | 
+-------------------------------+----------------------+----------------------+ 
                                                                                
+-----------------------------------------------------------------------------+ 
| Processes:                                                                  | 
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory | 
|        ID   ID                                                   Usage      | 
|=============================================================================| 
|    0   N/A  N/A      2728      G   /usr/bin/Xorg.bin                 328MiB | 
|    0   N/A  N/A      2960      G   /usr/bin/kded5                     10MiB | 
|    0   N/A  N/A      2964      G   /usr/bin/kwin_x11                 117MiB | 
|    0   N/A  N/A      3014      G   /usr/bin/plasmashell               47MiB | 
|    0   N/A  N/A      3380      G   ...AAAAAAAA== --shared-files       33MiB | 
+-----------------------------------------------------------------------------+

second…
-have you updated tumbleweed recently ? since i am on a fresh install i am on a newer kernel and nvidia driver.

  • Yes, like a month ago. but it ask me so many questions when i do, so i decided stop updating my s.o.

third…
-do you have the same issue with the external monitor in normal mode (as opposed to rotated) ?

  • no, i don’t. it boots normally

fourth…
-you mentioned the issue happens on a cold boot, restart and screen lock and that to solve it you need to reboot again. does rebooting a second time help ? since i suppose rebooting would present the same issue

  • that’s another problem. I have to reboot when what you saw in the video I posted happens, and when i reboot, it happen the black screen thing…

fifth…
i suggest you block the package too.

  • how do i do that?

Go to yast software management, search for the package, right click and select delete - this will uninstall it
Once it is uninstalled you can search for it again and this time right click and select taboo - never install - this will block it from being installed in the future.

I will run a few tests with my laptop and external monitor now that i know what you got setup and get back to you. For the time being, uninstall that package as it may interfere with the nvidia driver.

I suggest you look into updating the system as well since there is a new kernel and a newer nvidia driver, not saying it will solve the issues on it’s own but with nvidia you never know…
I’ll be back later with my findings.

Well i have managed to test things out.

  • 1

i cannot reproduce the screen corruption in your video with either KDE or Gnome
this might be due to using the a different kernel/driver or it might be the difference in hardware

For reference i am using this:

CPU: AMD Ryzen 7 3750H with Radeon Vega Mobile Gfx (8) @ 2.300GHz 
GPU: AMD ATI 05:00.0 Picasso 
GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q

My advice there would be doing a zypper dup

  • 2:

Using two monitors with SDDM (the KDE login manager) seems to be wonky at best. You can sort of get it to work but it really does not like it when multiple monitors are present.
It seems to be a long standing issue that SDDM does not load the monitor configuration until after you log in, meaning anything you set in KDE display settings does not get applied to the login window.
https://blog.victormendonca.com/2018/06/29/how-to-fix-sddm-on-multiple-screens/ - this is a “how to” for the issue – as for my personal opinion you could probably just have the login window appear on the laptop screen since that is where you have the keyboard too and just disable the second screen. This way you will have the login prompt on the laptop screen, the second monitor black, and once you login the settings should be loaded from KDE so it will turn the external display on and set it with the correct layout.

I for one have not managed to have the screens work nicely together under SDDM apart from setting the external to off (rest of the time it was overlapping the screens - tbh the fact that i find reports of the same issue going back to 2013 tels me it’s not something that will be fixed).

On GDM (Gnome display manager) it works fine. All you need to do there is set your monitor configuration in gnome settings and after that do :

sudo cp ~/.config/monitors.xml /var/lib/gdm/.config/
sudo chown gdm:gdm /var/lib/gdm/.config/monitors.xml

After that GDM will respect the same monitor configuration from your desktop, rotation and all

I also tested waking from screenlock on KDE but that seems to work without issues - see point 1

On a personal note, i have given up on using the external monitor until nvidia get their stuff together and implement reverse prime with the amd combo. As it stands, i prefer to have the nvidia card in prime mode so i can run games on it if need be and just use the integrated amd one for the other stuff. Since most of these laptops have the external monitor connected to the nvidia card tho, driving that would involve running in full nvidia mode as you are doing - this kinda defeats the purpose of an optimus setup but is needed to have the external display.

Hope this helps.

I’m looking at SDDM w/ dual displays (2560x1440 & 2560x1080 side-by-side) boot now. I don’t see anything about it to make it totally unusable. The restart and shutdown buttons are only on the right side screen, while the session selection, layout, users & clock/calendar are on both. I don’t remember any special settings in /etc/sddm.conf.d/ to achieve this, only specifying particular users to be in the select list, and DPI. Logged in, the displays are stacked, 1440 primary below 1080.

That’s the thing, the login window is showing on both. I for one have not seen any way to configure it to show only on the primary or at least follow your cursor from monitor to monitor. With the monitors in landscape (as it is normally) it works fine, however, if you set one monitor to be rotated 90degrees in KDE, like OP did, the login screen still appears in landscape. Setting rotation and spacing in Xsetup for sddm results in the image for both displays being overlapped (as in not respecting where the second screen should start). Also since it treats the entire geometry as a single big display, i can end up scrolling with the mouse (by bumping into the edge of the screen) to areas of a square canvas that is not displaying anything.

While SDDM is the default for KDE, it isn’t required. Dual display users bothered by these foibles can switch to another, e.g. LightDM.

ok. so i tested with the “how to” mentioned above, same result.

how do i change from SDDM to LightDM?

can’t change to Gnome, because it works awful on my laptop (i also tried Cinnamon)… the only one that works pretty well is KDE…

Possibly you’re trying to use GNOME on Wayland. Try to use GNOME on X11.

sudo update-alternatives --config default-displaymanager

Or use YaST.

So my problem still remains, I don’t know what else I can do. I tried lightdm with no results. change my configuration also, without rotation on the second monitor, but the problem persists … I noticed that when I am in the login screen, the order of the screens is reversed, hdmi monitor is on the left physically, but in the login it set right …

Arghhhhh! Yet another typo. Even though in #15 xrandr --listproviders says it exists, I think it’s wrong WRT the actual connections used, because it also says eDP-1, which is what I meant to be tried:

video=eDP-1:1920x1080e

I think probably both actually exist at some point that depends on prime state, but the dual GPUs makes it tough for anyone not in possession of same hardware, e.g. me, to work with or suggest what to try.

Each try of a temporary change to the kernel command line reported here should probably be accompanied by uploading the latest Xorg.0.log with susepaste, so that it’s clear exactly what happened, without any opportunity for a misleading translation. A fresh run of xrandr --listproviders might be good as well.

Given the amount of trouble I’ve seen here and other forums and mailing lists with laptops and second displays lately I think this is yet another instance where a bug report makes sense. I suggested same in another thread here 4 hours ago, with instructions how.

Can you please post:

cat /var/log/Xorg.0.log
zypper se -si nvidia prime nouveau

(zypper needs no grep, zypper shows all you searched separated by a space)

/sbin/lspci -nnk | grep -EiA3 'display|3d|vga'

no problem. first the request of mrmazda:

famnunezponce@localhost:~> xrandr --listproviders 
Providers: number : 2 
Provider 0: id: 0x1b8; cap: 0x1 (Source Output); crtcs: 4; outputs: 2; associated providers: 1; name: NVIDIA-0 
    output DP-0 
    output DP-1 
Provider 1: id: 0x1e4; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); crtcs: 4; outputs: 2; associate
d providers: 1; name: modesetting 
    output eDP-1-1 
    output HDMI-1-1

cat /var/log/Xorg.0.log

https://susepaste.org/452759


famnunezponce@localhost:~> zypper se -si nvidia prime nouveau 
Cargando datos del repositorio... 
Leyendo los paquetes instalados... 

S  | Name                      | Type    | Version               | Arch         | Repository 
---+---------------------------+---------+-----------------------+--------------+---------------------------- 
i+ | kernel-firmware-nvidia    | paquete | 20210419-1.1          | noarch       | (Paquetes del sistema) 
i+ | libdrm_nouveau2           | paquete | 2.4.105-1.1           | x86_64       | Repositorio principal (OSS) 
i+ | libdrm_nouveau2           | paquete | 2.4.105-1.1           | x86_64       | openSUSE:Tumbleweed 
i+ | libdrm_nouveau2           | paquete | 2.4.105-1.1           | x86_64       | openSUSE:Factory 
i+ | libdrm_nouveau2           | paquete | 2.4.105-1.1           | x86_64       | openSUSE-20201114-0 
i+ | libdrm_nouveau2-32bit     | paquete | 2.4.105-1.1           | x86_64       | Repositorio principal (OSS) 
i+ | libdrm_nouveau2-32bit     | paquete | 2.4.105-1.1           | x86_64       | openSUSE:Tumbleweed 
i+ | libdrm_nouveau2-32bit     | paquete | 2.4.105-1.1           | x86_64       | openSUSE:Factory 
i+ | libdrm_nouveau2-32bit     | paquete | 2.4.105-1.1           | x86_64       | openSUSE-20201114-0 
i+ | libvdpau_nouveau          | paquete | 20.3.5-273.1          | x86_64       | (Paquetes del sistema) 
i+ | nvidia-computeG05         | paquete | 460.80-38.1           | x86_64       | nVidia Graphics Drivers 
i+ | nvidia-gfxG05-kmp-default | paquete | 460.80_k5.12.0_2-38.1 | x86_64       | nVidia Graphics Drivers 
i+ | nvidia-glG05              | paquete | 460.80-38.1           | x86_64       | nVidia Graphics Drivers 
i+ | plasma5-applet-suse-prime | paquete | 1.1-1.5               | noarch       | (Paquetes del sistema) 
i+ | suse-prime                | paquete | 0.7.17-1.3            | noarch       | Repositorio principal (OSS) 
i+ | suse-prime                | paquete | 0.7.17-1.3            | noarch       | openSUSE:Tumbleweed 
i+ | suse-prime                | paquete | 0.7.17-1.3            | noarch       | openSUSE:Factory 
i+ | suse-prime                | paquete | 0.7.17-1.3            | noarch       | openSUSE-20201114-0 
i+ | x11-video-nvidiaG05       | paquete | 460.80-38.1           | x86_64       | nVidia Graphics Drivers 
i+ | xf86-video-nouveau        | paquete | 1.0.17-1.4            | x86_64       | Repositorio principal (OSS) 
i+ | xf86-video-nouveau        | paquete | 1.0.17-1.4            | x86_64       | openSUSE:Tumbleweed 
i+ | xf86-video-nouveau        | paquete | 1.0.17-1.4            | x86_64       | openSUSE:Factory 
i+ | xf86-video-nouveau        | paquete | 1.0.17-1.4            | x86_64       | openSUSE-20201114-0


famnunezponce@localhost:~> /sbin/lspci -nnk | grep -EiA3 'display|3d|vga' 
01:00.0 **VGA** compatible controller [0300]: NVIDIA Corporation TU116M [GeForce GTX 1660 Ti Mobile] [10de:2191] (rev a1) 
        Subsystem: ASUSTeK Computer Inc. Device [1043:16cf] 
        Kernel driver in use: nvidia 
        Kernel modules: nouveau, nvidia_drm, nvidia 
--
05:00.0 **VGA** compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Renoir [1002:1636] (rev c6) 
        Subsystem: ASUSTeK Computer Inc. Device [1043:16cf] 
        Kernel driver in use: amdgpu 
        Kernel modules: amdgpu

I just stumbled onto a possible config option that might help. If does not already exist the file /etc/X11/xorg.conf.d/50-device.conf, then create it with this content:

Section "Device"
    Identifier	"Default Device"
	Option	"ReprobeOutputs"	"true"
EndSection

If the file already exists, then add the above “Option” line to it. If the file already exists but each line begins with “#”, then each “#” must be removed from the first, last and Identifier lines, or just replace the file. With all lines begining with “#”, it’s nothing but a template file, inert, unused. If the ReprobeOutputs option does not seem to help, try switching to a vtty and back, e.g. Ctrl-Alt-F3, Alt-F7, after turning the external display on or off, or opening or closing the lid.

i have a file named 90-nvidia.conf, i’ll try your solution and post the results…

ok. so, the problem persist… maybe is something on that file? (this is the 90-nvidia.conf file)


ection "ServerLayout"
    Identifier "layout"
    Screen "nvidia"
    Inactive "intel"
    Inactive "modesetting"
EndSection

Section "Screen"
    Identifier "intel"
    Device "intel"
EndSection

Section "Device"
    Identifier "intel"
    Driver "intel"
EndSection

Section "Screen"
    Identifier "modesetting"
    Device "modesetting"
EndSection

Section "Device"
    Identifier "modesetting"
    Driver "modesetting"
EndSection

Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
EndSection

Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    Option "DPI" "96 x 96"
    Option "AllowEmptyInitialConfiguration"
    Option "AllowExternalGpus"
EndSection

Section "Device"
    Identifier    "Default Device"
    Option    "ReprobeOutputs"    "true"
EndSection