Asus A15 graphics problem

hi, i have an asus tuf a15 with tumbleweed installed. where almost everything works fine… i’m new on the world of linux, planning to use it for work and gaming :-). I already read everything i can find trying to fix the problem, with no luck so far. so i really need some help.
this is my laptop:

I have the laptop monitor and a dell P2419H on vertical configuration. when i restart my laptop or turn on, the laptop screen is off, this happen every time i restart or turn on. also when i’m leaving 5 minutes and come back, the logon screen shows on both screens and if i click on the menu on laptop screen is also show the menu on dell screen, it’s unusable. so i have to restart again…
i upload this video to show you the problem.

also, someone(thanks for your help SJLPHI]( recommend me to paste the output from several comands:

famnunezponce@localhost:~> rpm -qa |grep -i nvidia 

famnunezponce@localhost:~> rpm -qa |grep -i nouveau 

famnunezponce@localhost:~> uname -a 
Linux localhost.localdomain 5.11.11-1-default #1 SMP Tue Mar 30 17:57:52 UTC 2021 (dbc4
a02) x86_64 x86_64 x86_64 GNU/Linux 

Thanks to everyone, looking forward for your responses… remember, i’m a newbie on linux XD

Disable the screen lock:
systemsettings5----Workspace behavior-----Screen locking

thanks for your answer, but that doesn’t solve the problem, because when i turn on or reboot the laptop, the other problem continues… like this:

Rather than trusting Plasma’s KScreen to handle displays, try disabling it (systemsettings > background services > kscreen 2), and use a global startup script (e.g. in /etc/X11/xinit/xinitrc.d/) instead, either generated manually, or using arandr. To work right it may be necessary to remove .local/share/kscreen/, and .cache/, while logged out of Plasma.

Also, through which connector is the monitor connected to the laptop? Depends on the connector, the monitor may be using one GPU or another. Also Mrmazda, can you actually give him a demo global starup script? The OP reached out to me earlier and he mentioned that he’s fairly new to Linux.

Arandr will write one.

Unless Optimus complicates it somehow, it will probably be something like:

xrandr --output eDP-1 --primary --output HDMI-1 --right-of eDP-1 --rotate left

Use simply xrandr to determine the actual output names.

great, thanks to all of you. i’ll try this and get back to you…

the dell monitor is on HDMI port…

well, this is the result of trying with xrandr:

At this point I am guessing that the optimus complicates things a bit but I don’t have a clue if my bumblebee method would work for AMD+Nvidia, it works certaily for intel+Nvidia. may provide a boot parameter workaround until the root of the problem can be found:


First check xrandr to confirm the laptop screen output name is indeed eDP-1, then if so, see if forcing the display on helps:


If it doesn’t, I have to think you’re up against Optimus, for which I can’t really help, due to lack of Optimus hardware for hands on testing.*

Give a read and if you want to try bumblebee, try this:

My methods have only been tested for Intel+Nvidia Optimus for machines as recent as Lenovo T480. I cannot tell you if it would work at all for you. Also the bumblebee approach is high maintenance right now because you need to compile and keep overwriting libvglfaker with the one you compile everytime VGL gets updated. I’ve been bugging the developers about fixing the VirtualGL, it seems to have fallen in deaf ears since even after almost 5 months the devs haven’t fixed it.

first of all, thank you all for your responses. i can’t test your solution, because i’m new on linux world, so i can’t do that thing with libvglfaker, i don’t know how to do it and less give it maintenance… i’ll keep reading about this issue, and maybe i’ll find a simple method to be tested by a linux newbie XD.

i’m sorry, i read the .txt and your answer, but i don’t understand how to do it and where*

Oops! Assuming eDP-1 is the correct internal display output name shown (using e.g. Konsole) by any of

  • xrandr
  • xrandr --listmonitors
  • xrandr --listproviders
    it should have been:

This you apply by striking the E key when the Grub menu appears, and adding it to the end of the line that begins linu (which usually is wrapped). If it works, then it needs to be added into the file /etc/default/grub on the GRUB_CMDLINE_LINUX_DEFAULT= line, right before the last ‘** " **’. You can make this change using YaST Bootloader (the easier way), or with any text editor as root or via sudo (the harder way). Also if it works, a bug should be reported.

can you give me step by step how to do it with yast please? what is a grub menu?
this is my result to xrandr --listmonitors

famnunezponce@localhost:~> xrandr --listmonitors 
Monitors: 2 
 0: +*eDP-1-1 1920/344x1080/194+1080+840  eDP-1-1 
 1: +HDMI-1-1 1080/527x1920/296+0+0  HDMI-1-1

and this to xrandr --listproviders

famnunezponce@localhost:~> xrandr --listproviders 
Providers: number : 2 
Provider 0: id: 0x1b8; cap: 0x1 (Source Output); crtcs: 4; outputs: 2; associated providers: 
1; name: NVIDIA-0 
    output DP-0 
    output DP-1 
Provider 1: id: 0x1e4; cap: 0xf (Source Output, Sink Output, Source Offload, Sink Offload); c
rtcs: 4; outputs: 2; associated providers: 1; name: modesetting 
    output eDP-1-1 
    output HDMI-1-1

When a PC boots, usually the first thing that shows up on screen is an identification of the Computer’s or the motherboard’s manufacturer. There may or may not follow some POST messages produced by the BIOS. Next up is a menu produced by Grub, which presents boot options from which to select, first of which on your A15 would be Tumbleweed. When this appears, strike the E key to temporarily modify how boot will proceed according to the addition you will make on the linu line’s end.

First lets see if a temporary change solves your problem. Add this after striking the E key at the Grub menu, as described in post #14:


hi, i’ve done what you ask, with no result…

The suggestion should have been more like:

rpm -qa | egrep -i 'nvidia|prime|nouveau'

OP has what is generically considered to be “Optimus”, even though technically I believe it’s supposed to apply only to a combination of Intel and NVidia GPUs, while OP’s couples AMD with NVidia instead. Please have a read of There’s little I can suggest to help “Optimus” users, as I have no such hardware to work with, and I never use proprietary graphics drivers of any kind on Linux. If that Prime page or other forum posts on the subject of Optimus and Prime aren’t enough help for OP to figure this out on his own, he’ll need to capture the attention of someone who does have that experience, as I’m out of suggestions.

Thanks for your time. It helps me understand Linux a little more, but I already tried it with no results. so I’ll keep waiting for someone who has more experience, like you said before. Thank you. the problem remains, for all who read this thread …