Asterisk setup

hello , I ve just installed asterisk 13 in my opensuse 13.2 64bit machine , when I try to connect to asterisk console to setup new sip clients , (asterisk -r) I got the message

" Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?) " ; I tried to change setup in asterisk.conf no luck , in some forums it said

its a problem of ownship ; so I need your help guys , just the right configuration of asterisk.conf and some command lines to solve it …

Do these help?

http://www.voip-info.org/wiki/view/Asterisk+config+asterisk.conf
http://www.asteriskdocs.org/en/3rd_Edition/asterisk-book-html-chunk/additional_configuration_tasks-asterisk-conf-file.html

A minimal SIP configuration discussed here

http://www.rjsystems.nl/en/2100-asterisk.php

thanks for your reply , But it does not work yet , i think opensuse behaves differently from debian when it comes to config files

the documentation of the above links is based about debian or ubuntu , and I m using asterisk version 13 . i need the console to monitor the sip

clients and for testing too . I tried to chown the directories to asterisk user and nothing change still wont connect to console .

I’m not an asterisk user, but try running in console mode (with verbosity) like this

# asterisk -vvvc

Observe the output. Any errors/warnings reported?

thanks deano , I ve just compiled asterix from the source and installed it , in the source dir there is a folder called contrib it has a startup script for every major linux distro . I have of course chosen suse script . I was able to run asterix fine but i had to run it every time i boot the system . when I tried
to enable in mananger service it comes with an error . But it works and i was able to make my testings so thanks again …

Ok, thanks for the update.