Asterisk 1.4 with OpenSuse 11.0

I’m trying to set up a box with asterisk 1.4 WITH H323 support. unfortunately Asterisk is not happy with RPM versions of openh323 and when trying to compile from source I have errors for both openh323-1.18 and openh323-1.19. from some forums it seems to be an incompatibility between openh323 and GCC 4.3
Is there a workaround ?

I downgraded to OpenSuse 10.3 and it worked fine !

Sometimes the newest is not the best …