Associate VLC with .avi extension

Hi! I’m an opensuse noob, and I’m having trouble figuring out how to associate .avi files with VLC. In Yast, I’ve tried to use the custom command setting to start VLC instead of Totem, but a double click on any avi file starts BANSHEE instead of Totem OR VLC. No clue, here. I can’t find where to specifically associate a file extension with an application, as opposed to the very high-level settings in Yast.

Go to system settings - file associations. Put avi into search box, it should come up with ‘msvideo’ and ‘x-msvideo’, click on each and on the right is a list of associated programmes. Move VLC up to the top of the list. Click apply and exit.

Where are System Settings? I see “System” in Yast, and SYSTEM as a header under Control Center, but no System Settings anywhere.

Right click a .avi > properties > opens with and choose

I already did that. That’s the first thing I tried. Where are System Settings?

Are you sure, because this is the way
Is VLC radio selected when you open yours? Mine is set to SM Player

Yes, I’m quite sure. I’ve tried it several times, selecting VLC each time and checking the box to use it for all files with avi extensions.

Right click a .avi and go open with > vlc
Does the file start playing with vlc?

Yes. When I open with VLC and apply it as the app to open all AVIs, it opens it in VLC—once. The next time I double-click to open an AVI, it tries to open with Banshee again.

What version of openSUSE are you using and are you using kde or gnome?

11.3, GNOME

Then something is ‘Jeffed up’ in your settings.

Try this: open Yast > Security and Users > User and Group Management
Create a new user called Testing
Logout and login as new user Testing (You must have auto login disabled for this, and should have anyway)

Can you set the new user to work the way you want?

Nope–I just tried precisely what you suggested, and the same behavior holds.

You can delete that user now if you like.

If you open Control Centre > System > Preferred Applications
Under Multi-media (mine was blank until I clicked the pull down)
There were two options for me + Custom (Gnome Mplayer and Totem)
Now mine is set to Custom with nothing in the field.
Mine still works as expected.

I’m not sure what could be amiss with yours

Unfortunately, the only thing that has worked is uninstalling Totem and BAnshee. At least VLC is the default app now—because it’s the ONLY app. I’m disappointed; OpenSuSE seems so easy to use, but Kubuntu is still less buggy.

I have to tell you this is NOT normal

Ok, now I am trying to install Exaile to use for my music, but I’m having the same exact problem. When I try to associate .mp3s with Exaile, they are only opened in VLC. WTF? And WHERE is the system settings with the specific file extensions? I want to know where that is, so I can fix this issue for file types.

This is the way:
But you can’t seem to get it to work for you

Could this be an issue with user permissions? Do I need to chown and chmod my home directory?


You are logged in as a user not root?