assistant: symbol lookup error: /usr/lib64/ undefined symbol: _ZN14QWidgetPrivate15


I’m working on a small application with Qt for the UI and it worked fairly well so far. I haven’t been using my Linux OS lately for other reasons and came back today to find that some of the software on my system isn’t working anymore, given the error message from the title.
Before that, I have made a whole lot of automated updates to my Linux installation after booting.

assistant: symbol lookup error: /usr/lib64/ undefined symbol: _ZN14QWidgetPrivate15checkWindowRoleEv

// here’s an example for the Qt Assistant

Initially I thought only my own application is affected, but it seems to be a more general problem. Here’s the output of an ldd on assist, looks fairly normal to me:

ldd /usr/bin/assistant (0x00007fffa648e000) => /usr/lib64/ (0x00007f49ee45a000) => /usr/lib64/ (0x00007f49ec105000) => /usr/lib64/ (0x00007f49ebec4000) => /usr/lib64/ (0x00007f49eb1df000) => /usr/lib64/ (0x00007f49eaec7000) => /usr/lib64/ (0x00007f49ea9d1000) => /usr/lib64/ (0x00007f49ea6c8000) => /lib64/ (0x00007f49ea4b0000) => /lib64/ (0x00007f49ea108000) => /lib64/ (0x00007f49e9eea000) => /usr/lib64/ (0x00007f49e9bcf000) => /lib64/ (0x00007f49e98ce000) => /usr/lib64/ (0x00007f49e96c3000) => /usr/lib64/ (0x00007f49e946e000) => /usr/lib64/ (0x00007f49e9231000) => /usr/lib64/ (0x00007f49e8fd1000) => /usr/lib64/ (0x00007f49e8d92000) => /lib64/ (0x00007f49e8b7c000) => /usr/lib64/ (0x00007f49e8810000) => /usr/lib64/ (0x00007f49e8603000) => /usr/lib64/ (0x00007f49e83db000) => /usr/lib64/ (0x00007f49e8190000) => /usr/lib64/ (0x00007f49e7f45000) => /usr/lib64/ (0x00007f49e7cea000) => /usr/lib64/ (0x00007f49e79da000) => /usr/lib64/ (0x00007f49e7789000) => /usr/lib64/ (0x00007f49e747a000) => /usr/lib64/ (0x00007f49e71b2000) => /usr/lib64/ (0x00007f49e6f75000) => /usr/lib64/ (0x00007f49e6c75000) => /usr/lib64/ (0x00007f49e69e3000) => /usr/lib64/ (0x00007f49e66a5000) => /usr/lib64/ (0x00007f49e64a2000) => /lib64/ (0x00007f49e629a000) => /usr/lib64/ (0x00007f49e606c000) => /usr/lib64/ (0x00007f49e5db0000) => /usr/lib64/ (0x00007f49e5ba8000) => /usr/lib64/ (0x00007f49e598b000) => /usr/lib64/ (0x00007f49e5778000) => /lib64/ (0x00007f49e5574000)
        /lib64/ (0x0000564c44207000) => /usr/lib64/ (0x00007f49e534d000) => /usr/lib64/ (0x00007f49e50c9000) => /usr/lib64/ (0x00007f49e4e8f000) => /usr/lib64/ (0x00007f49e4c8b000) => /usr/lib64/ (0x00007f49e4a81000) => /usr/lib64/ (0x00007f49e481b000) => /usr/lib64/ (0x00007f49e45f1000) => /usr/lib64/ (0x00007f49e43c2000) => /usr/lib64/ (0x00007f49e41bf000) => /usr/lib64/ (0x00007f49e3fb9000) => /usr/lib64/ (0x00007f49e3db6000) => /usr/lib64/ (0x00007f49e3b9e000) => /usr/lib64/ (0x00007f49e3999000) => /usr/lib64/ (0x00007f49e3795000) => /usr/lib64/ (0x00007f49e3592000) => /usr/lib64/ (0x00007f49e338c000) => /usr/lib64/ (0x00007f49e316b000) => /usr/lib64/ (0x00007f49e2f68000) => /usr/lib64/ (0x00007f49e2d62000) => /usr/lib64/ (0x00007f49e2b52000) => /usr/lib64/ (0x00007f49e2940000) => /usr/lib64/ (0x00007f49e273a000) => /usr/lib64/ (0x00007f49e2536000)

I’ve tried to re-install libQtOpenGL again, did not fix the problem.

Any ideas as to what that could be?