Aspire One Internal Mic - Opensuse 12.1

My Acer Aspire One internal mic is not working properly.

The mic is not working in applications like skype or google talk.But when I run
“arecord -f dat teste.wav” it works. (without “-f dat” it not works)
Anyone knows how to fix it?

my alsa conf:
http://www.alsa-project.org/db/?f=8f8204910dfa43c674b5715366806e50f372692d

thanks

Try installing the application pulse audio volume control (pavucontrol) and use that with applications like skype to record. I provided some guidance in a blog entry here (toward the later half of the blog entry) : Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

I installed pavucontrol and followed the blog guide, but it not worked.

pavucontrol record tab was like this while I was on skype test call
http://thumbnails76.imagebam.com/18104/9ad06f181034322.jpg](http://www.imagebam.com/image/9ad06f181034322)

but it recorded no sound

ok . What did ‘input devices’ and ‘configuration’ tab look like ? What were your selections under the ‘configuration’ tab ?

My configuration and input device tabs
The options that were selected are the hilighted ones.

http://thumbnails71.imagebam.com/18114/7764db181135053.jpg](http://www.imagebam.com/image/7764db181135053)
http://thumbnails73.imagebam.com/18114/843c8a181135056.jpg](http://www.imagebam.com/image/843c8a181135056)

Ok, I see two channels in the “Input Devices” tab. Try putting one channel to zero (but keep other at high levels) and see if that helps. My reference for that is here: Acer Aspire One 532h [LinLap - Linux Laptop Wiki] in the summary which stated:

Microphone works after one put to zero one of the microphones channels with pavucontrol.

Also, if that fails, then in the configuration Tab try ‘analog stereo input’ and test. Also try ‘analog stereo output’ and test. You may (or may not) need to restart Skype between each configuration change (I don’t know).

IF the above does not work, then we may need to consider other possibilities, such as mic not being configured properly in the audio/mic driver upon boot. I note in the HD-Audio-Models.txt file only these options for the ALC272 (I could not find ALC272X) :


ALC662/663/272
==============
  asus-mode1	ASUS
  asus-mode2	ASUS
  asus-mode3	ASUS
  asus-mode4	ASUS
  asus-mode5	ASUS
  asus-mode6	ASUS
  asus-mode7	ASUS
  asus-mode8	ASUS

… and I can show how to apply those later, but in all due honesty I don’t think that should be necessary. I have read no indication on the web that the alsa driver needs any of those applied for an Acer Aspire One.