ASF demuxer plug in

I tried to play a wmv and got this error message from Totem.

The playback of this movie requires a Advanced Streaming Format (ASF) demuxer plugin which is not installed.

Any suggestions?

In a terminal report the output of this:

rpm -qi w32codec-all

Have you tried smplayer from Packman

Since I suppose you are using gstreamer version of totem…

$ gst-inspect | grep -i asf
typefindfunctions: video/x-ms-asf: wmv, wma, wm, asf
asf:  asfdemux: ASF Demuxer
asf:  rtspwms: WMS RTSP Extension
ffmpeg:  ffdemux_asf: FFMPEG ASF format demuxer
ffmpeg:  ffmux_asf: FFMPEG asf Muxer
$ rpm -qf /usr/lib64/gstreamer-0.10/libgstasf.so
gstreamer-0_10-plugins-ugly-0.10.9-42.pm.1
$ rpm -qf /usr/lib64/gstreamer-0.10/libgstffmpeg.so
gstreamer-0_10-ffmpeg-0.10.5-42.pm.1

Install gstreamer-0_10-ffmpeg and/or gstreamer-0_10-plugins-ugly from Packman.

Here is the output:

jss@linux-edq7:~> rpm -qi w32codec-all
package w32codec-all is not installed
jss@linux-edq7:~>

go su

zypper in w32codec-all libffmpeg0

I downloaded smplayer. It appeared to install fine but when I tried to play a dvd, it tried, but no display or sound just a black screen. Though the drive made noise like it was trying.

I also ran the zypper you suggested. It installed a bunch of stuff, but Totem still claims to be missing codecs.

From the other reply I installed the gstreamer packages. After installing the ‘ugly’ one Totem seemed to get one step further and gave me the error message:

Failed to connect stream: invalid argument"

Progress maybe, but not success yet.

give us the output of

zypper lr

zypper lr returns:

jss@linux-edq7:~> zypper lr

| Alias | Name | Enabled | Refresh

–±--------------------------------------------------------------------------------±---------------------------------------±--------±-------
1 | Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.0 | openSUSE BuildService - OpenOffice.org | Yes | Yes
2 | openSUSE-11.0-Oss | openSUSE-11.0-Oss | Yes | No
3 | Index of /pub/packman/suse/11.0 | Packman Repository | Yes | Yes
4 | i386 | i386 | Yes | Yes
5 | openSUSE-11.0-Non-Oss | openSUSE-11.0-Non-Oss | Yes | No
6 | openSUSE-11.0-Updates | openSUSE-11.0-Updates | Yes | Yes
7 | Index of /repositories/mozilla/openSUSE_11.0 | openSUSE BuildService - Mozilla | Yes | Yes
8 | Index of /repositories/games/openSUSE_11.0 | openSUSE BuildService - Games | Yes | Yes
9 | Index of /repositories/GNOME:/STABLE/openSUSE_11.0 | openSUSE BuildService - GNOME:STABLE | Yes | Yes

I suggest you click this OneClick

http://opensuse-community.org/codecs-gnome.ymp

you will need to enter your root password

I tried the 1click. Lots of stuff installed. When I tried to play a movie DVD I get this.

The playback of this movie requires a MPEG-2 System Stream demuxer plugin which is not installed

Try adding this from Packman
p, li { white-space: pre-wrap; } libmpeg2

I scrolled through the Packman list and didn’t see a file named “libmpeg2”

Do I adapt this (p, li { white-space: pre-wrap; } libmpeg2 ) somehow for the terminal?

Thanks!

Ignore the white space rubbish it’s a copy and paste error

It is in packman check Yast again: exact search is: libmpeg2-0
or do zypper below

in a termianl go su and do

zypper in libmpeg2-0

It ran in terminal just fine and installed.

I tried to play a couple of DVDs and get the same error message.

check here
Multi-media and Restricted Format Installation Guide - openSUSE Forums

I think I got through what was posted on that page. But still am unable to play a DVD. I tried a music CD too and that won’t play either. I also went to a website to listen to an MP3 stream that I could listen to on SLED10, but it won’t play either. I have RealPlayer installed.

I just not sure what to do.

But still am unable to play a DVD
HOW, unable? What happens. What players have you tried, smplayer, vlc, xine???

Same with Audio - What happens??

I just inserted Ghost in the Shell DVD. I open the folder (drive) and there is an open Totem link. I click on it and it opens and immediately shuts Totem. If I open specific files on the DVD I get a black screen with no audio. (Hates ejecting too. I have to hold the drive button in for several moments. It argues with me saying “cannot eject volume” but then opens up.

Inserting an audio CD seems to work now. I just put in Coltrane and it is playing. That wasn’t working before. Tough time getting the metadata.

You mention what I guess are other DVD players.Totem seems to have come with Opensuse 11 so I figured that is what you should use. I frankly don’t have an allegiance to any DVD player–whatever works. I don’t play many DVDs, but it seems like this should work out of the box, so to speak.

I had the same problem.

Finally i managed it by:

  • Installing the gstreamer* packages through the 1-click-collection (http://opensuse-community.org/codecs-gnome.ymp)
  • upgrading gstreamer-*-plugins-ugly to latest Packman repository version: 0.10.13-999.pm.1001.2 (i586) and accept the two depending upgrades.

No idea why this worked.

This troubleshooting solution did not work: Restricted Formats/11.2 - openSUSE-Community

greets

yes, this is the point!
Think you !
it works now !