Artifacts on GUI

Hi, sorry if this is a wrong section. I’m seeing artifacts some programs (VCL and Skype). The problem goes away when I go to Qt settings and change window style from GTK+ to anything. How would I fix that?

You might want to explain what version of openSUSE you use, what desktop you use and if you use the default display and window manager settings for that desktop.
A screenshot is always useful

openSuse 11.4
GNOME desktop
What settings do you mean? I did change things in gnome-control-center, thought none of them seem relevant (except “Qt 4 settings” which I didn’t change before having this problem).

My vlc looks like a gtk program (yours too). You can change the gtk style in VLC interface settings.
Skype is QT base (I guess, QT4). Then it will take (some of) its look & feel settings from the file ~/.config/Trolltech.conf. You can use the program qtconfig (from package libqt4-x11) to customize the appearance of QT programs outside of KDE.

Are you sure the problem goes away because you change the settings or because the desktop get refreshed after the style was changed? What happens when you move the app window with the mouse?

Like I said, if I go to Qt settings and change window style, the problem goes away. Still, I’d like to know why this is happening and how to fix it.
I am sure that this is fixed due to changing style. When I select GTK+ again, the problem returns. In fact, I see the same artifacts in Qt’s preview screen for GTK+.

Try to select another gtk theme in Preferences -> Appearance.

  • I took a look at “Qt4 settings” in Gnome -> System Preferences. It starts the qtconfig program I mentioned before.

Here is how mine look
SUSE Paste

try the sonar theme

Also try to start vlc in a terminal by typing the command:


and see if you get some GTK error messages (?)

In terminal I get

(process:9648): Gtk-WARNING **: Locale not supported by C library.
Using the fallback ‘C’ locale.

Changing themes makes no difference.