Article: Silverlight on openSUSE - HowTo


Thanks to the efforts by Richard Bos we can now have Silverlight applications / websites on our openSUSE install, using Pipelight. This project was started mainly to give dutch people access to Magister, a Silverlight based students/parents application a lot of dutch schools use, that was not accessible on linux until now.


Remove the moonlight plugin, through Yast + browsers, if installed.
Add the repo below for your openSUSE version, trust the key when prompted for:

[li]Through Yast: Add the repo below for your openSUSE version, trust the key when prompted for:[/li][LIST]
[li]12.2 : [/li][li]12.3 : [/li][li]Tumbleweed : [/li][/ul]

[li]Through zypper:[/li][ul]
[li]12.2: [/li]```
zypper ar

[li]12.3: [/li]```
zypper ar

[li]Tumbleweed: [/li]```
zypper ar

[li]Close any browser sessions [/li][/LIST]


[li]Through Yast:[/li][LIST]
[li]Select View - Repositories [/li][li]Tick the Pipelight repo [/li][li]Select the pipelight package for install, it will pull in some dependencies. [/li][li]Tick "Switch system packages .....". This will make sure the packages from the added repo will be used, not other. [/li][li]Perform the install [/li][/ul]
[li]Through zypper:[/li][ul]

su -c ‘zypper ref’


su -c ‘zypper in pipelight’



Start your browser and let the magic happen....... The pipelight plugin will trigger a Silverlight install on ~/.wine-pipelight and use that. Let it do it's thing, visit to test. You should see a square with bouncing balls.

Since I can’t edit the Article:

Please read


where the article says


This does not change / have effect on the instructions given.


Can you help me with this? Ive tried using your instructional but after
“zypper install pipelight”
I get a problem as follows:
Problem: nothing provides wine-gecko >= 2.24 needed by wine-pipelight-1.7.3-1.1.i586
**** Solution 1: do not install pipelight-0.1.4-2.2.i586

** Solution 2: break wine-pipelight-1.7.3-1.1.i586 by ignoring some of its dependencies

**Im a noobie to linux, can you help me figure out what i need to do?
Thank you,


Found out just now when updating. Here’s how I got it working:

zypper ar Wine-1.7
zypper ref
zypper in pipelight

Trust the key “always” when prompted for. The Wine-1.7 repo contains the wine-gecko package >= 2.24
Zypper will report an issue, allow it to get the wine-gecko package from the Wine-1.7 repo.

Just tried it, works perfect now, thanks!

Thanks for super article !

I wanted to test this, but discovered that the package wanted to uninstall the regular Wine package in order to install wine-pipelight. IMO, it would have been preferable to have the patched version of Wine needed by the plugin installed to a separate prefix (e.g., wine-pipelight) so that it could coexist with the unpatched Wine package and be used only for the plugin without affecting any other apps run in Wine.

I think you’ve got a point here. I’ll contact the packager.

Packages in the [noparse]home:rbos:pipelight[/noparse] repo now install a patched wine version that coexists with the stock, unpatched wine. This means you can install wine alongside wine-pipelight. Tested on 12.2, 12.3 and Tumbleweed.

Thanks for this Knurpht! I had previously made a cumbersome wine install of firefox and added silverlight, which meant I had to launch an entirely seperate browser for Silverlight websites. I am now watching the channel in a tab from my usual FF. Great stuff Knurpht!


I installed it, and the balls test at works fine. However, Microsoft’s Silverlight DRM Test just gets as far as “Media State: Opening” and never plays.

Great workaround! It works for me too, flawlessly. Thank you very much!

Thank you! It works first time, but… When I opened a site with the Silverlight a month later, I’ve got a fault :frowning: I tried to install it again. Firefox didn’t start the pipelight plugin. May be you will be able to help me. What did I do wrong?

It’s not working for me. Here’s what happened.

First attempt

OpenSuse 12.3, kernel 3.7.10-1.16-desktop

  1. Added the Pipelight repository Index of /repositories/home:/rbos:/pipelight/openSUSE_12.3.

  2. Installed using Yast as described above. No errors.

  3. Launched Firefox (v. 25.0). WINE kicked in and seemed to install and enable the Silverlight plug-in. When asked if I wanted to do automatic updates for Silverlight I said “no”.

  4. Verified in Firefox that the Silverlight plug-in was enabled. Also verified that WINE was running in Windows 7 emulation mode.

  5. Went to Netflix site and logged in. When I tried to launch a movie I was redirected to a page that said this:

Watch Movies & TV Episodes Instantly

                                                                                 Instant Watching System Compatibility                                      Complete System Requirements             To watch instantly, you''ll need a computer that meets the following minimum requirements:

[li]Windows Vista or Windows 7[/li][li]Internet Explorer 8 or higher; or the latest version of Firefox; or the latest version of Chrome[/li][li]1.2 GHz processor[/li][li]512 MB RAM[/li][/ul]

[li]An Intel-based Mac with OS 10.4.11 or later[/li][li]Safari 4 or higher; or the latest version of Firefox; or the latest version of Chrome[/li][li]1 GB RAM[/li][/ul]

[li]Chrome OS[/li][ul]
[li]A Google Chromebook or Chromebox running Chrome OS 20 or higher[/li][/ul]


I thought that since my version of WINE came from the WINE CVS Builds repo at URL: Index of /repositories/Emulators:/Wine/openSUSE_12.3 there could be a version issue, I de-installed WINE and Pipelight and re-nstalled them using the standard OpenSuse repo.

When I tried to launch a Netflix movie the same thing happened. I don’t see what could be wrong. Have I missed something obvious?

I was able to solve this issue with using chrome and a user agent manager.
Sadly I cannot seem to get it up and running via firefox

Here is the link for the firefox user agent I use to be able to play Netflix:

(also links for chrome and crhomium)

I finally got Netflix to work. I upgraded to OpenSuse 13.1 (from 12.3, not a fresh install). De-installed Pipelight and then re-installed it.

Works like a charm. Ignore my previous posts. Many thanks to the packager.

I am currently using opensuse 13.1, and wine 1.7.2

After reading through this thread, I’m still not sure which would be the best way to load the pipelight repository. Also does a pipelight repository even exist for 13.1?
If so, I’m assuming I would use one of the following two commands:

zypper ar


Zypper ar Wine-1.7

-or neither?-

Which would be best so as not to disturb the few programs I’m running under regular wine 1.7.2?

Once the repository is loaded and trusted, then I assume I would follow one of the above by these two commands:

zypper ref
zypper in pipelight

Also when I run the regular opensuse linux Firefox, and the Silverlight plugin is detected, I understand I would probably need to answer “no” to updates to Silverlight as this is a Windows plugin managed by pipelight/wine?

And I would probably need a user agent switcher in Firefox to simulate a Windows OS?

Have I summarized the steps I would need to go through? Thanks for any help or suggestions.

AMD Athlon 64 X2 Dual Core Processor 4400+, 4Gb RAM, GeForce 6100 nForce 430

Use Download openSUSE 13.1 and search for pipelight. You’ll see it’s available for openSUSE 13.1
BTW: you can browse the repos by going to Index of /

Thanks for that information, Knurpht. I found pipelight as you mentioned for 13.1, but it seems I still get two main choices, pipelight or wine-pipelight. Which would be best if I want to continue using a little bit of the regular wine with some programs in order to avoid conflict with the special version of wine that comes with pipelight? Does it matter which one?