Article: Bigpond Ultimate Broadband Wireless in openSUSE 11.4 (+) using Knetworkmanager

Sierra Wireless device 312U – Bigpond Ultimate Broadband Dongle – Australia (yahoo!) – openSUSE versions 11.4 and beyond – KDE

SEO keywords: Sierra 312U, Linux, openSUSE, KDE, Bigpond Ultimate, wireless broadband, 1199:68a3

Introduction: The latest Bigpond offering of the Sierra AirCard 312U connects pretty much as an out-of-the-box experience in openSUSE if you use the KDE network manager (icon in the system tray). It took me 2 months to find the almost trivially-simple parameters to use, so I thought I’d put them here for others.

This method should work for Internet Providers other than Bigpond and for other* contemporary* Sierra cards.
Cards that work in KDE should also work with the Gnome NM applet…

Which device are we talking about: A picture of the device I’m writing about is displayed at the bottom of this article. Here’s a link to the manufacturer’s page. When you plug the device in, wait a few seconds until it registers (blue lights) then run this command in a terminal: lsusb. You should see a device identifier like this “Bus 001 Device 007: ID 1199:68a3 Sierra Wireless, Inc.”. The important bit is 1199:68a3.

Prerequisites: You need openSUSE 11.4 or later (or Tumbleweed 11.4+). Check you have the RPM ppp installed and that you are using the KDE networkmanager (Knetworkmanager) to control your network connections. If you need to switch on Knetworkmanager, goto Yast → Network Devices → Network Settings → Global Options. Make sure the Network Setup Method has selected the option User Controlled with Networkmanager activated.

What you don’t need: there are many howto’s for wireless broadband modems on the Net. You might be confused about some of the suggestions. Here are a few tips about things you DO NOT have to do or install.

  • Do not try to configure the modem in Yast (i.e. do not use Yast → Network Devices → Modem)
  • You do not need to install the following software packages (although is they’re there you should leave them be): smpppd, wvdial, kppp, kinternet, usb_modeswitch-data or usb_modeswitch
  • You don’t have to switch on the smpppd daemon
  • You don’t need any dialing software or GUIs

** Configure the AirCard**: Plug the device into a USB port and wait for the blue lights, one steady and one flashing. Left click the network manager icon in the System Tray (bottom right of the screen) and select to Manage Connections. Activate the Tab labelled Mobile Broadband. Highlight the connection that openSUSE has sensed for the device. Click to Edit it. You will see three Tabs; viz: Mobile Broadband, PPP and IP Address. Simply add the settings I’ve captured in pictorial form, below.

Below: Here’s a pic of the AirCard as sold by Bipond for the product “Bigpond Ultimate”

Below: The panel under the Tab Mobile Broadband. I added every entry, including the name “Bigpond Ultimate”. You can choose to Connect Automatically, or not, it’s optional.

Below: The panel under the tab PPP. These are the defaults I found there. I changed nothing.

Below: The panel under the Tab IP Address. These are the defaults I found there. I changed nothing.

Be well, swerdna


I have a HP Compaq laptop with a built-in broadband modem

ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]

It too is a Sierra device

 dmesg|grep sierra     7.837980] sierra 4-1:1.0: Sierra USB modem converter detected
    7.840226] usbcore: registered new interface driver sierra
    7.840228] sierra: v.1.7.16:USB Driver for Sierra Wireless USB modems

It was recognised ‘out of the box’ by KDE’s plasmoid-networkmanagement, and configured for use with Telecom NZ with the following parameters:

Number *99#

It is worth noting that if dual-booting, and using Windows connection manager with these devices, they can be disabled on shut-down. This behaviour can usually be adjusted via the utility itself. It is advisable to install the ‘rfkill’ utility, so that it can be re-enabled if necessary (in openSUSE). For example

 # rfkill list
0: hp-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: hp-bluetooth: Bluetooth
        Soft blocked: yes
        Hard blocked: no
2: hp-wwan: Wireless WAN
        Soft blocked: no
        Hard blocked: no

Hello John,

maybe you could also add the hexadecimal ID 1199:68a3 for this mobile broadband device as a tag to this article. The device/the mattering hardware seems also to be named/sold as “Sierra Wireless USB 305 modem”, “Sierra Wireless USB308 modem”, “Telstra Turbo modem”, “AT&T USB GSM Modem”, “Sierra Wireless 890 AirCard (at&t ExpressCard)” and probably so on …


Done, 1199:68a3 now in 5 places, including Tags, Meta Words & my keywords

For some unknown reason I cannot see your pictures. Can you list the settings in text?

I’ve fixed it for you (I hope).

I found with my IInet connection and 140c Huawei modem that under APN I needed to use the number '5202 ’ and not the name iinet.

Thank you for the info

Though, this is a late post, I want to say “yes you fixed it” and I appreciate what you have done in order to help others.
My modem worked fine.