Arrg! VUZE quitting itself.

Perfect Thread title. :wink:

WHAT THE HECK is going on here and how to fix?

TheMask@superpussy:~> vuze
using MOZILLA_FIVE_HOME=/usr/lib64/xulrunner-1.9.0.7 and MOZ_PLUGIN_PATH=/usr/lib64/browser-plugins                                                                             
GRE/XULRunner automatically found                                                       
java virtual machine used: /usr/lib64/jvm/jre/bin/java                                  
classpath used: /usr/share/java/Azureus/Azureus4.jar:/usr/share/java/Azureus/swt-3.5-I20080702-0939.jar:/usr/share/java/Azureus/swt.jar                                         
main class used: org.gudy.azureus2.ui.swt.Main                                          
flags used:                                                                             
options used: -Xms16m -Xmx128m -Djava.library.path=/usr/lib64/Azureus:/usr/lib/Azureus -Dazureus.install.path=/var/lib/Azureus -Dazureus.script.version=2 -Dazureus.script=/usr/bin/vuze                                                                                
arguments used:                                                                         
file:/usr/share/java/Azureus/Azureus4.jar ; file:/usr/share/java/Azureus/swt-3.5-I20080702-0939.jar ; file:/usr/share/java/Azureus/swt-3.5-I20080702-0939.jar ; file:/home/TheMask/                                                                              
Locale Initializing took 256ms                                                          
09070:    Core: 25ms for activity between 'Load Plugin:azemp' and 'Load Plugin:azrating'
09082:    Core: 26ms for activity between 'Load Plugin:azrating' and 'Load Plugin:azplugins'                                                                                    
09111:    Core: 25ms for activity between 'Load Plugin:azplugins' and 'Load Plugin:azupnpav'                                                                                    
09140:    Core: 25ms for activity between 'Load Plugin:azupnpav' and 'Load Torrents'    
09194:    Core: 50ms for activity between 'Load Torrents' and 'Load Plugin:azupdater'   
09204:    Core: 25ms for activity between 'Load Plugin:Start/Stop Rules' and 'Load Plugin:Torrent Removal Rules'                                                                
09238:    Core: 26ms for activity between 'Load Plugin:UPnP' and 'Load Plugin:DHT'      
09275:    Core: 25ms for activity between 'Load Plugin:Magnet URI Handler' and 'Load Plugin:Core Update Checker'                                                                
09282:    Core: 25ms for activity between 'Load Plugin:Core Update Checker' and 'Load Plugin:Core Patch Checker'                                                                
09302:    Core: 25ms for activity between 'Load Plugin:Local Tracker' and 'Load Plugin:Network Status'                                                                          
[Cut some torrents here]             
11732:    Core: 239ms for activity between 'Initialize Global Torrent Manager' and 'Initialize Plugin: Rating'                                                            
11769:    Core: 20ms for activity between 'Initialize Plugin: Tracker Static Pages' and 'Initialize Plugin: Embedded Media Player'                                        
11797:    Core: 20ms for activity between 'Initialize Plugin: UPnP Media Server' and 'Initialize Plugin: Azureus Update Support'                                          
11801:    Core: 12ms for activity between 'Initialize Plugin: Start/Stop Rules' and 'Initialize Plugin: Download Remove Rules'                                            
11824:    Core: 25ms for activity between 'Initialize Plugin: Universal Plug and Play (UPnP)' and 'Initialize Plugin: Distributed DB'                                     
Core Initializing took 3001ms                                                           
UIFunctions/ImageLoad took 41ms                                                         
new shell took 40ms                                                                     
new shell setup took 31ms                                                               
skinlisteners init took 60ms                                                            
skin init took 105ms                                                                    
MainMenu init took 120ms                                                                
createWindow init took 0ms                                                              
skin layout took 0ms                                                                    
pre skin widgets init took 48ms                                                         
hooks init took 126ms                                                                   
WARNING: already added UIUpdatable com.aelitis.azureus.ui.swt.views.skin.sidebar.SideBar@6243487e                                                                               
skin widgets (1/2) init took 185ms                                                      
skin widgets init took 151ms                                                            
pre SWTInstance init took 0ms                                                           
Init Core Columns took 75ms                                                             
SWTInstance init took 205ms                                                             
shell.layout took 171ms                                                                 
---------READY AT 1237243096266                                                         
shell.open took 153ms                                                                   
processStartupDMS took 3ms                                                              
vuzeactivities init took 3ms
psDMS 14ms
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007f02196c42f2, pid=5269, tid=139647223961936
#
# Java VM: OpenJDK 64-Bit Server VM (14.0-b08 mixed mode linux-amd64 )
# Distribution: Custom build (Tue Mar  3 15:01:05 UTC 2009)
# Problematic frame:
# C  [libxul.so+0x3c82f2]  _ZN19nsACString_internal6AppendEPKcj+0x28
#
# An error report file with more information is saved as:
# /home/TheMask/hs_err_pid5269.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted

ANY help very much appreciated.


TheMask.***

What did you find here
/home/TheMask/hs_err_pid5269.log

You know Vuze is a Java app. Nice, but for many this is considered unnecessary for simple file sharing. So many do avoid it, though I do use it.!

Sometimes a fix can be achieved by downloading the latest Azureus4.jar here: SourceForge.net: Azureus: Files

Then place it in
/usr/share/java/Azureus

caf4926 you keep saying the same thing as if it is actually a solution. The solution would be for the packagers to compile a new binary for Vuze instead of telling us to drop Azureus4.jar into /usr/share/java/Azureus.

@FlameBait
A logical first step would be to report the error to the Packager which is I think what you suggest and I agree. If it’s the Packman version, you will likely receive a very quick response.

I should have perhaps used the word temporary - which is what my suggestion is. It might or might not solve the issue. As to it being the same thing? I know I suggested it recently, perhaps it was to you? But quite honestly I find I often repeat the same thing over and over, it’s part of what happens in the Forum - Which admittedly, could be reduced in some cases if users just used the search.

Yea I got the same advice from you. I downloaded the tarball from Sourceforge and it was the wrong file. The sources I downloaded gave me Azureus2.jar not Azureus4.jar. After downloading and extracting both the 64 and 32 bit Linux versions of Vuze_4.1.0.4 and seeing no Azureus4.jar and not knowing if I was to use the 32 bit version or the 64 bit version I gave up. Vuze is still telling me I need to “update” even after “updating” in the normal way. It refuses to reboot any time I try from the Vuze/Azureus menu.

I don’t know how to get hold of the packager and would not know what to tell them. Seeing how this problem is now old I don’t expect it’s getting fixed soon. Seeing how Vuze is pretty popular as a Torrent client I figured it would have taken care of it’s self by now. Before I used SuSE I just used to DL the tarball and install it in my /home/ and it always “just worked” including updates done in the normal Azureus way. Using the precompiled binaries didn’t work out well under my old distro either as they were compiled against open Java and not Sun Java and were broken. That is before I ran 64 bit and that makes everything different I never know what files I am supposed to get.

Ktorrent is crap compared to Azureus even when run in the classic mode the way I run “Vuze”. All I want is a pre-compiled binary that works compatible with what I already have installed.

My Vuze from Packman 32bit OS 11.1 is working fine. No problems of late.

The link I gave earlier offers a direct download (first in the list) of the Azureus4.jar (no need to extract it). It goes in the folder I specified.

What more can I say: Except perhaps Remove it completely and or try a re-name of the .azureus folder.

I just renamed the old .jar file .old and dropped the one from the link in. That at least got rid of the “update” looping problem but Vuze still refuses to restart from the Vuze menu.

I Liked the name Azureus better. :wink:

I am waiting on a new blob but from all the various Vuze trouble seen I doubt we will get a new binary any time soon.

Vuze still quits itself without notification - even after updating the .jar. :frowning:
AWESOME.

TheMask.

Dito, and also on 64 bit here.

I was also facing the same problem. Whenever I started vuze it just died. I would have re-installed vuze 100 times, it made me really insane.

Then I just replaced the openjdk package with that from Sun’s latest jre. I am not sure if that did the trick but since then Vuze is working fine on my dektop :)** **

Interesting, but I’m not using the Sun java.
So maybe it’s worth a re-install of whatever you have jdk or jre. Or switch to Sun jre and see.

I just tried openJDK and Sun Java on 11.1 (64 Bit, latest versions) and both work here withz latest version of Vuze (packman repo).

I was also using openjdk and Vuze was working fine, but suddenly one day it just stopped to start. It only started working when I removed openjdk and installed Sun’s jre. I do not know what is the relation, but as said it did the trick for me, atleast till now :slight_smile:

May be if someone else will try this and if this thing works again, then there may be a relation…

I’ll verify this. Lets see…


TheMask.***

HUGE thanks flies out to vendetta18! Your method works. No creepy update-stuff and no quitting. :slight_smile:
(reputation increased)

TheMask.

There is no reason to not use Sun JAVA that is sane. Using the other has always only caused me problems.

At least I don’t have the quitting problem, not restarting is trivial. The not updating thing was a PITA. It was bugging me about updating the Vuze media server plug in too. I got rid of that by disabling that plugin as I don’t use that bloat.Azureus classic mode rules. NFS sharing to the client boxes which run Smplayer for video playback.

:slight_smile: Thanks. So now there is definitely something wrong with openjdk :expressionless: I was facing this problem even when I had KDE4.1. It worked sometime in KDE4.1 and then did not. When I switched to KDE 4.2, vize did not work even then. And, I was also getting the problem with Vuze updates. After automatically installing updtes my Vuze would ask to be restarted. It never “restarted” on its own. And after starting Vuze it would again ask to be “restarted”. Updates never got installed.

But after my replacement of openjdk with Sun’s java that thing has also disappeared…

Only I can’t reproduce the results you guys are having and I’m on openjdk. So can we really say there is something definitely wrong with JDK?

I’m x86 are all of you _64 by any chance?

No I am on 32 bit. i.e x86

caf4926

I would have also re-installed openjdk 10 times before moving onto Sun’s JRE. I also completely removed openjdk(through yast) before installing it again. But nothing worked.

I am not **** sure that there is something wrong with openjdk. But if so many people are having issues with Vuze and openjdk there must be something… somewhere…:\