Armagetronad crashes X after software update

Dear all,

I did a fresh install of opensuse 11.2. Armagetron worked (more or less at least: it was quite a bit slower than what I was used to, only 15 fps). Then I did a software update and now starting armagetronad crashes the system. It becomes totally irresponsive and I have to push the reset button. If I start it in a window (with the -w option) it opens a window but the mouse cursor freezes and again I can only press the reset button.

The update installed some new versions of some xorg libraries but I don’t remember exactly which ones.

Is there a way to undo to updates? Or a way to make it work again?

System: amd64, 64 bit open suse. nVidia nForce 3

All the best,

Is there any output if you start it from the terminal, either a backtrace or any error messages?

Where did you install armegetron from? If your xorg libraries got updated, incompatibility with the new libraries is most likely the reason. If you compiled it yourself, recompile it, otherwise, talk to the person who made the rpm.

About your speed problem, I assume you have the gfx card drivers installed correctly?

Hello Masterpatricko,

In the meantime I more or less solved the issue of the crash. Deleting all configuration files in .armagetron and .armagetronad solves this. Strange…

I will still answer your questions below.

When it still crashed, I could not see any output on the terminal because it would just crash the system and I could basically not do anything anymore. I also tried starting it as armagetronad &> log but that just gives me an empty file.

I tried both armagetronad as it is in the suse repository and a home compiled one from Armagetron Advanced :: a Tron clone in 3D . Both used to crash.

The speed was still not so good, but that becomes better if I play on a lower resolution. Even though it is less beautiful that way it now at least is playable. As far as drivers is concerned: according to the nvidea website I should not need extra drives as they are open source and already automatically included in most distributions. nvidea does not distribute these drivers itself anymore. Actually, if 3D acceleration really is not working, I think arma should be even slower, like one frame per second.