ark/kf5 error Unable to find Ark's KPart component, please check your installation.

on my Laptop=Dell latitude E6510, RAM=8Gb, GPU=GT218 NVS 3100M, CPU=i7 Q 720 @ 1.60GHz running opensuse leap 42.2, plasma 5.9.3, KDE frameworks 5.31.0, KDE applications 16.12.2, Kernel 4.4.49-16-default, nvidia drivers, libreoffice
when I open a .zip file with ark/kf5 it doesn’t works and appear this error
Unable to find Ark’s KPart component, please check your installation.
what should I to do to have a working ark??
manythanks, ciao :slight_smile: pier

Maybe another mixture of packages from my repo and the standard repos?
What ark packages do you have installed?

zypper se -s ark

Try to reinstall ark5:

sudo zypper in -f ark5

If you uninstalled the standard ark after installing ark5, it will remove files from ark5 because they overlap.
If you install ark, only install the one from my repo, that’s the KDE4 version.

reinstalling ark5 worked :slight_smile: then I uninstalled ark, I’m using only plasma5 now, I use kde4 on 42.1 installation

Ok, but why are you using my repo in the first place then? It’s only purpose is to have KDE4 and Plasma5 side-by-side…
If you want to have the latest applications, you can rather use KDE:Applications, that would prevent such problems.

…first for beclock, second for amor, lol! third I’m trying to getting used to plasma5 but I’m not so sure with plasma5 so I take the possibility to use KDE4 anyway lol!
(but the problem rised up after a crash during the updating and during the installation of nvidia drivers, my son make my laptop drop nothing broken but battery and 220v cable detached, after this only black screen after boot, so I inserted the dvd and chosen upgrade leaving all the repos that was present, it worked but may be the order of installation of ark make this error…)