Are there currently and problems with the official nvidia repository for tumbleweed?


since the emergence of the new official nvidia repository for tumbleweed:
I am using it and it is fine most of the time. But currently there seem to some problems with the current kernel, because since about 2 weeks the driver is not working anymore.

Can someone confirm that this just a delay and that the driver will work eventually?

I don’t have any nvidia hardware on TW anymore, but I do see that the latest nvidia version is from the 4th of october. It is kernel 4.13 though, the rest of the kernel version numbering are build numbers. Try reinstalling the nvidia driver packages, I’ve seen someone reporting doing so created a working driver. IMHO reinstalling shouldn’t be a solution, but in this case might at least be a workaround for an unknown problem. After a phonecall during writing this, I suddenly think that the cause might also be Mesa updates that overwrite nvidia symlinks with it’s own packages, which would explain why a reinstall works, but it’s no more than an educated guess.
A temporary solution if that doesn’t work could be to download and install the driver manually. You can do automatic rebuild on a new kernel by using the --dkms option in the installer,. This requires the kernel-development packages + dkms.

Got same issues here with latest update on 42.3 and Tumbleweed as well. Even installin the driver by hand doesn’t work at all but gives me some hints to workaround the problem.

Simply install libelf-dev and **libglvnd-dev, **

install the driver again, you can even use the repository again (zypper inr).

Works fine for me but I’m still digging for the exact problem here, seems like they updated some serious stuff related to the glx parts here… don’t really know it yet, so let me know if that helps.

Simply install libelf-dev and libglvnd-dev,

Here on Leap 42.3 I have only libelf-devel installed to get the installed…
And Nvidia is working

libglvnd is also not in the official Repo for Leap 42.3, only in /home Repos…
So no need for 42.3.

Seems like they’re ahead of the kernel-releases. IIRC I saw that these packages are required for kernel 4.14

EDIT: Thanks a lot for sharing

zypper inr alone does not work at all even when installing libelf-dev first.
I also tried to reinstall the driver but I have 3 packages installed from this repository, nvidia-gfxG04-kpm-default, something with compute and one package with x11-video in its name.
Which one of those is the driver I have to reinstall via zypper in -f ?

Easiest way is to uninstall Nvidia drivers completely, restart and zypper inr again.

So I have to remove all three packages?

Yes, but it seems like repository wont work at all, even with the packages installed. Only building the driver from their website by hand works fine for now. At least on Tumbleweed, I’ll give it a shot later on 42.3.
//edit: to install the run package from nvidia you need to remove the repository driver and the the repo as well in order to have a succesful installation *

I just tried to only reinstall the first mentioned package via zypper in -f and it seems to work now

Glad to hear

I’ve had problems with lately with the latest kernel updates and Nvidia drivers from Repository.
I can only enter with Icewm with a bumpy resolution, and unconditionally upgrade kernels and Nvidia drivers.
It was too good to be true …!

I had to do the forced upgrade of the Kernel 4 times .
Post Edit ) I removed the 4.14 Kernel does not go with Nvidia’s drivers

There has been an update of the Nvidia Driver that has resolved everything