Are there any plug and play usb wlan adapters for opensuse11

Sorry for my non expert question, but my last unix knowhow ended 25 years ago.
So my daughter got a new notebook and yes she wanted linux, because she does not like MS.
After checking some linux forums, i decided that opensuse 11 should be the best OS for this purpose, because everyone stated, that it has the best support for different hardware.
And it really worked, there was the only problem with the buildtin wlan adapter and some minor problem with the display driver.
So i had to learn, what gnome is (in Unix there was not something like that) and i am proud, that i soon was able to install a better displaydriver.
Thanks to linux, that su command is still the same :slight_smile:
But with wlan i found out, that there is no simple solution.
There is ndiswarapper (a windows driver supporter ?) or there are solutions, where you have to compile drivers into the kernel (??).
So, if we forget the buildtin wlan adapter and buy a new usb wlan adapter, which should we choose?
Is there any NoProblem usb wlan on the market for opensuse 11?

2 places to check on wireless adapters
Linux wireless LAN support
HCL/Network Adapters & - openSUSE

also, if you post the output of

/sbin/lspci -v 

we may be able to get your on-board wireless working


Thanks a lot Andy for Your very nice help!

The onboard Wlan is via lspci:
Atheros AR242x 802llabg Wireless PCI Express Adapter Rev.01

Perhaps i should add, that WPA/PSK is a must for the Wlan adapter.

I looked into Your interesting links and found out, that most of the USB adapters change chipsets, while not changing model names ( and so on).
These manufacturers should be banned from the market, because most of them do not provide Linux drivers and while changing the hardware it is a pain for all customers.
It really looks, that it is a big problem to find a working adapter, which is usually sold in Europe.

As you have an Atheros card, Madwifi provide the drivers for your card, find them here Index of /suse/11.0 if those fail to work, you could try the ones from here Index of /repositories/home:/schmolle1980/openSUSE_11.0 any problems,just post back,drivers need to be installed via YaST & you configure the device via YaST - network devices - network settings


deltaflyer44 you looking to up your post count by double posting :D:D
“I’m only joking”

hrmph!, pesky touch-pad, now sorted :smiley:


Once again thanks, Andy!

We tried the MadWiFi Installation as described in Atheros madwifi - openSUSE

But our problem is our minimal knowledge of Linux:
So under Yast/Software/Software install we can find 2 Entries that are installed:
madwifi (Tools for configuring atheros cards)
madwifi-devel (Tools for configuring atheros cards)

So, but modprobe ath_pci says, that ath_pci is unknown.
We also have added ath5k to the blacklist.

The installation instruction said, that we had to choose the correct madwifi-kmp package, but there was no question about it.
We used the 1 click install for Yast.

WLan ist a horror for Linux, is there really no plug and play usb adapter out there?

Once the isl3887usb_bare firmware is installed, the Dell DW1450 Wireless USB
Adapter is p-n-p for me. It uses the p54usb driver. I got mine on E-bay for
$10.95 + $2.85 shipping.


After deinstalling the 2 installed madwifi entries in the software list, we took a second try as described in
Madwifi-kmp issues With 11.0 - Page 6 - openSUSE Forums

Now we can modprobe ath_pci but in networkconfiguration there is still no possibility to configure the atheros adapter.

WLan ist a horror for Linux, is there really no plug and play usb adapter out there?

Thanks Larry!

A Dell 1450 is at the moment not at sale by Dell.

Please only speak about what you’ve tried. Wlan is not a horror for all of Linux.
[It may (or may not be) for openSUSE, that’s your call. But, for a counter-example,
try Mepis, where most wifi-adapters work right from the LiveCD.]

My 2-cents worth…


RE: cookdav

Please only speak about what you’ve tried. Wlan is not a horror for all of Linux.

In a further post in this thread i explained why WLan is a horror for linux (for all linuxes).
It seems that each hardware manufacturer of WLan-adapters does not distribute any driver for linuxes.
In my opinion this is not a failure of linux(es), it is an absolute foolishness and laziness of these manufacturers.
And if You are lucky by using a linux, which supports by accident Your WLan adapter, You can only say that it works for You,
but You cannot guarantee, that it will work in a future version, because Your WLan adapter producer will not help You.

And so i can stay in my opinion, that WLan is a horror for all linux(es).

I bought an ASUS wireless card, and that was Atheros as far as I remember, and it worked straight away.

That was a PCMCIA card though, but ASUS are extremely Linux friendly, and if the boy says “Linux drivers supplied”. or carries the Tux logo, it’s a good bet that it will work.

I bought it from a small local computer shop with the promise that I could return it if it didn’t work.

One of the benefits of small business, they go out of their way to help their customers whereas big business doesn’t give a toss!