Are people getting Alsa problems in 11.4 like I have with 11.3?

Sound will work fine for a while, but sometimes I’ll launch a video (from disk or streaming) and get a box telling me that Alsa isn’t working, and I get no sound.

Is this going to be a problem in 11.4, or have these things been fixed?

This is a very random question with no supporting evidence. Did you run through your issues with @oldcpu and the sound troubleshooter?
You see, I haven’t had any trouble with sound ever, in any release…
So all I can say to your question is: What problems, mine is fine

I’m being a little vague because others may not have the identical problem. I am not a Linux guru, just an end user since about 2007 and trying to keep from breaking anything.

Works fine here
I disabled pulse audio because I am having trouble using the two sound cards at the same time

My experience is what you are seeing in 11.3 is one application has seized the audio device and is refusing to share it. You can tell what application is using the audio device by taking a look at the audio device related files that a multimedia application has opened. The command for listing open files is:

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/* 

note the syntax for the last entry is " /dev/snd/* " (ie different from earlier entries).

of course that command needs to be run when audio is working on various occasions, and then run when it is not working, in order to understand what it means. Posting it just once and expecting sound guru’s will jump all over and say the problem is ‘x’ will not happen. It needs to be run at many times (with an annotation as to what was running then … ).

My guess is the same problem will be in 11.4, unless you have a new PC (with a fairly fast CPU) in which case if you setup pulse audio properly it may work around the problem of applications seizing the audio device and refusing to share.

Here is the popup message:

“ALSA version problem:
VLC failed to re-initialize your sound output device.
Please update alsa-lib to version 1.0.22 or higher to fix this issue.
Potential ALSA version problem:
VLC failed to initialize your sound output device (if any).
Please update alsa-lib to version 1.0.23-2-g8d80d5f or higher to try to fix this issue.
ALSA version problem:
VLC failed to re-initialize your sound output device.
Please update alsa-lib to version 1.0.22 or higher to fix this issue.”

So, does 11.4 have this higher version?

That reads like a vlc bug to me.

I think it happens in whatever audio player I’m using, but I’ll check the next time to see.

However, getting back to the question, is this something that would have been fixed in 11.4?

I hope so. I am using Suse because nobody ever got fired for using Novell, and I’m using Linux because I used to sell computers and long ago learned to LOATHE the Redmond Gang. I am out of the industry now, and don’t have time to become a Suse guru, so all I’m after is a stable and safe OS that does the few things I need it to do.

If its a vlc bug, then its an upstream problem, and unlikely to be fixed in openSUSE nor in any other distro.

I confess I don’t see that error when I use vlc but it could be hardware, audio config, or application config specific, so my not running across it is truely meaningless.

Sound, including VLC, is working perfectly here on openSUSE 11.3 and 11.4 using the normal repos.

have similar problem with vlc, getting no sound on vlc when pause and when amarok is in background, but if only vlc is on there is no sound problems…I’d say its a bug.

It happens with packman repos and multimedia restricted formats codecs…

Having two applications vying for sound is usually asking for trouble.

Hi caf4926,
now I did some updates (gsteramer update ), just a minute ago and getting the same problem with vlc - silence after pause when only vlc is playing…

is it a bug or is there some codec’s incompatible ?

Try setting the audio output pref to


still the same, no sound after pause…

But you said

but if only vlc is on there is no sound problems

So is this correct or do you have Amarok running?

yes I said that, and there was no problem pausing vlc if only vlc was playing, until I updated gstreamer 10 (did update when got message of available updates)

will try to reinstall some of codecs

Please check you have all packman versions
Like this in Gnome:
And KDE:

all gstream10 codecs (all of them, -god, -ugly, etc)
and much more…

I reinstalled vlc and gsteramer and didn’t help

Do you actually try the switcher or just manually scan the list