AR9287 Wireless Adapter is not connecting/working

Hi,

It has been working for more than a week, once i have tried to connect to VPN network, my wlan0 got screwed up.
I have spent many hours read through many thread but no luck. hoping to get some help by post here.

Problem: My wlan0 is not connecting, from yast->Network Settings->Global options-> NetworkManager Service then Overview I get eth0 and wlan0 greyed

from yast->Network Settings->Global options-> Wicked Service then Overview I get eth0 working fine with cable but wlan0 found as (not connected)

I tried edit wlan0 -> Dynamic Address (Next)-> Operating Mode: Managed ->Network Name (ESSID) Scan Network does not work to find any networks

Device details:

1>

lspci | grep Network
        02:00.0 Network controller: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express) (rev 01)

2>

lspci -n | grep "02:00.0"
02:00.0 0280: 168c:002e (rev 01)

3>

dmesg |  grep firmware
    0.472232] [Firmware Bug]: ACPI: BIOS _OSI(Linux) query ignored
    4.562629] [Firmware Bug]: ACPI(NGFX) defines _DOD but not _DOS

4>

dmesg |  grep AR9287 
   11.199496] ieee80211 phy0: Atheros AR9287 Rev:2 mem=0xffffc900009a0000, irq=16

5>

iwconfig
eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          
lo        no wireless extensions.

tun0      no wireless extensions.

6>   
iwlist scan
eth0      Interface doesn't support scanning.

wlan0     Interface doesn't support scanning : Network is down

lo        Interface doesn't support scanning.

tun0      Interface doesn't support scanning.
7> 
ifup wlan0
wlan0           device-unconfigured

8>

rfkill list    # I have installed rfkill while investigating before0: sony-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: sony-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes


8> 
ip link set wlan0 upRTNETLINK answers: Operation not possible due to RF-kill

  
 9> 
rfkill unblock 0 
         
         rfkill unblock 3
 10> 
ip link set up wlan0
 11> 
rfkill list     # now the list0: sony-wifi: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: sony-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
3: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no


 12> 
iwlist scaneth0      Interface doesn't support scanning.

wlan0     Scan completed :
          Cell 01 - Address: 50:06:04:A7:F8:D1
....
....
# I found my wifi network in the scan at cell 05
          Cell 05 - Address: F0:B4:29:5C:61:D4
                    Channel:2
                    Frequency:2.417 GHz (Channel 2)
                    Quality=70/70  Signal level=-21 dBm  
                    Encryption key:on
                    ESSID:"my_hm_nw3"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=0000002001aadfb3
                    Extra: Last beacon: 224ms ago
                    IE: Unknown: 000E6D616C617468695F686D5F6E7733
                    IE: Unknown: 010882848B961224486C
                    IE: Unknown: 030102
                    IE: Unknown: 2A0104
                    IE: Unknown: 32040C183060
                    IE: Unknown: 2D1A6C0017FFFF000000000000000000000000000000000000000000
                    IE: Unknown: 3D1602000400000000000000000000000000000000000000
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101800003A4000027A4000042435E0062322F00
                    IE: Unknown: 0B05010040127A
                    IE: Unknown: DD07000C4300000000
                    IE: Unknown: 0706434E20010D10
                    IE: Unknown: DD7E0050F204104A0001101044000102103B000103104700102880288028801880A880F0B4295C61D4102100067869616F6D69102300045231434D10240004303030321042000831323334353637381054000800060050F20400011011000C5869616F4D69526F7574657210080002210C103C0001011049000600372A000120

[INDENT=2]  
[/INDENT]
lo        Interface doesn't support scanning.

tun0      Interface doesn't support scanning.




Please help me to solve my issue, many thanks

Your wireless device was soft-blocked, and you enabled it with rfkill. After that you should have been able to configure it. If using wicked, you do this via YaST > System > Network Settings > Overview. There you can select ‘Edit’ with the appropriate network device highlighted, and configure it so that it associates with the desired wireless network.

This command can be used for diagnostic purposes

sudo journalctl -u wicked

Thanks deano_ferrari,

I unblocked the wireless device using rfkill unblocked <identifier both 0 & 3>,
then from yast->Network Settings->Global options-> Wicked Service then Overview -> selected wlan0 (found as not connected)

tried to edit wlan0 -> Dynamic Address (Next)-> Operating Mode: Managed ->Network Name (ESSID) Scan Network -> this time it finds wifi APs, i chose my wifi AP and done.
Great that ifconfig showed that wlan0 acquired an ip, but still could not access to internet.

But ifstatus wlan0 --show link is up
and # journalctl -u wicked --shown the same thing it is up…

# journalctl -u wicked
May 28 20:04:33 <some hostname> wicked[8133]: wlan0           device-ready
May 28 20:04:33 <some hostname> wicked[8133]: wlan0           up

Moreover it did not show up in the Networks widget in the system tray [but wired one does show in system tray]

Did a reboot, after reboot, rfkill showed again that wlan0 has been blocked as before.

# journalctl -u wicked
-- Reboot --
May 28 20:23:01 <some hostname> wicked[1044]: lo              up
May 28 20:23:01 <some hostname> wicked[1044]: eth0            setup-in-progress
May 28 20:23:01 <some hostname> wicked[1044]: wlan0           device-unconfigured
May 28 20:25:41 <some hostname> wicked[2468]: ifreload: no matching interfaces
May 28 20:32:35 <some hostname> wicked[2959]: eth0            device-ready

looks like unblock was not permanent, any suggestions how to unblock it permanently or can it be anything else?

This is a bit vague. You should examine/report the following when the device is associated.

ip addr
ip route
grep "nameserver" /etc/resolv.conf

But ifstatus wlan0 --show link is up
and # journalctl -u wicked --shown the same thing it is up…

Moreover it did not show up in the Networks widget in the system tray [but wired one does show in system tray]

Do you mean the NetworkManager front-end? It is not used when wicked.service is used. You need to use the NetworkManager.service instead if you want to configure/control the wireless device with NetworkManager.

Did a reboot, after reboot, rfkill showed again that wlan0 has been blocked as before.

# journalctl -u wicked
-- Reboot --
May 28 20:23:01 <some hostname> wicked[1044]: lo              up
May 28 20:23:01 <some hostname> wicked[1044]: eth0            setup-in-progress
May 28 20:23:01 <some hostname> wicked[1044]: wlan0           device-unconfigured
May 28 20:25:41 <some hostname> wicked[2468]: ifreload: no matching interfaces
May 28 20:32:35 <some hostname> wicked[2959]: eth0            device-ready

looks like unblock was not permanent, any suggestions how to unblock it permanently or can it be anything else?

There could be a few reasons for this. For example, I have seen this behaviour reported occasionally when a certain kernel boot parameter (laptop driver) has been used, but which doesn’t play nicely with the wireless hardware. To return the current parameter configuration do

cat /proc/cmdline

Maybe the BIOS config needs to be checked as well?

Thanks Deano Ferrari,

Here is the cmd line params: (I do not think bios settings need some changes because wifi connects from other OS without any issue)


cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.1.12-1-default root=UUID=d7ac1707-3a8d-4661-9bbc-a99fcca60b98 resume=/dev/sda7 splash=silent quiet showopts

ip addr

ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether f0:bf:97:1a:e6:ec brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 90:00:4e:ae:39:89 brd ff:ff:ff:ff:ff:ff
    inet 172.16.84.175/24 brd 172.16.84.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::9200:4eff:feae:3989/64 scope link
       valid_lft forever preferred_lft forever

ip route:

ip route
default via 172.16.84.3 dev wlan0  proto dhcp
172.16.84.0/24 dev wlan0  proto kernel  scope link  src 172.16.84.175

resolv.conf

cat /etc/resolv.conf
# Generated by NetworkManager

Do you mean the NetworkManager front-end? It is not used when wicked.service is used. You need to use the NetworkManager.service instead if you want to configure/control the wireless device with NetworkManager.

Yes, you are right, I think my NetworkManager front-end is not seemed to be working.

I get below error: when I switch from wicked service to NetworkManager Service in YaST->Network Settings->Global Options->OK
YaST2 msg popup states:
Applet needed
NetworkManager is controlled by desktop applet
(KDE plasma widget and nm-applet for GNOME).
Be sure it’s running and if not, start it manually.

I can see plasma-nm5 is installed under s/w management, do not know why it is not starting/ should i miss anything with nm?

After posted above… I continued investigation, found below things:

Ran:

#rcnetwork restart
Job for NetworkManager.service failed. See "systemctl status NetworkManager.service" and "journalctl -xn" for details.

Output of “systemctl status NetworkManager.service” and “journalctl -xn”

#systemctl status NetworkManager.service
NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: failed (Result: start-limit) since Sun 2016-05-29 20:48:28 CST; 1min 40s ago
  Process: 5572 ExecStart=/usr/sbin/NetworkManager --no-daemon (code=exited, status=1/FAILURE)
 Main PID: 5572 (code=exited, status=1/FAILURE)

May 29 20:48:28 linuxosuse systemd[1]: NetworkManager.service start request repeated too quickly, refusing to start.
May 29 20:48:28 linuxosuse systemd[1]: Failed to start Network Manager.

#journalctl -xn
-- Logs begin at Sun 2016-05-08 17:38:41 CST, end at Sun 2016-05-29 20:48:28 CST. --
May 29 20:48:28 linuxosuse NetworkManager[5572]: <info>  NetworkManager (version 1.0.6) is starting...
May 29 20:48:28 linuxosuse NetworkManager[5572]: <info>  Read config: /etc/NetworkManager/NetworkManager.conf
May 29 20:48:28 linuxosuse NetworkManager[5572]: <error> [1464526108.025356] [nm-dbus-manager.c:826] nm_dbus_manager_start_service(): Could not
May 29 20:48:28 linuxosuse NetworkManager[5572]: <error> [1464526108.025404] [main.c:445] main(): failed to start the dbus service.
May 29 20:48:28 linuxosuse NetworkManager[5572]: <info>  exiting (error)
May 29 20:48:28 linuxosuse NetworkManager[5572]: this watch should have been invalidated
May 29 20:48:28 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
-- Subject: Unit NetworkManager-wait-online.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit NetworkManager-wait-online.service has failed.
-- 
-- The result is dependency.
May 29 20:48:28 linuxosuse systemd[1]: NetworkManager.service start request repeated too quickly, refusing to start.
May 29 20:48:28 linuxosuse systemd[1]: Failed to start Network Manager.
-- Subject: Unit NetworkManager.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit NetworkManager.service has failed.
-- 
-- The result is failed.
May 29 20:48:28 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
-- Subject: Unit NetworkManager-wait-online.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit NetworkManager-wait-online.service has failed.
-- 
-- The result is dependency.


#systemctl status NetworkManager-wait-online.service 
NetworkManager-wait-online.service - Network Manager Wait Online
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-wait-online.service; disabled)
   Active: inactive (dead)

May 29 20:42:01 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:42:01 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:42:01 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:42:02 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:48:26 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:48:27 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:48:27 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:48:27 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:48:28 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.
May 29 20:48:28 linuxosuse systemd[1]: Dependency failed for Network Manager Wait Online.

Tried to enable it:


#
#systemctl enable NetworkManager-wait-online.service
#

then tried to rcnetwork restart but did not do any good :frowning:


#rcnetwork restart
Job for NetworkManager.service failed. See "systemctl status NetworkManager.service" and "journalctl -xn" for details.


#service NetworkManager-wait-online start 
A dependency job for NetworkManager-wait-online.service failed. See 'journalctl -xn' for details.

Post:

cat /etc/sysconfig/network/config

I remember, read some where and i tried to alter NetworkManager.conf file as well as /etc/resolv.conf

# ls -lrt /etc/NetworkManager/NetworkManager.conf*
-rw-r--r-- 1 root root 34 Oct 25  2015 /etc/NetworkManager/NetworkManager.conf.bkp
-rw-r--r-- 1 root root 26 May 27 07:49 /etc/NetworkManager/NetworkManager.conf

# cat /etc/NetworkManager/NetworkManager.conf   
[main]
plugins=ifcfg-suse

# cat /etc/NetworkManager/NetworkManager.conf.bkp 
[main]
plugins=ifcfg-suse,keyfile

Now I tried with both files.

Here is /etc/sysconfig/network/config


# cat  /etc/sysconfig/network/config  
## Path:        Network/General
## Description: Global network configuration
#
# Note: 
# Most of the options can and should be overridden by per-interface
# settings in the ifcfg-* files.
#
# Note: The ISC dhclient started by the NetworkManager is not using any
# of these options -- NetworkManager is not using any sysconfig settings.
#


## Type:        yesno
## Default:     yes
# If ifup should check if an IPv4 address is already in use, set this to yes.
#
# Make sure that packet sockets (CONFIG_PACKET) are supported in the kernel,
# since this feature uses arp, which depends on that.
# Also be aware that this takes one second per interface; consider that when
# setting up a lot of interfaces. 
CHECK_DUPLICATE_IP="yes"


## Type:        list(auto,yes,no)
## Default:     auto
# If ifup should send a gratuitous ARP to inform the receivers about its
# IPv4 addresses. Default is to send gratuitous ARP, when duplicate IPv4
# address check is enabled and the check were sucessful.
#
# Make sure that packet sockets (CONFIG_PACKET) are supported in the kernel,
# since this feature uses arp, which depends on that.
SEND_GRATUITOUS_ARP="auto"


## Type:        yesno
## Default:     no
# Switch on/off debug messages for all network configuration stuff. If set to no
# most scripts can enable it locally with "-o debug".
DEBUG="no"


## Type:        integer
## Default:     30
#
# Some interfaces need some time to come up or come asynchronously via hotplug.
# WAIT_FOR_INTERFACES is a global wait for all mandatory interfaces in
# seconds. If empty no wait occurs.
#
WAIT_FOR_INTERFACES="30"


## Type:        yesno
## Default:     yes
#
# With this variable you can determine if the SuSEfirewall when enabled
# should get started when network interfaces are started.
FIREWALL="yes"


## Type:        int
## Default:     30
#
# When using NetworkManager you may define a timeout to wait for NetworkManager
# to connect in NetworkManager-wait-online.service.  Other network services
# may require the system to have a valid network setup in order to succeed.
#
# This variable has no effect if NetworkManager is disabled.
#
NM_ONLINE_TIMEOUT="30"


## Type:        string
## Default:     "dns-resolver dns-bind ntp-runtime nis"
#
# This variable defines the start order of netconfig modules installed
# in the /etc/netconfig.d/ directory.
#
# To disable the execution of a module, don't remove it from the list
# but prepend it with a minus sign, "-ntp-runtime".
#
NETCONFIG_MODULES_ORDER="dns-resolver dns-bind dns-dnsmasq nis ntp-runtime"


## Type:        yesno
## Default:     no
#
# Enable netconfig verbose reporting.
#
NETCONFIG_VERBOSE="no"


## Type:        yesno
## Default:     no
#
# This variable enables netconfig to always force a replace of modified
# files and automatically enables the -f | --force-replace parameter.
#
# The purpose is to use it as workaround, when some other tool trashes
# the files, e.g. /etc/resolv.conf and you observe messages like this
# in your logs on in "netconfig update" output:
# ATTENTION: You have modified /etc/resolv.conf. Leaving it untouched.
#
# Please do not forget to also report a bug as we have a system policy
# to use netconfig.
#
NETCONFIG_FORCE_REPLACE="no"


## Type:        string
## Default:     "auto"
#
# Defines the DNS merge policy as documented in netconfig(8) manual page.
# Set to "" to disable DNS configuration.
#
NETCONFIG_DNS_POLICY="auto"


## Type:        string(resolver,bind,dnsmasq,)
## Default:     "resolver"
#
# Defines the name of the DNS forwarder that has to be configured.
# Currently implemented are "bind", "dnsmasq" and "resolver", that
# causes to write the name server IP addresses to /etc/resolv.conf
# only (no forwarder). Empty string defaults to "resolver".
#
NETCONFIG_DNS_FORWARDER="resolver"


## Type:        yesno
## Default:     yes
#
# When enabled (default) in forwarder mode ("bind", "dnsmasq"),
# netconfig writes an explicit localhost nameserver address to the
# /etc/resolv.conf, followed by the policy resolved name server list
# as fallback for the moments, when the local forwarder is stopped.
#
NETCONFIG_DNS_FORWARDER_FALLBACK="yes"


## Type:        string
## Default:     ""
#
# List of DNS domain names used for host-name lookup.
# It is written as search list into the /etc/resolv.conf file.
#
NETCONFIG_DNS_STATIC_SEARCHLIST=""


## Type:        string
## Default:     ""
#
# List of DNS nameserver IP addresses to use for host-name lookup.
# When the NETCONFIG_DNS_FORWARDER variable is set to "resolver",
# the name servers are written directly to /etc/resolv.conf.
# Otherwise, the nameserver are written into a forwarder specific
# configuration file and the /etc/resolv.conf does not contain any
# nameservers causing the glibc to use the name server on the local
# machine (the forwarder). See also netconfig(8) manual page.
#
NETCONFIG_DNS_STATIC_SERVERS=""


## Type:        string
## Default:     "auto"
#
# Allows to specify a custom DNS service ranking list, that is which
# services provide preferred (e.g. vpn services), and which services
# fallback settings (e.g. avahi).
# Preferred service names have to be prepended with a "+", fallback
# service names with a "-" character. The special default value
# "auto" enables the current build-in service ranking list -- see the
# netconfig(8) manual page -- "none" or "" disables the ranking.
#
NETCONFIG_DNS_RANKING="auto"


## Type:        string
## Default:     ""
#
# Allows to specify options to use when writting the /etc/resolv.conf,
# for example:
#       "debug attempts:1 timeout:10"
# See resolv.conf(5) manual page for details.
#
NETCONFIG_DNS_RESOLVER_OPTIONS=""


## Type:        string
## Default:     ""
#
# Allows to specify a sortlist to use when writting the /etc/resolv.conf,
# for example:
#       130.155.160.0/255.255.240.0 130.155.0.0"
# See resolv.conf(5) manual page for details.
#
NETCONFIG_DNS_RESOLVER_SORTLIST=""


## Type:        string
## Default:     "auto"
#
# Defines the NTP merge policy as documented in netconfig(8) manual page.
# Set to "" to disable NTP configuration.
#
NETCONFIG_NTP_POLICY="auto"


## Type:        string
## Default:     ""
#
# List of NTP servers.
#
NETCONFIG_NTP_STATIC_SERVERS=""


## Type:        string
## Default:     "auto"
#
# Defines the NIS merge policy as documented in netconfig(8) manual page.
# Set to "" to disable NIS configuration.
#
NETCONFIG_NIS_POLICY="auto"


## Type:        string(yes,no,)
## Default:     "yes"
#
# Defines whether to set the default NIS domain. When enabled and no domain
# is provided dynamically or in static settings, /etc/defaultdomain is used.
# Valid values are:
#  - "no" or ""         netconfig does not set the domainname
#  - "yes"              netconfig sets the domainname according to the
#                       NIS policy using settings provided by the first
#                       iterface and service that provided it.
#  - "<interface name>" as yes, but only using settings from interface.
#
NETCONFIG_NIS_SETDOMAINNAME="yes"


## Type:        string
## Default:     ""
#
# Defines a default NIS domain.
#
# Further domain can be specified by adding a "_<number>" suffix to
# the NETCONFIG_NIS_STATIC_DOMAIN and NETCONFIG_NIS_STATIC_SERVERS
# variables, e.g.: NETCONFIG_NIS_STATIC_DOMAIN_1="second".
#
NETCONFIG_NIS_STATIC_DOMAIN=""


## Type:        string
## Default:     ""
#
# Defines a list of NIS servers for the default NIS domain or the
# domain specified with same "_<number>" suffix.
#
NETCONFIG_NIS_STATIC_SERVERS=""


## Type:        string
## Default:     ''
#
# Set this variable global variable to the ISO / IEC 3166 alpha2
# country code specifying the wireless regulatory domain to set.
# When not empty, ifup-wireless will be set in the wpa_supplicant
# config or via 'iw reg set' command.
#
# Note: This option requires a wpa driver supporting it, like
# the 'nl80211' driver used by default since openSUSE 11.3.
# When you notice problems with your hardware, please file a
# bug report and set e.g. WIRELESS_WPA_DRIVER='wext' (the old
# default driver) in the ifcfg file.
# See also "/usr/sbin/wpa_supplicant --help" for the list of
# available wpa drivers.
#
WIRELESS_REGULATORY_DOMAIN=''
## Type:        string
## Default:     ""
#
# Allows to specify a comma separated list of debug facilities used
# by wicked. Negated facility names can be prepended by a "-", e.g.:
#   "all,-events,-socket,-objectmodel,xpath,xml,dbus"
#
# When set, wicked debug level is automatically enabled.
# For a complete list of facility names, see: "wicked --debug help".
#
WICKED_DEBUG=""


## Type:        list("",error,warning,notice,info,debug,debug1,debug2,debug3)
## Default:     ""
#
# Allows to specify wicked debug level. Default level is "notice".
#
WICKED_LOG_LEVEL=""

Did a reboot, after reboot, rfkill showed again that wlan0 has been blocked as before.

→ Workaround/Hack: Create a file /etc/udev/rules.d/99-custom_rfkill.rules


# Unblock all RF kill switches for wifi
ACTION=="add", SUBSYSTEM=="rfkill", ATTR{name}=="*wifi*|phy?*", ATTR{type}=="wlan", RUN+="/bin/sh -c 'echo 1 > /sys/$env{DEVPATH}/state'

IMPORTANT: Everything from “ACTION” to “/sys/$env{DEVPATH}/state’” has to be put into one single line!

See if it is working (as root):


rfkill block wifi
rfkill list

→ Wifi should be blocked.


modprobe -rv ath9k # ass

modprobe -v ath9k

rfkill list

→ Wifi should be unblocked (and stay like that across reboots).

And for the other stuff, are wicked and NWM both running at the same time?


systemctl status NetworkManager wicked wickedd wpa_supplicant

ps auxww | grep -E 'wicked|Network|wpa|dhc'

NWM is setting anything (IP address, network mask, default gateway) except a nameserver, manually editing /etc/resolv.conf is also not a good idea.

Again, as root


rm /etc/resolv.conf*

netconfig -f update

The wohle issue sounds suspiciously a bit like “repaired the thing to death”, so cleaning up might be the next step before doing anything else.

Thank you Akoellh,

Recent reboots, rfkill list did not show any blocking.
So I did not go for rule set : **/etc/udev/rules.d/99-custom_rfkill.rules
**(I assume it is not needed now, let me know if it is necessary to do)
Even did not go for

 Code:
 modprobe -rv ath9k # ass

modprobe -v ath9k

rfkill list

linuxosuse:~ # modprobe -v ath
ath10k_core  ath10k_pci   ath3k        ath5k        ath6kl_core  ath6kl_sdio  ath6kl_usb   ath9k_htc    

linuxosuse:~ # modprobe -v ath9k_htc 
insmod /lib/modules/4.1.12-1-default/kernel/drivers/net/wireless/ath/ath9k/ath9k_htc.ko 
linuxosuse:~ # 


So far it was not sure, why even after ip is getting assigned and i can even login to the router., but only internet was not accessible.
Thank you :slight_smile: it is resolved now by your suggestion below

Again, as root

 Code:
 rm /etc/resolv.conf*

netconfig -f update

Now I am left without NM in system stray. I need to work out now how to bring back NM back in system stray.

linuxosuse:~ # systemctl status NetworkManager wicked wickedd wpa_supplicant
NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; disabled)
   Active: inactive (dead)


wicked.service - wicked managed network interfaces
   Loaded: loaded (/usr/lib/systemd/system/wicked.service; enabled)
   Active: active (exited) since Thu 2016-06-02 22:44:12 CST; 36min ago
  Process: 1030 ExecStart=/usr/sbin/wicked --systemd ifup all (code=exited, status=0/SUCCESS)
 Main PID: 1030 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/wicked.service

Jun 02 22:44:12 linuxosuse wicked[1030]: lo              up
Jun 02 22:44:12 linuxosuse wicked[1030]: eth0            setup-in-progress
Jun 02 22:44:12 linuxosuse wicked[1030]: wlan0           up

wickedd.service - wicked network management service daemon
   Loaded: loaded (/usr/lib/systemd/system/wickedd.service; static)
   Active: active (running) since Thu 2016-06-02 22:43:42 CST; 37min ago
 Main PID: 1023 (wickedd)
   CGroup: /system.slice/wickedd.service
           └─1023 /usr/sbin/wickedd --systemd --foreground

Jun 02 22:43:42 linuxosuse wickedd[1023]: unable to translate eap protocol AKA
Jun 02 22:43:42 linuxosuse wickedd[1023]: unable to translate eap protocol AKA'
Jun 02 22:43:42 linuxosuse wickedd[1023]: unable to translate eap protocol FAST
Jun 02 22:43:44 linuxosuse wickedd[1023]: wlan0: Notified neighbours about IP address 172.16.84.175

wpa_supplicant.service - WPA Supplicant daemon
   Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; enabled)
   Active: active (running) since Thu 2016-06-02 22:43:34 CST; 37min ago
 Main PID: 922 (wpa_supplicant)
   CGroup: /system.slice/wpa_supplicant.service
           └─922 /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log

Jun 02 22:43:42 linuxosuse wpa_supplicant[922]: ioctl[SIOCSIWENCODEEXT]: Invalid argument
Jun 02 22:43:42 linuxosuse wpa_supplicant[922]: ioctl[SIOCSIWENCODEEXT]: Invalid argument
Jun 02 22:43:43 linuxosuse wpa_supplicant[922]: ioctl[SIOCSIWFREQ]: Device or resource busy
linuxosuse:~ # 

linuxosuse:~ # ps auxww | grep -E 'wicked|Network|wpa|dhc'
root       922  0.0  0.1  30652  5888 ?        Ss   22:43   0:00 /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log
root      1016  0.0  0.1  29480  5020 ?        SLs  22:43   0:00 /usr/lib/wicked/bin/wickedd-dhcp6 --systemd --foreground
root      1017  0.0  0.1  29480  5080 ?        SLs  22:43   0:00 /usr/lib/wicked/bin/wickedd-dhcp4 --systemd --foreground
root      1018  0.0  0.1  29480  4812 ?        SLs  22:43   0:00 /usr/lib/wicked/bin/wickedd-auto4 --systemd --foreground
root      1023  0.0  0.1  29604  5120 ?        SLs  22:43   0:00 /usr/sbin/wickedd --systemd --foreground
root      1028  0.0  0.1  29632  5156 ?        SLs  22:43   0:00 /usr/sbin/wickedd-nanny --systemd --foreground
root      3000  0.0  0.0   9248  1560 pts/0    S+   23:23   0:00 grep -i -E wicked|Network|wpa|dhc
linuxosuse:~ # 

Let me select “NetworkManager Service” in Yast->Network settings->Global Options
and go for a fresh reboot…

When I select NM Service:

experienced below sequence of things:

I get below error: when I switch from wicked service to NetworkManager Service in YaST->Network Settings->Global Options->OK

a YaST2 msg popup states:

Applet needed

NetworkManager is controlled by desktop applet
(KDE plasma widget and nm-applet for GNOME).
Be sure it's running and if not, start it manually.


While saving it finishes with popup again saying:

Error

No network running

When I go and check ip

linuxosuse:~ # ip a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether f0:bf:97:1a:e6:ec brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 90:00:4e:ae:39:89 brd ff:ff:ff:ff:ff:ff
linuxosuse:~ #



linuxosuse:~ # ps auxww | grep -E 'wicked|Network|wpa|dhc'
root       916  0.0  0.0  30520  3352 ?        Ss   23:38   0:00 /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log
root      1004  0.0  0.3 403596 13664 ?        Ssl  23:39   0:00 /usr/sbin/NetworkManager --no-daemon
root      2078  0.0  0.0   9248  1564 pts/2    S+   23:41   0:00 grep -i -E wicked|Network|wpa|dhc
linuxosuse:~ # 

linuxosuse:~ # systemctl status NetworkManager wicked wickedd wpa_supplicant
NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled)
   Active: active (running) since Thu 2016-06-02 23:39:09 CST; 2min 46s ago
 Main PID: 1004 (NetworkManager)
   CGroup: /system.slice/NetworkManager.service
           └─1004 /usr/sbin/NetworkManager --no-daemon

Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  (wlan0): new 802.11 WiFi device (carrier: UNKNOWN, driver: 'ath9k', ifindex: 3)
Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  (wlan0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  (eth0): new Ethernet device (carrier: OFF, driver: 'sky2', ifindex: 2)
Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  (eth0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  keyfile: add connection in-memory (1950c52c-3ae4-4c03-9026-82cf8b99246d,"Wir...ion 1")
Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  (eth0): created default wired connection 'Wired connection 1'
Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  wpa_supplicant running
Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  use BlueZ version 5
Jun 02 23:39:10 linuxosuse NetworkManager[1004]: <info>  ModemManager available in the bus
Jun 02 23:39:15 linuxosuse NetworkManager[1004]: <info>  startup complete

wicked.service - wicked managed network interfaces
   Loaded: loaded (/usr/lib/systemd/system/wicked.service; disabled)
   Active: inactive (dead)


wickedd.service - wicked network management service daemon
   Loaded: loaded (/usr/lib/systemd/system/wickedd.service; static)
   Active: inactive (dead)


wpa_supplicant.service - WPA Supplicant daemon
   Loaded: loaded (/usr/lib/systemd/system/wpa_supplicant.service; enabled)
   Active: active (running) since Thu 2016-06-02 23:38:59 CST; 2min 58s ago
 Main PID: 916 (wpa_supplicant)
   CGroup: /system.slice/wpa_supplicant.service
           └─916 /usr/sbin/wpa_supplicant -c /etc/wpa_supplicant/wpa_supplicant.conf -u -f /var/log/wpa_supplicant.log

Hint: Some lines were ellipsized, use -l to show in full.
linuxosuse:~ # 

No IP or internet…

When I open Yast->network Settings to select Wicked Services
getting this popup

Warning

Network is currently handled by NetworkManager
or completely disabled. YaST is unable to configure some options.

Then I selected Wicked service, rfkill unblock wifi, rebooted and posted this msg (through wifi only)

So something wrong with NM that needs to be fixed :frowning:

Any suggestions? Shall I reinstall plasma-nm5 or something?

The ‘Network-Manager-gnome’ package provides nm-applet (NM front-end) if using Gnome. For KDE, the ‘plasma-nm5’ package is required.

Good explanatory posts here:
https://forums.opensuse.org/showthread.php/487268-Can-t-find-nm-applet-or-something-similar-to-use-NetworkManger-with-GUI-in-IceWm?p=2559512#post2559512
https://forums.opensuse.org/showthread.php/502490-Where-is-KDE-NetworkManager-plasmoid?p=2675751#post2675751

I tried your latest commands and found that I had 2 wireless devices listed with both blocked. One device was the Intel card installed in the HP laptop and the other was the D-link DWA-140. As a test, I removed the Intel card since it did not work. When I restarted the laptop, the LED in the DWA-140 began to blink. I used Opensuse’s network manager to specify the SSID and security code and the wireless connection worked perfectly.

Thanks so much for your help! I don’t know why two wireless devices would not work together but I’m not going to look a gift horse in the mouth.

Thanks again.

Ken

hello all,

its me again, after the last post, i’ve undergone lot of things

I tried uninstall 4to5 of palasma-nm5 packages in Yast :wink: after reboot its gone, i broke kde it seems. I got blank screen only. i tired to login rescue modes, recovery mode, boot from installer USB, renamed .kde5 etc., (learnt single user mode is best thing to use to get into systems shell).

almost i took backup of my stand alone software installations, before i was getting ready to reinstall OS. suddenly i thought to remove auto login which i read while come across some thing. i did it by going into single mode into yast into sysconfig edit etc… by doing that i got GUI. I went into iceWM. Then i found yast-pattens->KDE was missing some packages (because of what done before). I installed them I got KDE back working.
Then rfkill unblock wifi; rcnetwork restart to connect to wifi and posted this update from the same system like adventure :slight_smile:

i want to reinstall the system again soon. decided this not only because i lost network-manager - i want the system fresh & clean.
Thanks a lot for helps so far.

Sounds as if you like to live dangerously… but having fun learning anyway! :smiley: