AR242x wireless working (part 1)

Hello all,

I am a first time OpenSUSE user, but not a first time Linux user and just wanted to share a little info and a few articles that didn’t work and then what finally worked for me.
First of all I just want to say I’m not trying to imply that this procedure (well my procedure) will work for anyone, just trying to share.
My system info: Toshiba L305D-S5881, I just bought this and love it. Putting OpenSUSE on it completes my triple boot agenda.
Wireless is AR242x Atheros wireless built in.

Ok, What did not work…

  1. The sticky…

This sticky gives some info on how to go thru and discover what model card you have, gives the impression it will tell you where else to go for driver info but does not.
Don’t get me wrong the info is good, but look else where for more info on which driver to use.

  1. Atheros madwifi - openSUSE

Although this did not work, it helped me get the madwifi repo info installed into yast repo list and showed me how to edit.
The version installed did not work, no matter how many reboots and reinstalls I did.

  1. Acer Ferrari 5000 wireless configuration openSUSE 11.0 - howto solve the Atheros Communications Inc. AR242x problems ath5k phy0: failed to wakeup the MAC Chip

Again did not work, but gave some info on how and why to blacklist the ath5k driver that gets installed and does not work.
I found he had the same exact error I was getting, but gave no indication why the error was occurring, at least that I understood…(I suspect the device rev was too new for the driver, but that’s my opinion, only)

read on to part 2…

Now part2…
This finally worked and I am typing this with my newly connected AR242x Wireless connection to my Linksys wireless router.

First I had to gather info (like the sticky says!) and determine which direction to go:

lspci -v abbreviated list because I don’t want to paste the entire exhaustive pci info list, just the Atheros stuff

05:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

So my other Linux install is Ubuntu x86_64 (and this OpenSUSE is as well) and remember having had some of the exact same problems with that install (installed drivers didn’t work) oh btw, this is an AMD Turion 64 x2 system, ATI graphics, WIFI certified(what the heck does that mean!)
This article helped a lot!!
How To:MadWifi Support for AR2425 (AR5007EG) on 64bit Ubuntu !!! - Ubuntu Forums

Ahh, yes the savior post for me!! I used the info of this post to go and get the source version indicated, compiled, and installed…voila! it just worked.

so using that I proceed in this direction:

  1. remove all previous versions of madwifi and the corresponding kernel driver file. (I did this in the yast gui and don’t have a screen shot) just filter for madwifi, and then click on the installed button, pretty easy.
    Also remove ndiswrapper (I never liked this anyway, tried and have never been able to get it to work with the windows drivers)

  2. setup the system to get ready to dnload and compile the source
    installed this: (if you’ve compiled from source before you already have this, this was a new install so I didn’t)

yast2 --install kernel-source kernel-syms gcc make
  1. remove and blacklist the ath5k module
rmmod ath5k

add this line to the end of /etc/modprobe.d/blacklist

blacklist ath5k


  1. remove all the modules relating to atheros and wireless (not permanent, just making sure they are not used for now)

lsmod |grep ath
lsmod |grep wlan
lsmod |grep 802

rmmod on the result of each of these.

  1. go get this madwifi snapshot extract it to a working dir madwifi-hal-

cd to the nice newly unpacked snapshot and…

make clean
make install

I don’t pretend to even guess how to troubleshoot this if it doesn’t work…but it did, I’m golden!

ok so now I have this in my /lib/modules/
(the file list)

total 1628
drwxr-xr-x 2 root root   4096 Sep 20 22:21 .
drwxr-xr-x 6 root root   4096 Sep 20 22:24 ..
-rw-r--r-- 1 root root 415791 Sep 20 22:21 ath_hal.ko
-rw-r--r-- 1 root root 458846 Sep 20 22:21 ath_pci.ko
-rw-r--r-- 1 root root  30487 Sep 20 22:21 ath_rate_amrr.ko
-rw-r--r-- 1 root root  41958 Sep 20 22:21 ath_rate_minstrel.ko
-rw-r--r-- 1 root root  29478 Sep 20 22:21 ath_rate_onoe.ko
-rw-r--r-- 1 root root  38063 Sep 20 22:21 ath_rate_sample.ko
-rw-r--r-- 1 root root 376884 Sep 20 22:21 wlan.ko
-rw-r--r-- 1 root root  27360 Sep 20 22:21 wlan_acl.ko
-rw-r--r-- 1 root root  30413 Sep 20 22:21 wlan_ccmp.ko
-rw-r--r-- 1 root root  34580 Sep 20 22:21 wlan_scan_ap.ko
-rw-r--r-- 1 root root  41364 Sep 20 22:21 wlan_scan_sta.ko
-rw-r--r-- 1 root root  35175 Sep 20 22:21 wlan_tkip.ko
-rw-r--r-- 1 root root  28118 Sep 20 22:21 wlan_wep.ko
-rw-r--r-- 1 root root  21101 Sep 20 22:21 wlan_xauth.ko

  1. And now a reboot (this should load the newly compiled kernel drivers) and it did.
    lsmod reveals this:
lsmod |grep ath
ath_rate_sample        31232  1 
ath_pci               261952  0 
wlan                  266096  5 wlan_wep,wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal               346768  3 ath_rate_sample,ath_pci

UREKA!!! all the nice newly compiled modules loaded now

And to make sure I an actually using the newly compiled drivers I do a little spot checking with modinfo and reveal this:
They say I and using version: svn r3861 (the very snapshot I dnloaded and compiled)

filename:       /lib/modules/
license:        Dual BSD/GPL
version:        svn r3861

filename:       /lib/modules/
license:        Proprietary
version:        x86_64-elf:
description:    Atheros Hardware Access Layer (HAL)

filename:       /lib/modules/
license:        Dual BSD/GPL
version:        svn r3861

filename:       /lib/modules/
license:        Dual BSD/GPL
version:        svn r3861

modinfo <driver_name>
i.e. modinfo ath_pci

  1. Proceed to the Computer>Yast>Network Settings as normal
    You should now see an editable Wireless connection ready to be setup and configured.(previously it was not!)
    Again I have no screen shots of this, but its pretty easy, just make sure to use the ath_pci driver (NOT ath5k!!!) enter your ESSID where indicated and SHAZAM!!!

I GOT WIRELESS! I’ve rebooted several times since this procedure and it works every time.

ifconfig reveals this:

ifconfig -a
ath0      Link encap:Ethernet  HWaddr 00:22:68:CC:D8:19  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::222:68ff:fecc:d819/64 Scope:Link
          RX packets:49578 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19001 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:25580910 (24.3 Mb)  TX bytes:2707489 (2.5 Mb)

eth0      Link encap:Ethernet  HWaddr 00:1E:33:53:AF:1D  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:5120361568198 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:251 Base address:0x8000 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:86 errors:0 dropped:0 overruns:0 frame:0
          TX packets:86 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:8184 (7.9 Kb)  TX bytes:8184 (7.9 Kb)

wifi0     Link encap:UNSPEC  HWaddr 00-22-68-CC-D8-19-00-00-00-00-00-00-00-00-00-00  
          RX packets:753354 errors:0 dropped:0 overruns:0 frame:15064
          TX packets:35945 errors:47 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:280 
          RX bytes:78730027 (75.0 Mb)  TX bytes:4088099 (3.8 Mb)

and iwconfig this:

lo        no wireless extensions.

eth0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11g  ESSID:"daedalus"  Nickname:""
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:16:B6:D7:33:35   
          Bit Rate:6 Mb/s   Tx-Power:16 dBm   Sensitivity=1/1  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:<deleted by me!>   Security mode:restricted
          Power Management:off
          Link Quality=61/70  Signal level=-35 dBm  Noise level=-96 dBm
          Rx invalid nwid:333049  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Hope this helps someone out there, I tried to remember ALL the steps (I may have left one out).
Read the links and info for more help, if you need.

thank you,
it worked even for me.
opensuse 11.0
atheros wireless network adapter, AR5007EG

the installation required only 10 min!

my best greetings:)

I’m glad it helped friend!! enjoy and be safe!!;):wink:

I just wanted to thank you for saving me from going back to windows. I registered for the first to time to any of these forums to thank you. I appreciate the hairs you pulled out and then the time you took to write this for the rest of us.

I’m dealing with the AR5006 during the whole night, but your pose really do me a lot of favor. Thanks a lot!

Thanks a lot.
My wireless is now found and configured but my problem now is how to turn it on. The wireless switch does not respond when i press for it come on and so even though the device is found, thanks to madwifi, i cannot turn it on and use it. I use a Compaq Presario C700 and the wireless card is an AR242x model from Atheros.
Your assistance will be very much appreciated.

I have the same card and the best configuration for this I tried is: Start on boot and using network manager.
You can set this in YaST on 1st tab of network settings.

In the name of everything that is good and Holy, THANK YOU, THANK YOU, THANK YOU!!!. I have worked for days trying to get my wifi to work. It works great now, I feel like I just stuck one to microshaft :). Like so many other I just wanted to believe that Linux could actually work for me. You’ve made my day for a newbie on the road to learning.

I am using 64 bit openSuSE 11.0 on an Acer Aspire 4520. The wifi card is an Atheros AR242X.
Here are the rest of the specs for anyone else is wondering.
CPU=AMD Turion 64
Nvidia 7000M

I appreciate each and everyone’s comments that have used this procedure and am glad it helped!!

I’m now waiting impatiently for OpenSUSE 11.1!!

have a safe and happy holiday season!!

  1. go get this madwifi snapshot extract it to a working dir madwifi-hal-

cd to the nice newly unpacked snapshot and…


make clean
make install

I don’t pretend to even guess how to troubleshoot this if it doesn’t work…but it did, I’m golden!

In this mooment i got error *** KERNELCONF: /lib/modules/ does not exist.. Stop.

Works perfect on my acer aspire one


Toshiba Satellite AMD X2 64 2GB Ram
WiFi certified (means it complies with FCC radio regulations)
If not certified can’t legally be sold or used in US or CAN!
Realtech wireless Lan pci card seen in Linux as AR242x802.11abg wireless pci
kernel driver = atheros Ath5k_pci

  1. Turn on your wireless device
  2. make sure you check /etc/network, /etc/host, /etc/hosts.allow, /etc/hosts.deny, and /etc/fstab for any reference to ivp6 and remove it!
    ivp6 entries will result in both internet and printer failures with this driver and device.
  3. make sure you set up your router/firewall (mine is dlink 615) to operate WPA1 or WPA2 in fixed mode b or g
    mode (a) and combo modes (ab, abg, bg) will result in numerous >40% loss for some reason.
  4. Under Yast->Network->settings disable ivp6 as your very first step or you may find strange entries in the network config files as I had happen.
  5. Set-up your Yast network normally with essid & phraseword … detection etc…
  6. Internet should come up fine now.
  7. If slow internet trace back using linuxfan50 suggestions. Take note of %loss when you ping as this is indicative of excessive noise from walls and obstructions and incorrect rate setting using iwconfig.
    Simply re-orienting the pc-wireless can solve alot.
    In my case moved laptop 2 feet and turning it 15 degrees changed me from 5Mbit/sec to 54Mbit/sec and %loss from 65% down to 0% with router in basement and laptop upstairs at oposite end of house.

good luck:)