April snapshot gives btrfs error, triggers after suspend

Ladies and gents, we have a weird one. This post is primarily meant as a reference for others experiencing the same issue.

First off, HW specs and config:

  • HP Probook 650 G1 with Crucial MX100 512GB SSD, Intel based SATA controller
  • Dual boot witrh Windows 8 and openSUSE TW

After having some problems with software dependencies, I decided to reinstall with a fresh Tumbleweed. Made a backup of my data, downloaded the snapshot of the day and ran an install. Pretty much without any complications, right up to adding some software from third party repo’s.

It started with slowing down the system. Traced the problem to the btrfs root fs turning RO (yes, read only) and some daemons not being able to write logs. Kept getting a error message about “COMRESET” on the ata. Thought it was either the SSD or the partitions. I tried to reproduce the error, but it was not consistent. Finally I narrowed it down to a) either stressing the root (/) fs with activities by the root user or b) suspending the setup.

I decided not to troubleshoot too long, and reinstalled the whole setup. Rinse and repeat. Same issue even though the partitions were removed and did a fully automatic partition setup. Decided to try and repair the partitions, snapshot rollbacks, everything I could think of.

Eventually decided that it must be a hardware error. Ran an extended SMART check from a TW live CD, however no error! Did a BIOS-based check, and again no error. Tried a new setup with another partition order (same setup: root = btrfs, home=xfs and swap) and the error came back.

Last resort, downloaded the LEAP 42.2 ISO and installed that. NO PROBLEMS? Suspend works, root activities do not trigger any issues. Unfortunately all logging is gone obviously because of the reinstalls, so troubleshooting is quite a problem, but can anyone tell me what happened on the TW software set between end of March 2017 up till now (May 2) regarding:

a) the kernel (specifically drivers for SATA controllers and/or BTRFS)? I can remember that my last working kernel with TW was 4.9.x and the current is 4.10.x.
b) btrfs related daemons, such as fs housekeeping, logs, trim, etc?

Any ideas?